Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Xorg kommt plötzlich nicht mehr hoch, keine updates gefahren

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Software
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
pcAlko



Anmeldungsdatum: 14.05.2007
Beiträge: 70

BeitragVerfasst am: 10. Okt 2010 16:13   Titel: Xorg kommt plötzlich nicht mehr hoch, keine updates gefahren

Mein Bildschirm ist heute wieder einmal schawarz geblieben.
Habe Kubuntu 10.04 32 bit

Ist mir vor einigen Tagen schon mal passiert.
mit [Strg]+[Alt]+[F1] kann ich nicht mehr auf die Konsole umsteigen.
Habe mit der LiveCD neu gebooted
/dev/sda1 mit fsck überprüft
er hat mir ohne zu testen sofort gesagt "sauber"

unter /var/cache/apt/archive nachgesehen ob ich am Vortrag irgend ein update gefahren habe -> war nicht der Fall
Das system neu gebootet und hat funktioniert.
Das ist dann wieder einige Tage gut gegangen

heute habe ich wieder das Problem -> gleiches Szenario durchgeführt -> hat funktioniert
dann hab ich den Computer ausgeschaltet und bin Essen gegangen.

Als ich zurück gekommen bin hat der Computer wieder nicht gebootet
LiveCD eingelegt aber dieses mal beim ersten Auswahl Menü die letzte option "von Festplatte booten" genommen
und hat funktioniert.

Hat da irgend jemand eine Idee was da falsch gelaufen sein könnte?
in der /var/log/messages kann ich keinen Fehler entdecken

/var/log/Xorg.0.log hab ich leider nicht mehr
muss ich dann wenn es wieder auftritt mal mit der LiveCD sichern.

/var/log/Xorg.failsafe.log (Datum passt zum heutigen Tag)
Code:

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server i686 Ubuntu
Current Operating System: Linux KOAL-desktop 2.6.32-24-generic-pae #43-Ubuntu SMP Thu Sep 16 15:30:27 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-24-generic-pae root=UUID=93fadcb2-7609-4284-b997-34311751e806 ro quiet splash
Build Date: 21 July 2010  12:47:34PM
xorg-server 2:1.7.6-2ubuntu7.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.16.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(++) Log file: "/var/log/Xorg.failsafe.log", Time: Sun Oct 10 11:40:31 2010
(++) Using config file: "/etc/X11/xorg.conf.failsafe"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
(==) No Layout section.  Using the first Screen section.
(**) |-->Screen "Default Screen" (0)
(**) |   |-->Monitor "Configured Monitor"
(**) |   |-->Device "Configured Video Device"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
        Entry deleted from font path.
(==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
        built-ins
(==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
(II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
(II) Loader magic: 0x81f0e80
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 6.0
        X.Org XInput driver : 7.0
        X.Org Server Extension : 2.0
(--) using VT number 8


Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call


Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.failsafe.log" for additional information.

 ddxSigGiveUp: Closing log


früher war's bei linux doch immer dass beim Booten ein haufen Text herunter läuft
kann ich das bei kubuntu nicht irgendwie mit einem Tasten Druck wieder herstellen?


hat irgendjemand eine Idee wie ich das Problem beheben könnte?
will nicht nach jedem halben Jahr mein Kubuntu erneuern
bitte um Hilfeeeeeeeeeeeeeeeeeeeeeeeeeeeee!!!

Cool pcAlko
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 11. Okt 2010 3:48   Titel:

Boote mal mit der Option "vga=normal". Falls es beim Wechsel des Bildschirmmodus zu Problemen kommt, kann auch die Option "nomodeset" helfen. Damit schaltest du wieder auf die traditionelle Methode zurück, bei der X das selbst macht und daher als root laufen muss -- aber das tut es bei den aktuellen Distributionen ohnehin noch, es ist also noch kein Problem, "nomodeset" anzugeben.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

pcAlko



Anmeldungsdatum: 14.05.2007
Beiträge: 70

BeitragVerfasst am: 11. Okt 2010 19:05   Titel:

Hallo Janka,

heute hatte ich das Problem wieder nicht.

wie soll ich mit vga=normal booten wenn es keine /etc/X11/Xorg.conf mehr gibt?
wo soll ich das eintragen?

Danke für Deine Hilfe
Cool pcAlko
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 11. Okt 2010 22:59   Titel:

Im Bootlader-Prompt natürlich!

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

pcAlko



Anmeldungsdatum: 14.05.2007
Beiträge: 70

BeitragVerfasst am: 12. Okt 2010 17:19   Titel:

Janka hat folgendes geschrieben::
Im Bootlader-Prompt natürlich!

Janka


Kubuntu 10.04 zeigt mir aber nie ein boot-Prompt
(nehme an dass Du das meinst)
muss ich da irgendeine Taste drücken?
In diesem Fall wäre das aber nur einmalig Crying or Very sad
und wenn ich nicht mal auf die Konsole wechseln kann, wird die Taste ja auch nichts nützen.

kann ich das nicht in /etc/default/grub oder unter /etc/grub.d/ eintragen

Cool pcAlko
 
Benutzer-Profile anzeigen Private Nachricht senden

Janka



Anmeldungsdatum: 11.02.2006
Beiträge: 3569

BeitragVerfasst am: 12. Okt 2010 21:29   Titel:

Falls kein Bootlader-Prompt kommt, ist das vermutlich abgeschaltet worden (idiotisch). Dann gehören diese Optionen auf die Kernel-Kommandozeile in /boot/grub/menu.lst. Das ist zum reinen Ausprobieren natürlich erheblich unkomfortabler.

Janka
_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.
 
Benutzer-Profile anzeigen Private Nachricht senden

pcAlko



Anmeldungsdatum: 14.05.2007
Beiträge: 70

BeitragVerfasst am: 14. Okt 2010 17:50   Titel:

Hi Janka,

Ein Bootlader-Prompt gibt es doch schon lang nicht mehr bei Linux
zumindest ist es seit meiner Linux-Zeit (ubuntu 7.04) nicht mehr aktiviert.

Zur Zeit läufts bei mir wieder
Wenns wieder auftritt werd ich mich melden, Danke

/boot/grub/menu.lst gibt es seit 9.10 nicht mehr
grub2 hat zum ändern der Startreihenfolge /etc/default/grub
Du meinst sicher dass ich dort die Einträge machen soll.

könnte es nicht sein dass der Nvidia Treiber Probleme macht?
Wenn ich den deaktiviere läuft die Grafik-Karte ja auf dem nuovo Treiber.

Bei einem Freund, der das erste mal Linux versucht hat, Kubuntu 10.04
ist der Bildschirm schwarz geblieben nach dem aktivieren des Nvidia Treibers.
Dann hat er neu installiert.

Meld mich wieder wenn es neuigkeiten gibt.
Cool pcAlko
 
Benutzer-Profile anzeigen Private Nachricht senden

Mosca Bianca



Anmeldungsdatum: 08.02.2010
Beiträge: 18

BeitragVerfasst am: 14. Okt 2010 18:05   Titel:

Moin,

pcAlko hat folgendes geschrieben::
Ein Bootlader-Prompt gibt es doch schon lang nicht mehr bei Linux


also ich habe den noch, genauso wie die /boot/grub/menu.lst.

pcAlko hat folgendes geschrieben::
könnte es nicht sein dass der Nvidia Treiber Probleme macht?
Wenn ich den deaktiviere läuft die Grafik-Karte ja auf dem nuovo Treiber.


Habe ich das richtig verstanden, dass Du beide Treiber gleichzeitig installiert hast?
_________________
Gruß

Mosca Bianca
 
Benutzer-Profile anzeigen Private Nachricht senden

pcAlko



Anmeldungsdatum: 14.05.2007
Beiträge: 70

BeitragVerfasst am: 14. Okt 2010 20:14   Titel:

Hi,

Ich bin zwar kein Ubuntu Administrator aber unter dem Hardwere Front-End sind 3 Nvidia Treiber die Aktiviert werden können und nach der frischen Ubuntu Installation ist soviel ich weiß der nuovou Treiber aktiviert.
Also ist dieser Treiber wohl auch jetzt vorhanden, aber eben nicht aktiviert. Würde ich mal so sagen.

Cool pcAlko
 
Benutzer-Profile anzeigen Private Nachricht senden

pcAlko



Anmeldungsdatum: 14.05.2007
Beiträge: 70

BeitragVerfasst am: 18. Okt 2010 17:25   Titel:

Heute ist es wieder mal so weit,
der Bildschirm ist schwarz geblieben.

habe mit der liveCD gebootet und diesesmal die Xorg.0.log gesichert.
konnte jedoch keinen Fehler darin finden.

Dann hab ich am Ende der Datei /etc/default/grub eine Zeile mit vga=normal angehängt.
Den Computer runtergefahen.
Etwas gewartet
und neu gebootet.

dieses mal war wieder alles normal.

habe den unterschied von der Xorg.0.log gecheckt ...
bei der Version wo der Bildschirm nicht hoch gekommen war
hatte er mir nur am Ende
nach der Zeile '(II) No input driver/identifier specified (ignoring)'
Code:

(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) Power Button: Close
(II) UnloadModule: "evdev"
(II) Logitech Optical USB Mouse: Close
(II) UnloadModule: "evdev"
(II) AT Translated Set 2 keyboard: Close
(II) UnloadModule: "evdev"
(II) Macintosh mouse button emulation: Close
(II) UnloadModule: "evdev"
 ddxSigGiveUp: Closing log
angehängt.

eine Xorg.failsave.log hat er mir diesesmal aber nicht generiert.
melde mich wenns wieder mal schief läuft

im moment sieht es aus als ob das vga=normal funktioniert
Danke Janka

Cool pcAlko
 
Benutzer-Profile anzeigen Private Nachricht senden

pcAlko



Anmeldungsdatum: 14.05.2007
Beiträge: 70

BeitragVerfasst am: 24. Okt 2010 10:00   Titel:

wieder das gleich Problem, Bildschirm ist schwarz geblieben.
Er schreibt mir auch in Xorg.0.log.old wie ich später gesehen habe die gleichen Einträge wie in meinem letzten Post.

In der Zwischenzeit habe ich mir das aktuelle linuxUSER, wegen dem Artikel 'Bootsysteme(1)', besorgt
jetzt weiß ich auch dass ich zur kernel-Auswahl, wenn diese abgeschalten ist, komme
wenn ich beim boot-Vorgang die SHIFT-Taste drücke
dort könnte ich auch die Taste [E] für jeden Kernel drücken (grub2)
um zu den Boot-Parametern zu gelangen.
Wie mir Janka geraten hat könnte ich dort auch das vga=normal eintragen

Ich wollte aber zuvor mal sehen was passiert wenn ich nur einfach den Kernel auswähle.
Dann ist er mir normal hochgefahren.

Liegt dass jetzt wirklich beim Grafik-Treiber? Question

Cool pcAlko

%PS: 16:03 Uhr > soeben habe ich meinen Rechner neu gebootet
. dieses mal ist er mir wieder schwarz geblieben.
. habe dann bei der kernel-Auswahl vga=normal eingetragen
. shauen ob es dann beim nächsten mal (eventuell morgen)
. funktioniert.
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Software Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy