Alsa verliert Einstellungen immer wieder

Antworten
Nachricht
Autor
ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

Alsa verliert Einstellungen immer wieder

#1 Beitrag von ElBlues » 23. Okt 2010 14:34

Hi,

im alsamixer hat meine Soundkarte verschiedene Kanäle. Damit ich am richtigen Ausgang ein Signal bekomme, muss ich "S/PDIF 5" ausschalten und "S/PDIF 0" aktivieren - dann läuft alles erstklassig, inklusive Pass-Through.

Leider geht diese Einstellung nach jedem Neustart verloren, anschließend ist wieder nur "S/PDIF 5" aktiv. Wie kann ich das ändern? Oder gibt es eine Möglichkeit, in der .asoundrc zu vermerken, welche Kanäle an und welche aus sein sollen?
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 24. Okt 2010 11:23

Mach die Einstellung und danach

Code: Alles auswählen

# alsactl store
Dann speichert er die aktuellen Einstellungen in der Datei /etc/asound.state. Von dort kann man sie mit

Code: Alles auswählen

# alsactl restore
wieder laden. Probier aus ob das klappt, also danach nochmal verstellen und neu laden.

Bei einigen Distributionen werden diese beiden Befehle beim Hoch-/runterfahren oder am Beginn und am Ende der primären X11-Sitzung ausgeführt, aber vielleicht klappt das bei dir aus irgendeinem Grund nicht.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

#3 Beitrag von ElBlues » 26. Okt 2010 11:31

Funktioniert - danke!
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

Antworten