Keine zwei Monitore mehr nach Umstieg auf SUSE 11.3 KDE 4.4.4

Antworten
Nachricht
Autor
stimzuk
Beiträge: 59
Registriert: 26. Nov 2009 4:01

Keine zwei Monitore mehr nach Umstieg auf SUSE 11.3 KDE 4.4.4

#1 Beitrag von stimzuk » 12. Dez 2010 18:36

Hallo, ich habe mich endlich für einen Umstiieg von SUSE 11.1 / KDE3.5 auf SUSE 11.3 / KDE4.4.4 entschloasen und habe schon zu Beginn die ersten Probleme - fängt ja gut an. Vorher hatte ich 2 Monitore im Dual-Head Modus in Verwendung. Nachdem auch das Menü zum Grafikkarten-Einstellen aus YAST->Hardware verschwunden war hatte ich die EInstellungen endlich im KDE-Menü unter Systemeinstellungen gefunden. Dort werden mir beide Monitore VGA-0 (Verbunden) und DVI-0 (Verbunden) angezeigt aber in einer Klone-EInstellungen. Sobald ich mir den zweiten Monitor rechts oder links von VGA-0 verschiebe funktioniert das zwar, aber nur bis zum Abmelden. Wenn ich mich im System dann wieder neu anmelde sind beide Monitore wieder in der Klone-Einstellung. Ich verwende das RADEON Model RV280 5960. Kann mir da bitte jemand weiterhelfen?

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 12. Dez 2010 21:26

Diese Einstellungen werden jetzt einheitlich über RANDR durchgeführt. Das eigentliche Kontrollprogramm ist "xrandr", das andere sind GUIs dafür bzw. ahmen dessen Funktion nach.

Eigentlich sollte KDE4 sich die letzte Einstellung vor dem Abmelden merken und nach dem Wiederanmelden automatisch anwenden. Melde dich mal nur einfach ab, statt den Rechner runterzufahren. Evtl. speichert er die Einstellungen sonst nicht.

Ansonsten kannst du auch einen Befehl

Code: Alles auswählen

xrandr --output DVI-0 --right-of VGA-0 --auto
kurz vor das Ende (exec $WINDOWMANAGER) deiner ~/.xinitrc schreiben.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

stimzuk
Beiträge: 59
Registriert: 26. Nov 2009 4:01

#3 Beitrag von stimzuk » 17. Dez 2010 16:45

Hallo Janka, danke für den Tip der aber nur zur Hälfte funktioniert hat. MIt dem Kommando xrandr ......habe ich jetzt plötzlich zwei Bildschirme, aber ich habe keine ~/.xinitrc wo ich was reinschreiben könnte? Nach dem Abmelden habe ich das selbe Problem wie ich es Beschrieben hatte (siehe oben). Ich melde mich auch nur ab, ich fahre nicht herunter. Woher bekomme ich eine ~/.xinitrc? Ich habe im meinem Homeverzeichnis nur eine ~/.xinitrc.template gefunden??

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 17. Dez 2010 20:14

Benenne das Template um und füge die xrandr Zeile direkt vor dem "exec $WINDOWMANAGER" ein.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

stimzuk
Beiträge: 59
Registriert: 26. Nov 2009 4:01

#5 Beitrag von stimzuk » 17. Dez 2010 22:10

Punktlandung! hat funktioniert - vielen Dank!!!

Antworten