Probleme mit SUSE 11.3 Kernel 2.6.34-12 sourcen

Forum für Leute, die von anderen Systemen auf Linux gewechselt haben oder den Umstieg planen
Antworten
Nachricht
Autor
stimzuk
Beiträge: 59
Registriert: 26. Nov 2009 4:01

Probleme mit SUSE 11.3 Kernel 2.6.34-12 sourcen

#1 Beitrag von stimzuk » 09. Jan 2011 17:42

Hallo, ich habe SUSE11.3 / KDE 4.4.4 komplett neu installieren müssen und habe auch gleich aktualisiert. Jetzt zeigt mir der Arbeitsplatz die Kernelversion "Linux 2.6.34-1[b]2[/b]-default i686". Wieso ich jetzt die version 12 habe weiß ich nicht ich hatt vorher die Kernelversion "Linux 2.6.34-[b]7[/b]-default i686". Ich habe auch die officziellen Repos eingebunden auch das Repos für die Sourcen und dieses ist auch aktiv. Wenn ich versuche mit YAST die "kernel-source " zu aktualisieren wird mir aber immer die version [b]7[/b] heruntergeladen und nicht die [b]12[/b]! Als weiteren Hinweis gibt mir das Kommande "[i]rpm -qa | grep kernel[/i]" folgendes aus:
kernel-default-2.6.34-12.3.i586
kernel-devel-2.6.34.7-0.7.1.noarch
kernel-source-2.6.34.7-0.7.1.noarch
kernel-xen-devel-2.6.34.7-0.7.1.i586
kernel-firmware-20100617-2.2.noarch
kernel-desktop-devel-2.6.34.7-0.7.1.i586
kernel-default-devel-2.6.34.7-0.7.1.i586
kernel-syms-2.6.34.7-0.7.1.i586
kernel-pae-devel-2.6.34.7-0.7.1.i586
Wieso kann ich nicht die sourcen auf die kernelversion 2.6.34-1[b]2[/b] aktualisieren?
Wieso habe ich überhaupt zwei unterschiedliche Versionen auf dem System?[/list][/list]

stimzuk
Beiträge: 59
Registriert: 26. Nov 2009 4:01

#2 Beitrag von stimzuk » 09. Jan 2011 17:49

Nachdem obiger Text schwer lesbar ist weil BOLD und KURSIV scheionbar nicht funktioniert habe ich den Text nochmals geschrieben........

Hallo, ich habe SUSE11.3 / KDE 4.4.4 komplett neu installieren müssen und habe auch gleich aktualisiert. Jetzt zeigt mir der Arbeitsplatz die Kernelversion "Linux 2.6.34-12-default i686". Wieso ich jetzt die version 12 habe weiß ich nicht ich hatt vorher die Kernelversion "Linux 2.6.34-7-default i686". Ich habe auch die officziellen Repos eingebunden auch das Repos für die Sourcen und dieses ist auch aktiv. Wenn ich versuche mit YAST die "kernel-source " zu aktualisieren wird mir aber immer die version 7 heruntergeladen und nicht die 12!! Als weiteren Hinweis gibt mir das Kommando "rpm -qa | grep kerne]" folgendes aus:
kernel-default-2.6.34-12.3.i586
kernel-devel-2.6.34.7-0.7.1.noarch
kernel-source-2.6.34.7-0.7.1.noarch
kernel-xen-devel-2.6.34.7-0.7.1.i586
kernel-firmware-20100617-2.2.noarch
kernel-desktop-devel-2.6.34.7-0.7.1.i586
kernel-default-devel-2.6.34.7-0.7.1.i586
kernel-syms-2.6.34.7-0.7.1.i586
kernel-pae-devel-2.6.34.7-0.7.1.i586
Wieso kann ich nicht die sourcen auf die kernelversion 2.6.34-12 aktualisieren?
Wieso habe ich überhaupt zwei unterschiedliche Versionen auf dem System?

lotharb
Beiträge: 411
Registriert: 10. Feb 2002 21:39
Wohnort: Heroldsberg (ERH)

#3 Beitrag von lotharb » 09. Jan 2011 22:02

Hallo stimzuk

Bei mir sieht's doch ein wenig übersichtlicher aus.

Code: Alles auswählen

lothar@linux:~> rpm -qa | grep kernel
kernel-desktop-2.6.34.7-0.7.1.i586
lothar@linux:~> uname -a
Linux linux 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 i686 i686 i386 GNU/Linux
lothar@linux:~>
Ich will dir in deine Pläne nicht hineinreden, aber brauchst du wirklich die developer- und Quelltextpakete?

Wenn die Versionen verschiedener Pakete in deinem System scheinbar kreuz und quer gehen: Starte doch mal YaST; Software installieren oder löschen, markiere ein Paket und klicke unten rechts "Versionen" an. Du kannst dann probehalber das eine oder andere Paket zum Löschen vormerken und schauen, ob YaST darüber meckert.

Grüße an die schöne blaue Donau
Lothar

Benutzeravatar
Janka
Beiträge: 3573
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 09. Jan 2011 22:18

Du hast aus dem Update-Repository einen neueren Kernel bekommen, weil es da inzwischen Sicherheitsupdates gab. Die devel-Pakete enthalten nur include-Dateien, die haben sich dadurch wohl nicht geändert. Dass es für die Quellen kein Update gibt mag daran liegen, dass du das Source-Repository aus dem Netz nicht eingebunden hast.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Antworten