Bildschirmschoner geht nicht immer an

Antworten
Nachricht
Autor
gallius

Bildschirmschoner geht nicht immer an

#1 Beitrag von gallius » 02. Mär 2011 8:25

Hallo Leute,

gibt es eine Mehode oder Softwarelösung, den Bildschirmschoner mit Sicherheit angehen zu lassen?

Es besteht die Vorgabe, das ein Bildschirmschoner nach bestimmter Zeit Userinaktivität sicher anspringt.
Laufen aber unter KDE bestimmte Anwendungen, so geht der standart-Bildschirmschoner nicht an.
(unclutter ist nicht installiert)

Gruß
gallius

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 02. Mär 2011 13:30

Welche Anwendungen verhindern bei dir angeblich den Start der Bildschirmsperre?

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

gallius

schoner geht nicht an

#3 Beitrag von gallius » 02. Mär 2011 17:02

Der VMware Player verhindert den Screensaverstart.

gruß
gallius

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 03. Mär 2011 9:54

Prüfe mal bitte in einer Konsole mit

Code: Alles auswählen

$ xset q|grep -A2 'Screen Saver'
vor und nach dem Start des vmware-players, ob dieser nicht einfach den Bildschirmschoner beim Start abschaltet und bei Beendigung wieder einschaltet. "timeout: 0" heißt abgeschaltet. Wenn ja, kann man ein Wrapper-Skript um den vmware-player drumherum basteln, das den Bildschirmschoner sofort nach dem Aufruf des vmware-players wieder einschaltet.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

gallus

screensaver

#5 Beitrag von gallus » 03. Mär 2011 10:10

Hallo,

das sihet dann so aus:

Code: Alles auswählen

:~> xset q|grep -A2 'Screen Saver'
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  40    cycle:  600
Die Konstellation ist schon ein bißchen ungewöhnlich:
SLED mit VMwareplayer, darauf ein XP. Unter diesem läuft NX-NoMachine zu einem andern SLED. In diesem Fall springt der Schoner nicht :(

Gruß
gallius

PS
Die /var/lib/kde-profiles/default/share/config/kdesktoprc hat u.a. folgendn Eintrag:

Code: Alles auswählen

[ScreenSaver][$i]
ActionBottomLeft=0
ActionBottomRight=0
ActionTopLeft=2
ActionTopRight=1
Enabled=true
Lock=true
LockGrace=15000
Priority=1
Saver=KClock.desktop
Timeout=300

Antworten