Pro-Linux.de

Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 18. Nov 2018 17:27

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 
Autor Nachricht
BeitragVerfasst: 17. Mai 2011 23:55 
Offline

Registriert: 17. Mai 2011 23:01
Beiträge: 2
Hi,

ich habe mir ein verschlüsseltes gentoo Linux nach der folgenden Anleitung von dieser Seite aufgesetzt:
http://www.pro-linux.de/artikel/2/528/1 ... elung.html
(bzw. der entscheidende Teil mit dem init Skript: http://www.pro-linux.de/artikel/2/528/1 ... elung.html)

Allerdings habe ich ein kleine Anpassung vorgenommen. Auf meinem USB-Stick habe ich 2 Partitionen eingerichtet. Die 1. Partition ist als FAT32 zum Datenaustausch mit der Familie eingerichtet, die 2. ist die verschlüsselte ext3 Partition mit dem Key-File. Ich habe daher das init Skript angepasst, indem ich alle "/dev/sdb1" Angaben durch "/dev/sdb2" ersetzt habe. Es sieht also am Anfang folgendermaßen aus:
Code:
while [ ! -e /dev/sdb2 ] ; do
 cd /dev
 /bin/busybox mknod sdb2 b 8 17
 chmod 666 sdb1
done
while [ ! -e /dev/mapper/usbstick ] ; do
 sleep 2
 cryptsetup -c aes-lrw-benbi:sha512 -s 384 luksOpen /dev/sdb2 usbstick
done
Wenn ich nun normal (von Festplatte) boote, wird der USB-Stick zwar als sdb bezeichnet, aber ich erhalte immer die Fehlermeldung:
Device /dev/sdb2 is not a valid LUKS device.

Ein Test der 2. USB-Stick Partition, nach dem booten von der gentoo-Install-CD, kann diese jedoch problemlos entcrypten und mounten, daher denke ich, dass mein init Skript fehlerhaft ist.
Kann mir jemand weiter helfen?

Gruß
Fabian


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 18. Mai 2011 22:07 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Stimmen denn die Parameter für Cryptsetup, insbesondere der Schlüsseltyp und die Länge?

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 19. Mai 2011 21:11 
Offline

Registriert: 17. Mai 2011 23:01
Beiträge: 2
Ja, es sind die "gleichen" Parameter, die ich beim Erstellen des crypto-devices verwendet habe:
Code:
cryptsetup -vyc aes-lrw-benbi:sha512 -s 384 luksFormat /dev/sdb2
wobei v - verbose und y - doppelte Passworteingabe bei der Erstellung sind.

Ich habe auch getestet, ob das init-Skript ohne Angabe der Schlüsselparameter läuft, da ja cryptsetup diese Angaben aus dem Header zu dem crypto-container entnehmen kann. Aber auch das funktionert nicht.

Ich habe jetzt aber aber mal ein -v im init Skript ergänzt. Nun bekomme ich zusätzlich folgende Meldung:
Code:
Command failed with code 22: Device /dev/sdb2 is not a valid LUKS device.
google hat mir dazu nur einen Treffer dazu ausgegeben:
http://www.google.de/search?q=busybox+% ... b33745015c
Das ist ein Chat Protokoll. Hier wird erwähnt, dass es ein Problem gibt, falls die 2. Partition klein ist.
Habe leider keine Zeit das am Wochenende auszuprobieren. Werde also nächste Woche mal testen, ob es funktioniert, wenn ich die 2. Partition größer mache und werde mich danach noch mal melden.

Gruß und Dank
Fabian


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 3 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de