Serielle Schnittstelle

Antworten
Nachricht
Autor
ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

Serielle Schnittstelle

#1 Beitrag von ElBlues » 05. Okt 2011 21:03

Hi,

ich habe noch eines dieser seltenen Mainboards mit einer seriellen Schnittstelle, leider kriege ich sie unter Fedora nicht zum laufen.

Das Gerät /dev/ttyS0 existiert, Programme wie minicom können die Schnittstelle erfolgreich öffnen und Daten dort hin senden, leider klappt es mit dem Empfangen nicht. Um Probleme mit dem Kabel auszuschließen habe ich einfach mal einen Loopback-Stecker angeschlossen, der Pin 2 und 3 brückt - keine Änderung, es wird nix empfangen.

/dev/ttyS0 ist les- und schreibbar und es ist ein Modul serio_raw geladen.

Wo könnte das Problem noch liegen?
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 06. Okt 2011 12:10

serio_raw.ko ist der Treiber für die PS/2-Schnittstelle. Das Modul für die RS232-Schnittstelle heißt serial.ko. Aber das ist vermutlich ohnehin fest einkompiliert. Dass du auf /dev/ttyS0 zugreifen kannst spricht dafür, dass die Schnittstelle da ist.

Guck mal mit setserial -a /dev/ttyS0 nach den Einstellungen.Fehlt z.B. der IRQ, kann man nichts empfangen. Außerdem mal mehr als ein Zeichen ausgeben und dann "dmesg" beobachten, ob da Fehlermeldungen kommen.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

DH
Beiträge: 103
Registriert: 19. Feb 2006 13:31

#3 Beitrag von DH » 06. Okt 2011 19:54

Hallo ElBlues,

leg mal einen agetty-Prozess auf die Schnittstelle.

Ich hab' ein Progrämmchen geschrieben, das eine Relaiskarte ansteuert, allerdings unter SuSE 11.2/11.4.

Wenn Du magst, schicke ich Dir den Code.

Gruß - Dieter

ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

#4 Beitrag von ElBlues » 08. Okt 2011 14:28

Hm, ein IRQ ist da, das Senden von größeren Datenmengen führt auch nicht zu irgend welchen Meldungen - scheint also, als wäre die Schnittstelle hardwaremäßig im Popo.

> leg mal einen agetty-Prozess auf die Schnittstelle.

Da passiert nicht viel, agetty kommt nach ein paar Sekunden einfach unverrichteter Dinge zurück...
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

DH
Beiträge: 103
Registriert: 19. Feb 2006 13:31

#5 Beitrag von DH » 08. Okt 2011 17:49

agetty mit action 'respawn' in /etc/inittab aufrufen.

Danach bekommst Du aussagefähige 'dmesg'-Ausgaben.

ElBlues
Beiträge: 127
Registriert: 25. Mär 2008 12:50
Kontaktdaten:

#6 Beitrag von ElBlues » 13. Okt 2011 10:51

So, Ende der Experimente, die Schnittstelle ist wohl wirklich kaputt - wenn ich genau das Gleiche mit exakt der gleichen Software auf einem /dev/ttyUSB0 probiere, dann läuft alles problemlos.
http://www.kaufkauf.net - nie wieder Einkäufe vergessen!

Antworten