Drucker will jedesmal neu

Antworten
Nachricht
Autor
Der J

Drucker will jedesmal neu

#1 Beitrag von Der J » 08. Dez 2011 10:43

Hallo Leite,

wahrscheinlich gehört diese Anfrage in die Rubrik Software/System , ich vermute ein USB-Problem.

Mein Laserdrucker - Samsung ML2010- welcher noch niemals Probleme macht, spinnt nun.
Der Drucker muss nun _nach_ dem PC-Start eingeschaltet werden und manchmal auch zwischendurch beim Druck mehrerer einzeln in Auftrag gegebenen Seiten ein-/ausgeschaltet werden. Ein Restart von CUPS bring nichts.
Alternativ kann man auch den USB-Anschluss ab- und wieder anstecken. Der Drucker ist direkt und nicht über ein USB-Hub angeschlossen.

Für zündende Ideen bin ich dankbar ;)

LG
Der J

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 08. Dez 2011 12:08

Was hast du geändert? Schau mal direkt nach so einem Problem mit dmesg im Kernel-Log nach, ob du dort nicht verdächtige Meldungen, z.B. zu dem von dir vermuteten USB-Problem, findest.
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Der J

Update

#3 Beitrag von Der J » 08. Dez 2011 14:51

Naja, ich habe auf eine andere Version per Neu-Installation (Mandriva 2010.0 -> 2010.2) gewechselt...

Der J

dmesg

#4 Beitrag von Der J » 08. Dez 2011 15:34

Also "system-config-printer" poppt eine meldung auf dem Bildschirm "Drucker ggf. nicht angeschlossen."
Die dmesg bringt noch

Code: Alles auswählen

usb 4-2: usbfs: interface 0 claimed by usbfs while 'gcm-apply' sets config #1
Aber ob das damit etwas zu tun hat?

In usbview wird der Drucker angezeigt.

Code: Alles auswählen

Aber erst nach ein-/ausschalten kommt dann bei dmesg:
usb 5-1: USB disconnect, address 2
usb 5-1: new full speed USB device using uhci_hcd and address 3
usb 5-1: New USB device found, idVendor=04e8, idProduct=326c
usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 5-1: Product: Samsung ML-2010
usb 5-1: Manufacturer: Samsung
usb 5-1: SerialNumber: 4421BKCP409183Y.
und der im System gelöschte Drucker wird wieder eingestellt.

Gruss
Der J

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#5 Beitrag von Janka » 08. Dez 2011 20:47

Das ist leider nicht aussagekräftig genug. Warte mal auf den Fehler, bei dem der Drucker mittendrin weg ist.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Der J

Hardware

#6 Beitrag von Der J » 08. Dez 2011 21:00

Es war wirklich die Hardware als Ursache :lol:
Die Klappe zum Tonerschacht war nicht richtig zu :roll:

Danke für alle Überlegungen :)

Gruß
Der J

Der J

Korrektur

#7 Beitrag von Der J » 26. Dez 2011 12:12

Frohe Weihnachten,

ich ziehe meinen Beitrag - über diesen - zurück.
Es war Zufall, das der Drucker nach Schließen der Klappen wieder lief.

Ist ist nach wie vor so:
Nach PC-Start muss man den Drucker aus-/einschalten oder den USB-Anschluß aus-/einstecken. Sonst wird der Druckauftrag nicht transportiert.
Das geht eine Weile gut, dann wird der Druckauftrag in's Nirvana transportiert, und man muss wier ein/aus.....

Ich habe das Problem nun mit einem kleinen Netzwerk Druckserver gelöst.

Als Ursache sehe ich einen verpfuschten 2.6.33.7-Kernel von Mandriva 2010.2 an.
Bei Mandriva 2010.0 gab es keinerlei Probleme, eine super Distribution.

Verhärtet hat sich der Verdacht, das mein USB-Scanner nun genauso spinnt....

Frohe Weihnachten
Der J

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#8 Beitrag von Janka » 26. Dez 2011 13:38

Dann vermute ich, dass der USB-Host in deinem Rechner dem Treiber Überstrom meldet, obwohl gar kein Überstromfall vorliegt. Bei den neueren Hosttreibern wird dieses Flag der Hardware ausgewertet, und dann die USB-Verbindung gekappt.

Da du keine passenden dmesg-Meldungen gepostet hast, kann ich das aber nur vermuten.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Der J

keine Meldung

#9 Beitrag von Der J » 26. Dez 2011 15:18

Es gibt leider keine auswertbare Meldung.

Im Fall 1, also vor dem ersten Disconnect, erscheint nichts,- es ist nur einfach kein Drucker da - erst danach, aber dann als erfolgreiche Einbindung und dann geht's eine Weile.

Im Fall 2 gibt's auch keinen Fehler, diesmal geht der Druckauftrag aber 'raus ... kommt aber nicht an. Das habe ich mit Onboard-USB und externer USB-Karte probiert.

Antworten