Dateisystem nur lesbar

Antworten
Nachricht
Autor
Albert

Dateisystem nur lesbar

#1 Beitrag von Albert » 02. Jun 2013 9:45

ich habe leider was blödes gemacht,dabei sollte es eine Lösung sein.
Nun nach dem Befehl systemctl mask tmp.mount kann ich nicht mehr einloggen.

Als Fehlermedlung kommt folgendes :

mktemp: konnte die Datei nicht mittels Schablone m/tmp/serverauth.XXXXXX erstellen: Das Dateisystem ist nur lesbar
xauth: file does not exists
xauth: unable to link authory file, use -n

Was kann ich jetzt tun???

Albert

Albert

#2 Beitrag von Albert » 02. Jun 2013 13:24

Ich habe eine Lösung gefunden,die aber nicht optimal ist :

Mittels Befehl via root : mount -o remount,rw /dev/sda3 wird dann das Dateisystem wieder rw.
Dies geschieht aber nur,wenn ich jedesmal mich einloggen will diesen Befehl ausführe.

Um das aber festzulegen,brauche ich von Euich Hilfe,wie ich das abstellen kann ,ohne daß ich den Befehl ausführen soll...

Albert

Benutzeravatar
Phoenix
Beiträge: 582
Registriert: 12. Okt 2008 17:02
Wohnort: HSK

#3 Beitrag von Phoenix » 02. Jun 2013 16:26

Hallo Albert,

ich kann spontan den Befehl nicht zusammenbauen; aber suche doch mal nach dem Linuxwerkzeug chmod. Spontan bei mir probiere ich meist erst, mit dem Krusader im root- Modus (rotes Schaltfeld) die entsprechende Datei bzw. das Verzeichnis aufzusuchen und mit den Werkzeugen im unteren Teil bzw. per Rechtsklick ("Eigenschaften") zu bearbeiten. Chmod und für andere Fälle chown als Root (su ...) sind aber in schwierigen Fällen wirksamer.

Viel Erfolg

Phoenix
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0

Benutzeravatar
Janka
Beiträge: 3573
Registriert: 11. Feb 2006 19:10

#4 Beitrag von Janka » 02. Jun 2013 19:25

Nein, das ist Unsinn. Der Fehler ist, dass das *Dateisystem* als ganzes auf Readonly gesetzt ist. Diese Einstellung überstimmt alle Einstellungen für einzelne Dateien in diesem Dateisystem. Die Lösung ist selbstverständlich, die ausmaskierte tmp.mount-Unit wieder einzuschalten, das geht mit naheliegend mit

Code: Alles auswählen

# systemctl unmask tmp.mount
Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Antworten