Verbindungsversuch über falsche Netzwerkschnittstelle mit CentOS 6.5

Antworten
Nachricht
Autor
Harstad

Verbindungsversuch über falsche Netzwerkschnittstelle mit CentOS 6.5

#1 Beitrag von Harstad » 31. Jan 2014 20:05

Hi,

ich habe hier auf meinem Laptop ein seltsames Problem. WLAN ist 192.168.1.117 und soll sich über 192.168.1.1 (den Router) nach draußen verbinden. An eth0 ist nichts angeschlossen (wird aber ab und zu mal verwendet), und hat die IP 192.168.2.117.

Wenn ich den Rechner zum ersten mal starte, gehen keinerlei Internetverbindungen, es sieht so aus, als ob eth0 as Weg nach draußen verwendet wird. Wenn ich das Netzwerk dann einmal deaktiviere und wieder aktiviere, dann geht alles.

Was kann das sein? Was müsste ich für die WLAN-Schnittstelle konfigurieren, dass immer diese für Internetverbindungen verwendet wird?

brum

netzwerk tool

#2 Beitrag von brum » 01. Feb 2014 11:48

Moin,

dann ist das von dir verwendete Netzwerktool nicht sehr clever :(.

Ich verwende das vom KDE und kann problemlos zwischen WLAN, LAN und UMTS hin- und her switchen, ohne das es einen weiteren Eingriffs bedarf.

Benutzeravatar
hastifranki
Beiträge: 259
Registriert: 06. Mai 2006 19:58

#3 Beitrag von hastifranki » 01. Feb 2014 13:21

Ist bei CentOS 6.5 Gnome 2 die Standardoberfläche?

Fest kann man das auch in

/etc/network/interfaces

konfigurieren, wenn es das Netzwerktool nicht kann:

http://wiki.ubuntuusers.de/interfaces

VG
Frank

Harstad

#4 Beitrag von Harstad » 01. Feb 2014 20:25

Ja, es ist Gnome 2 und der NetworkManager. Gibt es nicht eine Möglichkeit, eine Route für alle Verbindungen außer ins 192.168.2.x-er Netzwerk zu setzen?

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#5 Beitrag von Janka » 02. Feb 2014 0:29

Aus der Erinnerung: Setze im Networkmanager bei der Ethernetschnittstelle unter dem Reiter IPv4 und der dortigen Drop-Down-Seite "Routen" den Haken bei "Nur für Quellen dieser Verbindung verwenden". Dann wird die Defaultroute nicht geändert, wenn die Ethernetschnitte aktiviert wird.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

Antworten