Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 12. Nov 2018 23:06

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 5 Beiträge ] 
Autor Nachricht
 Betreff des Beitrags: Autostart Suse 12.3
BeitragVerfasst: 08. Apr 2014 15:52 
Offline

Registriert: 09. Sep 2004 15:00
Beiträge: 176
Hallo zusammen,
ich hab mir per RPM-Paket xrdp installiert. Funktioniert! Wenn ich die /etc/xrdp/xrdp.sh starte, kann man eine Verbindung aufbauen.
Ich würde das jetzt aber gern so einrichten, dass das Script schon beim Systemstart mit gestartet wird.
Dazu hab ich unter /etc/init.d/rc3.d und /etc/init.d/rc5.d Links angelegt mit:
Code:
linux-9l6t:/etc/init.d/rc5.d # ln -s ../../xrdp/xrdp.sh K60xrdp
linux-9l6t:/etc/init.d/rc5.d # ln -s ../../xrdp/xrdp.sh S60xrdp
Funktioniert aber leider nicht. Nach dem booten muss das Script erst wieder von Hand gestartet werden, damit man RDP nutzen kann.
Was mach ich falsch?
Danke.
Gruß.
ottto


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 08. Apr 2014 16:49 
Bei Suse gibt es doch Yast als Werkzeug, da kannst du das einstellen. Schau mal nach Runlevel, da sollte das drinstehen. Wenn du mit Yast nicht zurecht kommst meld dich wieder und sag was du gemacht hast.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09. Apr 2014 17:05 
Offline
Benutzeravatar

Registriert: 06. Mai 2006 19:58
Beiträge: 252
Hallo,

eigentlich benutze ich Debian. Systemd schon mal anzusehen, kann aber nicht schaden.

# systemctl enable xrdp

könnte funktionieren.

Ab 8:10 wird es für deinen Fall interessant:

http://www.youtube.com/watch?v=zjtZEFwKiZY

Viele Grüße
Frank


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09. Apr 2014 17:40 
Offline

Registriert: 09. Sep 2004 15:00
Beiträge: 176
Zitat:
Bei Suse gibt es doch Yast als Werkzeug, da kannst du das einstellen. Schau mal nach Runlevel, da sollte das drinstehen. Wenn du mit Yast nicht zurecht kommst meld dich wieder und sag was du gemacht hast.
Hallo,
im yast unter SystemServices (Runlevel) ist kein RDP oder xrdp zu finden.
Danke.
Gruß.
ottto


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 09. Apr 2014 17:47 
Offline

Registriert: 09. Sep 2004 15:00
Beiträge: 176
Zitat:
Hallo,

eigentlich benutze ich Debian. Systemd schon mal anzusehen, kann aber nicht schaden.

# systemctl enable xrdp
Hallo Frank,
systemctl bringt nichts.
Danke.
Gruß.
ottto
Code:
linux-9l6t:~ # systemctl enable xrdp
Failed to issue method call: No such file or directory
linux-9l6t:~ #


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 5 Beiträge ] 

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de