Pro-Linux

Pro-Linux Diskussions- und Hilfeforum
Aktuelle Zeit: 15. Nov 2018 23:45

Alle Zeiten sind UTC+01:00




Ein neues Thema erstellen  Auf das Thema antworten  [ 33 Beiträge ]  Gehe zu Seite 1 2 3 Nächste
Autor Nachricht
 Betreff des Beitrags: opensuse 13.1
BeitragVerfasst: 10. Mai 2014 17:30 
hallo

habe mal eine frage wie man während des bootens in den level 3 kommt?
habe da ein par probs mit dem xserver.
Aber ich kann da nirgens etwas eingeben wo ist da der trick?


mfg


Nach oben
   
 Betreff des Beitrags: schau ins google land
BeitragVerfasst: 10. Mai 2014 20:07 
moin,

guck hier, fragen wirst du da beantwortet bekommen:

http://www.if-not-true-then-false.com/2 ... -on-grub2/
https://access.redhat.com/site/document ... evels.html

halof


Nach oben
   
 Betreff des Beitrags: opensuse 13.1
BeitragVerfasst: 11. Mai 2014 13:51 
hallo

der tipp war gold richtig aber gut versteckt. ich kann booten aber er bleibt hängen nach dem bootprozess.
Der Runlevel 1 und 3 laufen und kann alles machen auch root nur der xerver will nicht und im level 5 bleibt der xserver mit samt kernel stehen.
Nach der Kernellog sind da doch einige Fehler.
Code:
xdm[3882]: [b]GLib:ERROR:gutf8.c:1736:_g_utf8_make_valid: assertion failed: (g_utf8_validate (string->str, -1, NULL))
2014-05-10T16&#58;59&#58;12.095981+02&#58;00 linux killproc&#58; killproc&#58; Usage&#58;#012    killproc &#91;-v&#93; &#91;-q&#93; &#91;-L&#93; &#91;-g|-G&#93; &#91;-N&#93; &#91;-p pid_file&#93; &#91;-i ingnore_file&#93; \#012        &#91;-c root&#93; &#91;-t<sec>&#93; &#91;-SIG&#93; /full/path/to/executable#012    killproc -l&#91;/b&#93;
2014-05-10T16&#58;59&#58;12.105801+02&#58;00 linux xdm&#91;3941&#93;&#58; ..done
2014-05-10T16&#58;59&#58;40.644982+02&#58;00 linux systemd&#91;1&#93;&#58; Starting Stop Read-Ahead Data Collection...
2014-05-10T16&#58;59&#58;40.718214+02&#58;00 linux systemd&#91;1&#93;&#58; Started Stop Read-Ahead Data Collection.
2014-05-10T17&#58;00&#58;02.772769+02&#58;00 linux /usr/sbin/cron&#91;3956&#93;&#58; pam_unix&#40;crond&#58;session&#41;&#58; session opened for user root by &#40;uid=0&#41;
2014-05-10T17&#58;00&#58;02.801441+02&#58;00 linux systemd&#91;1&#93;&#58; Starting user-0.slice.
2014-05-10T17&#58;00&#58;02.806250+02&#58;00 linux systemd&#91;1&#93;&#58; Created slice user-0.slice.
2014-05-10T17&#58;00&#58;02.826575+02&#58;00 linux systemd&#91;1&#93;&#58; Starting User Manager for 0...
2014-05-10T17&#58;00&#58;02.848289+02&#58;00 linux systemd&#91;1&#93;&#58; Starting Session 1 of user root.
2014-05-10T17&#58;00&#58;02.856549+02&#58;00 linux systemd&#91;1&#93;&#58; Started Session 1 of user root.
2014-05-10T17&#58;00&#58;02.873444+02&#58;00 linux systemd&#58; pam_unix&#40;systemd-user&#58;session&#41;&#58; session opened for user root by &#40;uid=0&#41;
2014-05-10T17&#58;00&#58;02.923411+02&#58;00 linux systemd&#91;3957&#93;&#58; &#91;b&#93;Failed to open private bus connection&#58; Failed to connect to socket /run/user/0/dbus/user_bus_socket&#58; No such file or directory&#91;/b&#93;
2014-05-10T17&#58;00&#58;03.081272+02&#58;00 linux systemd&#91;3957&#93;&#58; Stopped target Printer.
2014-05-10T17&#58;00&#58;03.082986+02&#58;00 linux systemd&#91;3957&#93;&#58; Stopped target Sound Card.
2014-05-10T17&#58;00&#58;03.091548+02&#58;00 linux systemd&#91;3957&#93;&#58; Starting Default.
2014-05-10T17&#58;00&#58;03.095796+02&#58;00 linux systemd&#91;3957&#93;&#58; Reached target Default.
2014-05-10T17&#58;00&#58;03.101634+02&#58;00 linux systemd&#91;3957&#93;&#58; Startup finished in 183ms.
2014-05-10T17&#58;00&#58;03.105852+02&#58;00 linux systemd&#91;1&#93;&#58; Started User Manager for 0.
2014-05-10T17&#58;03&#58;01.803221+02&#58;00 linux /USR/SBIN/CRON&#91;3956&#93;&#58; pam_unix&#40;crond&#58;session&#41;&#58; session closed for user root

bin mir nicht sicher woran das liegen könnte oder wie ich das beheben kann


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 11. Mai 2014 17:13 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Das ist nicht der Xserver, sondern der xdm, der da spotzt. Und der Kernel bleibt auch nicht stehen, keine Ahnung woran du das gesehen haben willst. Bei einem Panic blinken die Tastatur-LEDs und das Log in der Konsole gibt Hinweise, woran es lag - außerdem funktioniert der MagicSysRq dann auch noch.

Guck mal ob "startx" geht. Wenn ja, ist es wirklich nur der xdm.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags: opensuse 13.1
BeitragVerfasst: 11. Mai 2014 20:01 
also ich habe in den level 3 gewechselt unter root startx eingegeben und nichts nur ein schwarzer bildschirm.
die Fehler in massages sind die selben.
Der kernel selber ist zwar noch da aber die Tastatur nimmt keine Eingaben mehr an womit ich dann nur noch ausschalten kann.
Laut google suche habe ich gelesen das systemd und der kernel 3.11 eventuell probleme haben was die kompatibilität angeht. Kann aber nicht sagen in wie weit dies eine rolle spielt.
Mit zypper patch habe ich ein update schon eingespielt was aber auch nichts daran geändert hat.
Zumindest liegt es nicht an dem xserver. Welche Optionen gibt es noch?


Nach oben
   
 Betreff des Beitrags: ist hardware oder software ok?
BeitragVerfasst: 11. Mai 2014 20:24 
Moin.

komische Sache, darum mal die Fragen: Sind Software und Hardware in Ordnung?

Ist die Suse-Install-DVD selbst gezogen und gebrannt?
Dann sollte der Datenträger geprüft werden. Entweder mit md5-Vergleichsumme oder auch,wenn bei der Installation die Option "Datenträger prüfen" angeboten wird.

Ist die Hardware in Ordnung?
Dann teste es am besten mal mit einer Live-CD, z.B. Knoppix o.ö.

VG


Nach oben
   
 Betreff des Beitrags: Re: opensuse 13.1
BeitragVerfasst: 11. Mai 2014 21:46 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Zitat:
also ich habe in den level 3 gewechselt unter root startx eingegeben und nichts nur ein schwarzer bildschirm.
die Fehler in massages sind die selben.
Der kernel selber ist zwar noch da aber die Tastatur nimmt keine Eingaben mehr an womit ich dann nur noch ausschalten kann.
Strg+Alt+F1 sollte dich in eine Konsole bringen.
Zitat:
Laut google suche habe ich gelesen das systemd und der kernel 3.11 eventuell probleme
Dann boote den Kernel 3.10, den die SuSE ebenfalls installiert.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags: opensuse 13.1
BeitragVerfasst: 12. Mai 2014 12:02 
hallo

erstmal bedanke ich mich für euere Antworten. Was die opensuse angeht ich habe sie selbst gezogen und gebrannt geprüft mit md5 beim Download und nach dem Brennen.
Werde aber die dvd nochmals genauer prüfen. Es ist nicht ausgeschlossen das der Brenner mist gebaut hat was aber nicht umbedingt mit der md5 checksumme methode auffällt. Villeicht hätte ich besser die sha-Variante verwenden sollen die ist wesentlich genauer. Meine Hardware ist soweit OK habe zur Zeit ne 7.2 Knoppix laufen
Als erstes werde ich mir aber den 3.10 Kernel einbauen mal sehen ob an der geschichte was drann ist das der 3.11 sich nicht mit der systemd vertägt.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12. Mai 2014 15:01 
Offline
Benutzeravatar

Registriert: 11. Feb 2006 19:10
Beiträge: 3569
Brauchst du nicht bauen, musst du nur im Grub auswählen.

Janka

_________________
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 12. Mai 2014 16:58 
Offline
Benutzeravatar

Registriert: 12. Okt 2008 17:02
Beiträge: 582
Wohnort: HSK
Hallo linuxman,

kennst Du mehr als 2 Möglichkeiten, mit md5sum & Co. Tests auszuführen?

-> http://www.linux-forum.de/wiki/index.ph ... vergleiche

Vielleicht ist ja auch was für Dich dabei?

Viel Erfolg

Phoenix

_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0


Nach oben
   
 Betreff des Beitrags: opensuse 13.1
BeitragVerfasst: 13. Mai 2014 19:32 
hallo allerseits

die DVD der opensuse habe ich nochmal durchlaufen lassen und überprüft ob sich doch schäden eingeschlichen haben - alles ok soweit.
Knoppix 7.2.0 läuft sauber und stabil.
Leider hat auch das booten mit dem 3.10 Kernel nichts gebracht. Hab sogar ne neue DVD von der opensuse 13.1 gebrannt mit der Windows-Mohre meiner Schwester auch das keine änderung nach der installation gleicher Fehler an der gleichen Stelle.
Dies kann nur ein Bug in der opensuse selbst sein.
Welche log-files ausser xorg.0.log und massages gibt es noch die aufschluss geben könnten wo da der Schuh drückt?
Was passiert wenn der xserver nicht läd oder kurz darauf abstürtzt?
ich denke mal der kernel würde es überleben aber alles andere wäre weg kein bild, keine Maus und keine Tastatur und genau so sieht es aus den es geht nicht eine taste mehr und somit auch keine Tastenkombi wie strg+alt+F1 .
Ich muss mir selber eingestehen das ich mit meinem Latein am ende bin.
Seit 14 Jahren habe ich schon linux und ich habe oft schon Kernels und auch xservers konfiguriert aber das habe ich noch nicht erlebt.
Irgenwo muss es eine Stelle geben wo man sehen kann was ds los ist hab sie nur noch nicht gefunden.


Gruß

RMH


Nach oben
   
 Betreff des Beitrags: hhhmmm
BeitragVerfasst: 13. Mai 2014 20:19 
Moin, irgendwas gefällt möglicherweise dem XDM an deiner Hardware nicht?

Aber bei der Erstinstallation hast Du den KDE starten können?

Das wäre komisch. Mein Workaround wäre, den Loginmangader xdm gegen einen anderen auszutauschen. Da gibts nicht viele, vielleicht slim:
http://software.opensuse.org/search?q=s ... rted=false

Oder probierst mal ein Kubuntu?

Viel Erfolg ;-)


Nach oben
   
 Betreff des Beitrags: oder
BeitragVerfasst: 13. Mai 2014 20:26 
Oder probierst mal etwas nicht alltägliches, den Debian-Clone Siduction.
Ist eine Rolling-Release-Distrie ... ;-)


Nach oben
   
 Betreff des Beitrags: opensuse 13.1
BeitragVerfasst: 14. Mai 2014 11:01 
hallo

die erste inst. von der 13.1 war mit kde und es war das selbe.
Denke auch das es villeicht an meiner Hardware liegen könnte. Die opensuse 12.2 war noch OK . Möglicherweise unterstützt opensuse nicht mehr alles. Das hätte aber schon wärend der Installation auffallen müssen und da war alles im grünen Bereich.
Aber Du hast recht ich werde mir mal die aktuelle debian ausprobieren.Wenn dann der Fehler weg ist, dann lags an der opensuse.
sobald ich die debian habe werde ich mich hier nochmal melden und erfolg/misserfolg posten.


mfg


Nach oben
   
 Betreff des Beitrags:
BeitragVerfasst: 14. Mai 2014 16:29 
Offline
Benutzeravatar

Registriert: 12. Okt 2008 17:02
Beiträge: 582
Wohnort: HSK
Hallo linuxman,

aus meiner Erfahrung ist es ungewöhnlich, daß openSUSE nicht mit Hardware umgehen kann. Aber sei es wie es ist...

Hättest Du Interesse, die aktuelle, kaum in den Foren bekannte Liveversion von openSUSE 13.1 zu probieren? Installierst Du die auf DVD, ist das eine gewöhnliche Liveversion. Installierst Du die auf USB- Stick oder Platte, wird die selbsttätig zum persistenten Livesystem.

Downloadquelle: http://software.opensuse.org/131/en
(openSUSE-13.1-KDE-Live-x86_64.iso/openSUSE-13.1-KDE-Live-x86_64.iso )
etwas Info:
http://www.opensuse-forum.de/wow-kde-li ... 10083-f56/

Liveversionen haben oftmals kaum Schwierigkeiten mit exotischer Hardware...

Viel Spaß

Phoenix

_________________
Für kein Tier tut man so viel wie für die Katz!

3 BS aktuell
openSUSE 13.1-64 KDE auf Hauptplatte
Mageia 4-64 KDE auf USB- Platte
openSUSE 13.1-64 KDE auf USB- Platte mit Starter BodhiLinux 1.4.0


Nach oben
   
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen  Auf das Thema antworten  [ 33 Beiträge ]  Gehe zu Seite 1 2 3 Nächste

Alle Zeiten sind UTC+01:00


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste


Sie dürfen keine neuen Themen in diesem Forum erstellen.
Sie dürfen keine Antworten zu Themen in diesem Forum erstellen.
Sie dürfen Ihre Beiträge in diesem Forum nicht ändern.
Sie dürfen Ihre Beiträge in diesem Forum nicht löschen.
Sie dürfen keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Limited
Deutsche Übersetzung durch phpBB.de