CentOS 7 Gnome und Tastar Layout

Software besorgen und anwenden
Antworten
Nachricht
Autor
martin123

CentOS 7 Gnome und Tastar Layout

#1 Beitrag von martin123 » 22. Jul 2014 16:10

Hallo Leute,

verzweifle gerade am CentOS 7. Habe Tastatur auf US gestellt, da funktioniert sie zu 95%.
Ist aber ein Gemisch von Englisch und Deutsch ohne Pipe ...

Auf DE sieht diese so aus

Bild

Wer findet das noch lustig

Mit config keyboerd und language und X11 xorg.conf.d 00 kezboard conf habe ich schon gespielt.

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#2 Beitrag von Janka » 22. Jul 2014 19:55

Ist das überhaupt das passende Tastaturmodell? Das gewählte Layout ist 104-Key, in Deutschland sind aber 102-Key (ohne Windows-Tasten) und 105-Key üblich, jeweils mit der zusätzlichen Taste neben der linken Shift und der senkrechten Return-Taste.

Zudem hast du nicht geschrieben, was du eigentlich erreichen willst: Ein funktionsfähiges deutsches Layout oder ein US-Layout.

Janka
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

martin123

config

#3 Beitrag von martin123 » 22. Jul 2014 21:01

Ja, ich bin auch kein Gnome-Fan, aber da das nicht unbedigt hauptsächlich ein Desktop-PC werden soll,
so habe ich den vorausgewählten Desktop bei der Installation genommen.

Im Gnome gibt es einzelne Konfigurationstools, wie config-setting-keyboard.für die Tastatur.
Da wählt man "Deutsch" und "Deutschland" .. und das war es gewesen.
Dann kann man sich noch das schreckliche Layout anzeigen lassen, ohne Korrekturmöglichkeit.

Einstellungen wie wie sonst üblich, sämtliche Tastaturhersteller und Tastenbelegung, das ist wohl bei dem Gnome unter dem Tisch gefallen.
Es gibt nun zwar unter xorg.conf.d/ eine Keyboard-Datei, diese kann man ja editieren, brachte aber nix. Morgen knalle ich KDE drauf ....

Vielleicht liegt der Fehler auch woanders?
Die Installation ist auf einem CentOS 6 auf einer Virtualbox-VM mit CentOS 7, welche ich über VNC 300m weiter auf Win7 wiedergebe.
Morgen mal auf dem Weg machen ...

VG martin123

martin123

kde + rd

#4 Beitrag von martin123 » 23. Jul 2014 15:57

Mit KDE geht das Keyboard bis auf die Einschränkung der AltGR-Lage. Muss dann eben das | manuel einkopieren. Was noch einigermaßen träge, aber fehlerfrei funktioniert ist den Server von Virtualbox anzuwerfen und mittels RDP daraufzugehen.

VG martin123[/b]

Benutzeravatar
Janka
Beiträge: 3581
Registriert: 11. Feb 2006 19:10

#5 Beitrag von Janka » 23. Jul 2014 23:34

Eine VM verbindet Tastatur und Maus nicht roh als Geräte, sondern schon gekocht als Events, sonst könnten sich VM und Host die Tastatur und Maus nicht teilen. Du musst daher in der VM-Konfiguration das richtige Tastaturmodell einstellen.
Ich vertonne Spam immer in /dev/dsp statt /dev/null.
Ich mag die Schreie.

marin123

keyboardvm

#6 Beitrag von marin123 » 24. Jul 2014 10:28

Moin,

habe da wenig Plan, aber schon einiges probiert:

Code: Alles auswählen

VBoxManage controlvm NAME keyboardscancode HEX
Es ergab keine Änderung oder es kam Murks heraus.

Per RDP über Virtualbox gibts keine Schwierigkeit

Gruß martin123

Antworten