Login
Newsletter
Werbung

Thema: Ubuntu 8.04 LTS freigegeben

1 Kommentar(e) || Alle anzeigen ||  RSS || Kommentieren
Kommentare von Lesern spiegeln nicht unbedingt die Meinung der Redaktion wider.
0
Von sd07 am So, 27. April 2008 um 14:27 #
Bei meiner alten Geforce4MX hat der Ubuntu-Treiber zwar funktioniert (im Sinne von "3D-Einschalten").
Aber z.B. Torcs ruckelte beim Spielen merklich (ohne xorg.conf).
Jetzt benutze ich wieder eine "vernünftige" xorg.conf, seitdem ruckelt nichts mehr.

Mir gehen aber mittlerweile diese 3D-Treiber-Probleme - in qualitativer wie auch lizenzrechtlicher Hinsicht - so langsam auf die Nerven:

1. NVidia-Karten erhalten zur Zeit nur proprietäre 3D-Treiber von NVidia, ansonsten gibt es nur diesen absichtlich "kastrierten" 2D-nv-Treiber von Xorg, der aber ebenfalls von NVidia stammt und auch nur von NVIdia gewartet wird und - so sieht es aus - auch nur von NVidia selbst gewartet werden kann. Der nv-Treiber ist zwar "frei", aber anscheinend kann man als Nicht-NVidia-Angestellter trotz vorliegender Sourcen nicht nachvollziehen, was er eigentlich "macht".
Da bin ich selbst unter BeOS/Haiku mit deren nativen und freien 2D/3D-Treiber besser dran.
Nouveau-Treiber sind bei Ubuntu scheinbar nicht mit dabei. Leider.

2. 3D unter Linux ist im Hinblick auf die meisten freien Treiber mittlerweile generell bedroht, da die GLX-Lizenz unfrei ist:
Siehe z.B.:
http://fedoraproject.org/wiki/Licensing
unter "Bad Licenses": "SGI GLX Public License"

3. Die freien ATI-Treiber enthalten zudem Microcode von ATI (r128 und radeon), von dem man zum einen nicht genau wissen kann, was er wirklich "macht" (obwohl die Sourcen vorliegen), und der zum anderen anscheinend ohne wirklich gültige Lizenz benutzt wird:
http://wiki.debian.org/KernelFirmwareLicensing
contains "CCE [bzw. CP] microcode (from ATI)"
"The problem here is that we don't have a copyright notice or license from ATI to go with the microcode "from ATI". (If ATI has transferred the copyright to Precision Insight or VA Linux, all would be well, but there's no reason to believe that they did, and plenty of reason to believe that they didn't.)"

Wenn das so weiter geht, reicht bald wieder meine alte Matrox-Millennium-Karte mit 4MB für die unter Linux "bestmögliche Performance": in tollem 2D.

Pro-Linux
Traut euch!
Neue Nachrichten
Werbung