Login
Newsletter
Werbung

Thema: Neue NVIDIA-Treiber für Linux

63 Kommentar(e) || Alle anzeigen ||  RSS || Kommentieren
Kommentare von Lesern spiegeln nicht unbedingt die Meinung der Redaktion wider.
0
Von Anonymous am Fr, 19. Januar 2001 um 22:11 #
ENDLICH!
ich hoffe das es zumindest besser ist als und nicht so wie der 0.9-5 'Fehler'.
ausserdem:
TwinView Unterstüzung?
Träume ich? :)
Hoffentlich ist es auch was gescheits und meine freunde versinnkt nicht im Wut über versprochenes und nicht eingehaltenes.
  • 0
    Von Mario am Fr, 19. Januar 2001 um 22:26 #
    Ich habe den Treiber gestern ausprobiert und bin wirklich begeistert! Mit dem von XFree-Team gelieferten Treibern konnte ich gerade mal 5-10 Frames bei ssystem erreichen. Die von NVIDIA bringen dagegen zwischen 95-100 Frames/Sekunde. Ich hatte auch noch keine Probleme in den neuen Treibern entdecken koennen. Fairnesshalber sollte ich aber erwaehnen, dass ich noch nie Probleme mit NVIDIA-Treibern hatte und ich setze diese schon seit einer sehr langen Zeit ein. Erst beim Umstieg auf Kernel 2.4 konnte ich die nicht einsetzen und war wirklich traurig. ;-)
    0
    Von Anonymous am Mo, 22. Januar 2001 um 11:33 #
    @ Mario:

    Wenn die *rschl*ch*r von NVidia keine Speks freigeben und auch sonst wenig kooperativ sind können die XFree-Leute wohl auch wenig Hardwarebeschleunigung unterstützen, oder? Schön, dass es neue Treiber gibt, die vielleicht ausnahmsweise sogar besser sind als die alten Schrottdinger, die aus dem Hause NVidia kamen, ich möchte trotzdem keinem Opensourcler anraten, NVidia irgendwie in Betracht zu ziehen, solange die ihre Einstellung nicht ändern. Die haben ein quasi-Monopol auf dem Grafikkartenmarkt und ihre Unterstützung für Linux ist außerst mager; da ist die Tatsache, dass ihre Hardware gut ist für Linux um so bedrohlicher, denn dann wird im nicht unwichtigen Bereich Grafik/3D/Spiele Linux nie mit Windows konkurrieren können.

    0
    Von Jens am Mo, 22. Januar 2001 um 21:44 #
    ooooooooooooooooh mann, schon wieder so ein anonymer *r*ch!! soso, nvidia soll man aussen vor lassen, klar!! haste mal mitbekommen, dass die 3dfx gekauft haben? was gibt's da noch? matrox? war mal! ati radeon? totgeburt!

    nvidia ist nun mal einsame spitze, was die performance angeht und selbst wenn ich mit linux arbeit hab ich nix dagegen, ab und an mal quake zu starten!!

    jens

    0
    Von Anonymous am Di, 23. Januar 2001 um 15:53 #
    @ Jens
    Ich wünsche dir ein angenehmes Leben, du solltest aber mal versuchen ansatzweise dein Hirn zu benutzen; denk mal darüber nach was du tust, warum du tust was du tust und warum du das was du tust oder tun könntest überhaupt tun kannst. Ich weiß, das ist alles nicht einfach zu verstehen aber es ist vielleicht ein Denkanstoß, oder?
0
Von greg am Fr, 19. Januar 2001 um 22:21 #
die neuen treiber rulen echt :)
keine abstürze .. perfekt stabilität, auch keine crashs beim wechsel auf die textkonsole o.ä. hab ich.
und die laufen auch mit xfree 4.0.2 ohne probs!
mit q3 hab ich se auch schon getestet, 3d speed ist ungefähr gleich scheinbar.
  • 0
    Von greg am Fr, 19. Januar 2001 um 22:26 #
    ach ja und kompileren auch mit kernel 2.4.1pre8 ohne probleme :)
    0
    Von Anonymous am Fr, 19. Januar 2001 um 22:30 #
    Wie ist es mit TV-out?
    Twinview bezieht sich a nur für 2 Monitore, aber bei meiner Geforce2 MX Twinview hat der zweite 'nur' ein Tv-out.
    Scheint das Tv-out so wie man ihn bei den windows Treibern erhält noch Zukunftsmusik ist.
    0
    Von Det am Sa, 20. Januar 2001 um 15:51 #
    TV-Out interessiert mich auch. Ich möchte meinen neuen Rechner (der leider immer noch nicht geliefert wurde :-( ) auch als DVD-Video-Player verwenden. Würde mir gar nicht gefallen, dafür Win zu installieren.

    Ich habe mir mal die TWINVIEW-README angesehen. Ich denke mal, dass das vom Grundsatz her funktionieren müsste. Eigentlich nur für den zweiten Bildschirm die Auflösung und Wiederholrate des Fernsehers in der XF86Config angeben. Das Problem wird eher sein der Karte mitzuteilen, dass sie es mit dem PAL-Standard zu tun hat. Dafür habe ich aber mal was auf http://www.multimedia4linux.de gesehen.

    Ich glaube, da kommen einige lange Nächte auf mich zu.

0
Von CDEater am Fr, 19. Januar 2001 um 22:53 #
Wurd ja wohl auch Zeit!
unter windoof gibbet jeden Monat neu Treiber mit Bugfixes und neuen Features, und unter Linux lassen die uns monate warten, um noch nicht mal die treiber version 1.0 heruaszubringen...
Aber jetzt genug Kritik! Die neuen sind echt klasse, X 402 ist schneller gestartet, und stabil scheinen sie auch zu sein, wäre nur schön, wenn die häufiger neue Treiber bringen würden
0
Von Anonymous am Fr, 19. Januar 2001 um 23:07 #
Schade, das der neue Treiber immer noch nicht aa-fonts unter Xfree 4.0.2 unterstützt :-(
  • 0
    Von Anonymous am Fr, 19. Januar 2001 um 23:27 #
    ant-aliasing unter X hängt nicht von dem Treiber ab! Für AA muß das Programm die sogennante render extension benutzen. ES gibt z.b. schon ein Patch für QT mt dem dann alle QT und KDE2 programme anti-aliased werden. auch ein patch für gtk soll in arbeit sein. Es ist auhc möglich XFree mit einer speziellen FreeType Version zu kompilieren um AA zu erhaletn.
    0
    Von Thomas am Sa, 20. Januar 2001 um 12:32 #
    AA funzt doch schon!

    Schauts Euch an: http://forum.winner.de/ showthread.php?threadid=1545

    ACHTUNG: IHR MÜSST DAS LEERZEICHEN IN DER URL WIEDER ENTFERNEN! DAS BOARD HIER MECKERT ICH DÜRFE KEIN SO LANGES WORT POSTEN...

    Gruß
    Thomas
    www.powered-by-linux.de

0
Von Jochen Puchalla am Fr, 19. Januar 2001 um 23:27 #
Ich hab denen ne mail geschrieben, daß ich deren Produkt kaufe, wenn die nen stabilen Treiber für 3D und TV-out bieten, da ich sonst mit meiner Graka zufrieden bin und die Dinger Geld kosten.
Vielleicht raffen die was, wenn die _viele_ solche mails bekommen...

info@nvidia.com

für Leute, denen die Idee gefällt.

  • 0
    Von Anonymous am Sa, 20. Januar 2001 um 02:50 #
    gute idee, lasst uns die mal in grund und boden mailen! ;-).
    mit besseren 3d-treibern gibts vieleicht endlich mal bessere games fuer linux.

    gute sache das mit dem neuen treiber, aber open-source-treiber faende ich noch viel besser!

0
Von Oliver am Fr, 19. Januar 2001 um 23:30 #
Benchmarks auf Evil3D stimmen eher düster, was die Performance anbelangt.

http://www.evil3d.net/articles/linux/nv95v96/

  • 0
    Von greg am Fr, 19. Januar 2001 um 23:44 #
    lies mal ein bischen genauer: da wird von einem bug gesprochen der nur auf Geforce2 karten auftritt und deshalb das ganze lansgamer macht. Geforce1 oder ältere Karten sollen schneller sein mit den neuen treibern.
0
Von Anonymous am Sa, 20. Januar 2001 um 11:30 #
Gibt es auch 3D-beschleunigte Treiber für die Riva 128?
0
Von DonCayman am Sa, 20. Januar 2001 um 12:38 #
Hmmm, die 0.9-5 Version hat bei mir funktioniert, sehr instabil aber ich konnte z.B. GLTron spielen und bei der 0.9-6 gibt es immer den Fehler:

- trying to create window
Xlib: extension "GLX" missing on display ":0.0".
Couldn't set GL mode:
Couldn't find matching GLX visual -

Das glx Modul wird in der XFreeconfig-4 geladen.
Und in der /var/log/XFree86.0.log steht auch nix drin.
Was mach ich falsch?

Grüße,
D.C.

0
Von Tux am Sa, 20. Januar 2001 um 12:53 #
huhu

ich hab nen Athlon 600, 256ram, geforce 2 mx

jetzt die neuen kernel module drauf ...
laeuft super ... hatte vorher die gepatchten fuer 2.4.0 von phoenix

meine frage jetzt: ist es normal das ich bei meinem system beim timdemo (/demo demo127)
nur auf cirka 60 fps komme ?
woran kann das liegen ? hab AGP alles an ...
und trotzdem so niedrige rates :(

ich hab alle details runter ...

cu

0
Von Kai Lahmann am Sa, 20. Januar 2001 um 13:53 #
Das Ding ist echt genial! Allerdings sind da noch ein paar Dinge verbesserungswürdig:

- Kompilieren:
Es gibt immer noch einige Warnings über diversen kleinkram... Das muss doch nicht sein, oder?

- Modul:
das Modul landet mein 2.4.0 immer noch in /lib/modules/2.4.0/video, was schlicht falsch ist. Richtig wäre /lib/modules/2.4.0/kernel/drivers/video/

- XRENDER:
diese Funktion wird in der Tat (im Gegensatz zum "nv" treiber noch NICHT unterstützt (soll aber mit 0.9-7 kommen)

- devfs:
dafür braucht man derzeit noch einen Patch...

- AGP:
achtung, doc lesen! es ist total unübersichtlich, ob man nun besser apggart oder den eingebauten Treiber verwendet...

Zu der Frage oben wg. 3D auf einer Riva 128:
so weit ich weiß, eignet sich dieser Treiber auch für diese etwas ältere Karte...

  • 0
    Von Gutschy am Sa, 20. Januar 2001 um 17:05 #
    das Modul Prob hab ich so gelöst:

    NVIDIA_kernel-0.9-6
    im Makefile suchen nach:

    INSTALLDIR=/lib/modules/`uname -r`/video

    abändern auf:
    INSTALLDIR=/lib/modules/`uname -r`/kernel/drivers/video

    0
    Von Micronuke am Mo, 22. Januar 2001 um 14:31 #
    Zu den Compiler-Warnungen:

    1. Es gibt einige Stellen, da muss man nun mal etwas machen, was der Compiler nicht so super findet. Aber sonst sie die Treiber auch nicht so toll (siehe mein posting weiter unten).

    2. Hast' wohl noch nie die tdfx-(voodoo)-treiber kompiliert oder? *gg*

0
Von Catonga am Sa, 20. Januar 2001 um 16:34 #
Sagt mal, weiß einer von euch wie es jetzt eigentlich mit der Weiterentwicklung von 3dFX Voodoo Treibern für XFree 4.0.2 aussieht, nachdem 3dFX bald nicht mehr existiert.
  • 0
    Von Anonymous am Sa, 20. Januar 2001 um 17:53 #
    Ja genau!

    Ich habe noch eine ältere ELSA Vitory II mit dem Banshee Chipsatz. Gibt es da mal irgendwelche brauchbaren Treiber ausßer dem Standard SVGA-XFree?

    (Mandrake 7.2)

    0
    Von Anonymous am Sa, 20. Januar 2001 um 17:54 #
    Ja genau!

    Ich habe noch eine ältere ELSA Vitory II mit dem Banshee Chipsatz. Weiß einer, ob es da mal irgendwelche brauchbaren Treiber außer dem Standard SVGA-XFree gibt?

    (Mandrake 7.2)

    0
    Von Peter am Sa, 20. Januar 2001 um 20:06 #
    Hallo,
    da gab e auf linuxgames.com eine Stellungnahme von den Eumels die die meisten 3D Karten treiber für Linux basteln (Name ist mir gerade entfallen), sie haben gesagt, niemand zahle sie mehr dafür, also werden sie höchstens in ihrer Freizeit dran basteln.
0
Von Razi Lotfi am Sa, 20. Januar 2001 um 16:55 #
Hallo Leute,

ich habe SuSE-6.4 und XFree 4.0.1.
Ich wollte mir die Source-Codes (Kernel-Modul) kompilieren.
Das Programm ließ sich nicht kompilieren.
Das liegt wohl an dem modifizierten Kernel von SuSE (Kernel 2.2.17). Die RPM-Datei läßt sich zwar installieren aber die Module lassen sich nicht laden. Ich mußte eine Datei modifizieren. Dann klappte alles. Die Datei, die modifiziert werden muß heißt "os-interface.c".

Am besten mit patch-Befehl diese Datei modifizieren:

patch os-interface.c patch.txt

Wobei der Inhalt dieser "patch.txt"-Datei ist:


1650a1651
> #if defined(INTEL_I840)
1651a1653
> #endif
1658a1661
> #if defined(VIA_MVP4)
1659a1663
> #endif

Tschüß und viel Spaß

0
Von Slartibartfas am Sa, 20. Januar 2001 um 17:22 #
Laufen bei irgendjemandem mit einer MX die open GL Bildschirmschoner von KDE2?
0
Von LinuxLuder am Sa, 20. Januar 2001 um 19:08 #
"Wer die manuelle Installation der Treiber in seinem System nicht durchführen möchte, dem bietet der Hersteller bereits fertige RPM-Pakete für die Distributionen Mandrake, RedHat und SuSE zum Download an. "

Soweit, so gut. Aber ich kann nirgendwo die RPMs für Mandrake 7.2 finden. Auf der Seite gibt's
nur Mandrake 7.1 - kann ich die
auch nehmen?! Hat das Jemand mal ausprobiert?

0
Von Razi Lotfi am Sa, 20. Januar 2001 um 19:33 #
Hi,

ich wollte "SDL-1.1.7" installieren.
Ich erhalte bei "configure" die folgende Fehlermeldung:

configure:5207: checking for OpenGL (GLX) support
configure:5222: gcc -c -g -O2 -Wall -DUSE_ASMBLIT -I./hermes -I$(top_srcdir)/src/hermes -DOSS_SUPPORT -DALSA_SUPPORT -DESD_SUPPORT -I/usr/X11R6/include -DENABLE_X11 -DXFREE86_VM -DXFREE86_VMGAMMA -DXFREE86_
configure:5212: GL/gl.h: No such file or directory
configure:5213: GL/glx.h: No such file or directory
configure: failed program was:
#line 5210 "configure"
#include "confdefs.h"

#include
#include
#include /* For loading extensions */

Naja, diese Header-Dateien sind bei diesem Paket nicht dabei.

Was kann man machen, wenn man trotzdem diese OpenGL-Funktionalität nutzen möchte?

  • 0
    Von Micronuke am Mo, 22. Januar 2001 um 14:34 #
    Die GL-Includes sind nicht bei NVidia dabei, sondern z.B. bei MESA.
    Installiere dies, pass aber dabei auf, dass sich keine Dateien überschneiden, oder das Versionen es Versionskonflikte gibt (am besten danach NVidia-RPM nochmal installieren, und schauen, dass NUR die nvidia-gl-lib existiert).
    Leider hat NVidia gegen uraltes openGl 1.0 gelinkt :(
0
Von Anonymous am Sa, 20. Januar 2001 um 19:40 #
Hallo,

nimm doch einfach die Source RPMs. Damit hat es bei mir mit Mandrake 7.2 ohne Probleme geklappt. In der README von den Treibern steht auch ne Anleitung dafür!

Bei mir laufen die Treiber bis jetzt ohne Probleme.

Charly

0
Von Anonymous am Sa, 20. Januar 2001 um 19:56 #
Hallo, weiß vielleicht jemand, ob
dieser Treiber DVI-Monitore
unterstützt.
CRT's flimmern mir einfach zu sehr.
0
Von greg am Sa, 20. Januar 2001 um 23:19 #
die rpms kann man sowieso vergessen.. das beste ist immer noch das selbstkompilieren aus den .tar.gz sourcen.
0
Von Anonymous am So, 21. Januar 2001 um 11:30 #
Auch neue Treiber machen Linux nicht viel besser
  • 0
    Von Anonymous am So, 21. Januar 2001 um 12:56 #
    schon die 0.95 nvidia treiber haben
    die OpenGL Applications derart schnell beschleunigt, dass einem schwindelig wurde, zb. die OGL Bildschirmschoner
    Quake 3 sieht qualitativ und von der Geschwindigkeit identisch mit der Winversion aus!
    linux ist windows technisch überlegen, und kostet noch nicht mal was, also was soll das?
    klar ist die windose die derzeit bessere spielekonsole, aber auch nur weil es mehr games gibt und zum bedienen ein paar tasten weniger gedrückt werden müssen.
    0
    Von Kai Lahmann am Mi, 24. Januar 2001 um 19:06 #
    Die Version 0.9-5 war in Quake 3 ca. 3% langsamer als die Windows-Version. Die Version 0.9-6 ist (solange man keinen GeForce 2 hat -> Bug) mindestens genausoschnell..
0
Von Lukas am So, 21. Januar 2001 um 12:47 #
Kann mir jemand sagen, ob der Treiber Support für die neue XVideo Extension von XFree hat ?

Ich überlege nämlich jetzt von meiner Voodoo 3, auf der XV nur "halb" funktioniert", auf eine NVidia Karte umzusteigen. Obwohl mir diese Geschichte mit den Closed Source Treiber ja überhaupt nicht gefällt...
Wie gesagt wär es mir vor dem Kauf jedoch wichtig zu wissen wie es mit XV aussieht !

0
Von katakombi am So, 21. Januar 2001 um 12:52 #
Mit welchen Proggi kann ich testen, ob die 3D-Leistung angemessen ist unter X?
Und was sind ungefaehre Werte fuer Geforce2MX?

Habe naemlich im Bios irgendwelche Sachen disablen muessen, um das 3D unter Linux zum Laufen zu bringen (liegt wohl am Board: MSI 5169 mit ALI-Chipsatz...).

Jetzt befuerchte ich, das die Karte ohne AGP laeuft...

Hat jemand ahnung?

  • 0
    Von hjb am So, 21. Januar 2001 um 13:04 #
    Für einen schnellen Test empfehlen sich ein paar Programme von xscreensaver (z.B. gears) oder ssystem (sollte man ohnehin kennen!).
    0
    Von Maik am So, 21. Januar 2001 um 18:11 #
    Vieleicht hilfts:

    System: 800MHz Ahtlon mit Geforce2MX

    ssystem mit 0.95 = 280 fps (rund)
    ssystem mit 0.96 = 300 fps (rund)

    Agpgart im Kernel sollte nicht aktiviert sein, sonst ist die 0.96 deutlich langsammer als die 0.95.

0
Von Micronuke am Mo, 22. Januar 2001 um 14:14 #
Leider ist der "neue" Treiber immer noch gegen OpenGL 1.0 gelinkt, was in für pLib-Spiele unfähig macht.

cu
micronuke

  • 0
    Von Micronuke am Mo, 22. Januar 2001 um 14:24 #
    ....weiterhin scheint sich die auto-erkennnung für SD-RAM / SG-RAM eher verschlechtert als verbessert zu haben.
    Ziemlich umständlich immer erst den Quellcode editieren zu müssen.

    Ich hoffe die kriegen das bald mal gebacken, so schwer kann das doch nicht sein (ich meine nicht nur die Speichererkennung, auch die Geschwindigkeit ist unter win besser, und an mangelden Spezifikationen kann es ja wohl nicht liegen....).
    Ich werde auch keine NVidia mehr kaufen, das war jetzt meine erste und letzte.

    Das nächste mal ATi, wie laufen deren Treiber? (Be, inc. gegenüber ist ATi jedenfalls _wesentlich_ offener als NVidia)

0
Von Evilsgate am Mo, 22. Januar 2001 um 20:10 #
Der scheiß Treiber geht irgendwie nicht. ich hab in die XF86.config reingeschaut, da war immer noch der nv Treiber drin. dann hab ich mir die FAQ zu dem Treiber angeschaut. da steht drin, das ich aus dem nv ein nvidia machen soll. Gasagt getan. Doch was ist das? X startet nicht mehr. Was mache ich fallsch. hab den alten nv Treiber wieder eingestellt, sodas ich überhaupt X habe. Kann mir zufällig jemand bei dieser Sache helfen? Ich habe Suse 7.0.
  • 0
    Von Razi Lotfi am Di, 23. Januar 2001 um 14:27 #
    solche Problem hatte ich auch.
    Zwar wurden die Kernel-Module richtig geladen. Aber der Server startete nicht.
    Bekommst Du beim "lsmod" (als SU) sowas?

    agpgart 18296 2 (autoclean)
    NVdriver 609376 8 (autoclean)

    Falls nicht dann sind Deine Module nicht richtig installiert.

    Falls diese Zeilen bei Die auch erscheinen, schau mal Dir Deine Fehlermeldung an. Es kann sein, daß Du Dein BIOS modifizieren mußt. Die VGA-Karte muß unbedingt ein IRQ von dem BIOS zugewiesen bekommen.

0
Von oliver am Mo, 22. Januar 2001 um 21:58 #
Bei mir läuft der treiber deutlich besser als der alte 0.94 von Xfree4.0.1.
Mit der alten version habe ich die 3D Hardwareakzelleration nicht hinbekommen und jetzt ist alles gut.
Leistung: gears: 1780 fps (SuSe gibt für die GeForce2MX ca. 1500 fps als Referenz an).
damit ist sie etwas schneller als mit dem alten treiber.
Wirklich ätzend finde ich das Kuddelmuddel mit den open_gl-Bibliothelken. Wer da auf welche Bibliothek nen Link gesetzt hat und deshalb nichts funktioniert ist doof.
Kann man sich da nicht auf einheitliche Bennenung und Pfade einigen?
Ich habe deshalb mit dem neuen treiber auch auf xfree864.0.2 aufgerüstet und den ganzen alten Mesa-Kram mit deinstalliert und nach Anleitung (SuSE für Xfree und NVIDIA-Readme)neu installiert.
Hat auf jeden fall geholfen.
Wie bekomme ich jetzt raus ob ich agpgart oder den Nvidia-agp nutze (agpgart ist bei mir schon bisher als Modul mir drin gewesen)??

oliver

  • 0
    Von greg am Di, 23. Januar 2001 um 13:30 #
    cat /proc/nv/card0
    0
    Von Oliver am Mi, 24. Januar 2001 um 10:09 #
    Agp-Support ist laut Nvidia FQ per default aktiviert und sorgt manchmal für Probleme wie beschrieben. Deshalb in der screen-Section von XF86Config folgendes eintragen:

    option "NvGgp" "0"

    OpenGL läuft bei mir, nachdem ich die Mesas umbenannt und libGL.so.1.0.6 aus dem NVIDIA-GLX-Verzeichnis nach /usr/X11R6/lib kopiert und davon einen SLink auf libGL.so.1.2 gesetzt habe.

    Trotzdem ist der Treiber nicht stabil. Heretic2 crasht ab und zu - möglicherweise ein Problem mit der Auflösung?

0
Von huebi am Di, 23. Januar 2001 um 14:42 #
Mal so ein bischen was zum closed source
Treiber. NVidia kooperiert sehr eng mit SGI,
wie auch schon aus der Meldung zu sehen ist.
D.h. die Entwickler von beiden Firmen arbeiten
sehr eng miteinander zusammen, den SGI stellt
nun einmal die leistungsfaehigsten Grafiksys-
teme der Welt her. Fuer die neuen Visual Work
Stations auf PC-Basis werden nun aber andere
Grafikkarten gebraucht. Deshalb werden SGI-Karten
auch unter Linux immer die schnellsten sein.
Mit open source kommt die Konkurenz aber sofort dahinter
wie das geht. Die neues Features der karten werden dann auch erst mal nur von SGI genutzt.
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung