Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in libxml
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in libxml
ID: MDVSA-2009:200-1
Distribution: Mandriva
Plattformen: Mandriva 2008.0
Datum: Fr, 4. Dezember 2009, 04:03
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2414
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2416
Applikationen: libxml2

Originalnachricht

This is a multi-part message in MIME format...

------------=_1259895810-24326-1593


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDVSA-2009:200-1
http://www.mandriva.com/security/
_______________________________________________________________________

Package : libxml
Date : December 4, 2009
Affected: 2008.0
_______________________________________________________________________

Problem Description:

Multiple vulnerabilities has been found and corrected in libxml:

Stack consumption vulnerability in libxml2 2.5.10, 2.6.16, 2.6.26,
2.6.27, and 2.6.32, and libxml 1.8.17, allows context-dependent
attackers to cause a denial of service (application crash) via a
large depth of element declarations in a DTD, related to a function
recursion, as demonstrated by the Codenomicon XML fuzzing framework
(CVE-2009-2414).

Multiple use-after-free vulnerabilities in libxml2 2.5.10, 2.6.16,
2.6.26, 2.6.27, and 2.6.32, and libxml 1.8.17, allow context-dependent
attackers to cause a denial of service (application crash) via crafted
(1) Notation or (2) Enumeration attribute types in an XML file, as
demonstrated by the Codenomicon XML fuzzing framework (CVE-2009-2416).

This update provides a solution to these vulnerabilities.

Update:

Packages for 2008.0 are being provided due to extended support for
Corporate products.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2414
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2416
_______________________________________________________________________

Updated Packages:

Mandriva Linux 2008.0:
4c418296249dc8cc94b1b15e49b2d429
2008.0/i586/libxml1-1.8.17-11.1mdv2008.0.i586.rpm
7f55b33d9357641ccfbe9421c2818dc8
2008.0/i586/libxml1-devel-1.8.17-11.1mdv2008.0.i586.rpm
415af7a47df0783359018e7c8818123b
2008.0/i586/libxml2_2-2.6.30-1.6mdv2008.0.i586.rpm
44c479adb1d416beb45380e10398e350
2008.0/i586/libxml2-devel-2.6.30-1.6mdv2008.0.i586.rpm
affb65b84643897980a4db16bac8262d
2008.0/i586/libxml2-python-2.6.30-1.6mdv2008.0.i586.rpm
517f2690932d66302975469282a7f624
2008.0/i586/libxml2-utils-2.6.30-1.6mdv2008.0.i586.rpm
1df8e776ad34bdfe5b68437e45718ff8
2008.0/SRPMS/libxml-1.8.17-11.1mdv2008.0.src.rpm
f9eee25ac518012b01c9f54fbab3b3d8
2008.0/SRPMS/libxml2-2.6.30-1.6mdv2008.0.src.rpm

Mandriva Linux 2008.0/X86_64:
5dcd354e680675ffd08c9f0d562e5686
2008.0/x86_64/lib64xml1-1.8.17-11.1mdv2008.0.x86_64.rpm
9ef4286da3bf35a2b07d1a86d63b577b
2008.0/x86_64/lib64xml1-devel-1.8.17-11.1mdv2008.0.x86_64.rpm
09b50a18697fc91e9c801c3a8ffe83b4
2008.0/x86_64/lib64xml2_2-2.6.30-1.6mdv2008.0.x86_64.rpm
4453c937d9dfabdc9526f253fe0a14aa
2008.0/x86_64/lib64xml2-devel-2.6.30-1.6mdv2008.0.x86_64.rpm
2ab42a3413a471384a6e280d7afc3c90
2008.0/x86_64/libxml2-python-2.6.30-1.6mdv2008.0.x86_64.rpm
3e3127451a7348e2ef8e4990122c3518
2008.0/x86_64/libxml2-utils-2.6.30-1.6mdv2008.0.x86_64.rpm
1df8e776ad34bdfe5b68437e45718ff8
2008.0/SRPMS/libxml-1.8.17-11.1mdv2008.0.src.rpm
f9eee25ac518012b01c9f54fbab3b3d8
2008.0/SRPMS/libxml2-2.6.30-1.6mdv2008.0.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
<security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFLGE/cmqjQ0CJFipgRAk/PAKCz43qimvWl4XvfLCAWGlKd7OlgHACgsV/X
APy0BqGd7fLxPXDfkwOAKKg=
=tR4I
-----END PGP SIGNATURE-----


------------=_1259895810-24326-1593
Content-Type: text/plain; name="message-footer.txt"
Content-Disposition: inline; filename="message-footer.txt"
Content-Transfer-Encoding: 8bit

To unsubscribe, send a email to sympa@mandrivalinux.org
with this subject : unsubscribe security-announce
_______________________________________________________
Want to buy your Pack or Services from Mandriva?
Go to http://www.mandrivastore.com
Join the Club : http://www.mandrivaclub.com
_______________________________________________________

------------=_1259895810-24326-1593--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung