Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in MediaWiki
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in MediaWiki
ID: FEDORA-2011-6774
Distribution: Fedora
Plattformen: Fedora 14
Datum: Sa, 21. Mai 2011, 08:55
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-1765
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-1766
Applikationen: MediaWiki

Originalnachricht

-------------------------------------------------------------------------------
-
Fedora Update Notification
FEDORA-2011-6774
2011-05-09 20:36:36
-------------------------------------------------------------------------------
-

Name : mediawiki
Product : Fedora 14
Version : 1.16.5
Release : 59.fc14
URL : http://www.mediawiki.org/
Summary : A wiki engine
Description :
MediaWiki is the software used for Wikipedia and the other Wikimedia
Foundation websites. Compared to other wikis, it has an excellent
range of features and support for high-traffic websites using multiple
servers

This package supports wiki farms. Read the instructions for creating wiki
instances under /usr/share/doc/mediawiki-1.16.5/README.RPM.
Remember to remove the config dir after completing the configuration.

-------------------------------------------------------------------------------
-
Update Information:

Mediawiki 1.16.5 was released to correct two security flaws:

The first issue is yet another recurrence of the Internet Explorer 6 XSS
vulnerability that caused the release of 1.16.4. It was pointed out that there are dangerous extensions with more than four characters, so the regular expressions we introduced had to be updated to match longer extensions. (CVE-2011-1765)

The second issue allows unauthenticated users to gain additional
rights, on wikis where $wgBlockDisablesLogin is enabled. By default, it is
disabled. The issue occurs when a malicious user sends cookies which contain the user name and user ID of a "victim" account. In certain circumstances, the rights of the victim are loaded and persist throughout the malicious request, allowing the malicious user to perform actions with the victim's rights. (CVE-2011-1766)

$wgBlockDisablesLogin is a feature which is sometimes used on private wikis to
prevent users who have an account from logging in and viewing content on the wiki.
-------------------------------------------------------------------------------
-
ChangeLog:

* Sun May 8 2011 Axel Thimm <Axel.Thimm@ATrpms.net> - 1.16.5-59
- Update to 1.16.5.
* Fri Apr 22 2011 Axel Thimm <Axel.Thimm@ATrpms.net> - 1.16.4-58
- texvc was being accidentially wiped out before packaging it.
* Sat Apr 16 2011 Axel Thimm <Axel.Thimm@ATrpms.net> - 1.16.4-57
- Update to 1.16.4.
* Sun Apr 3 2011 Axel Thimm <Axel.Thimm@ATrpms.net> - 1.16.2-56
- Update to 1.16.2.
- Fixes RH bugs #614065, #644325, #682281, #662402
- Enable suggestions while typing in search boxes by default.
- Add some basic mediawiki management scripts.
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #702512 - CVE-2011-1765 mediawiki: two vulnerabilities fixed in
1.16.5
https://bugzilla.redhat.com/show_bug.cgi?id=702512
-------------------------------------------------------------------------------
-

This update can be installed with the "yum" update program. Use
su -c 'yum update mediawiki' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung