Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in WebKit
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in WebKit
ID: USN-1195-1
Distribution: Ubuntu
Plattformen: Ubuntu 10.04 LTS, Ubuntu 10.10
Datum: Di, 23. August 2011, 10:36
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-1824
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-2646
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-2651
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-2900
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-2901
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-3120
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-3254
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-3812
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-3813
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4040
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4042
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4197
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4198
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4199
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4204
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4206
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4492
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4493
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4577
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4578
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0482
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-0778
Applikationen: WebKit

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--===============3413183474075144500==
Content-Type: multipart/signed; micalg=pgp-sha1;
protocol="application/pgp-signature";
boundary="------------enigD295918E1892CED1D54A1172"

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigD295918E1892CED1D54A1172
Content-Type: text/plain; charset=ISO-8859-
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-1195-1
August 23, 2011

webkit vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 10.10
- Ubuntu 10.04 LTS

Summary:

Multiple security vulnerabilities were fixed in WebKit.

Software Description:
- webkit: Web content engine library for GTK+

Details:

A large number of security issues were discovered in the WebKit browser and
JavaScript engines. If a user were tricked into viewing a malicious
website, a remote attacker could exploit a variety of issues related to web
browser security, including cross-site scripting attacks, denial of
service attacks, and arbitrary code execution.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 10.10:
libwebkit-1.0-2 1.2.7-0ubuntu0.10.10.1

Ubuntu 10.04 LTS:
libwebkit-1.0-2 1.2.7-0ubuntu0.10.04.1

After a standard system update you need to restart any applications that
use WebKit, such as Epiphany and Midori, to make all the necessary changes.

References:
http://www.ubuntu.com/usn/usn-1195-1
CVE-2010-1824, CVE-2010-2646, CVE-2010-2651, CVE-2010-2900,
CVE-2010-2901, CVE-2010-3120, CVE-2010-3254, CVE-2010-3812,
CVE-2010-3813, CVE-2010-4040, CVE-2010-4042, CVE-2010-4197,
CVE-2010-4198, CVE-2010-4199, CVE-2010-4204, CVE-2010-4206,
CVE-2010-4492, CVE-2010-4493, CVE-2010-4577, CVE-2010-4578,
CVE-2011-0482, CVE-2011-0778

Package Information:
https://launchpad.net/ubuntu/+source/webkit/1.2.7-0ubuntu0.10.10.1
https://launchpad.net/ubuntu/+source/webkit/1.2.7-0ubuntu0.10.04.1




--------------enigD295918E1892CED1D54A1172
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk5TWQwACgkQTniv4aqX/VlMaQCeM3b9UquLUWJfCVn299u8ajm5
TmMAnA+mS7tJm2mofV4ife4VjCM5abdq
=NeLX
-----END PGP SIGNATURE-----

--------------enigD295918E1892CED1D54A1172--


--===============3413183474075144500==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============3413183474075144500==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung