Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in iceweasel
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in iceweasel
ID: DSA-2313-1
Distribution: Debian
Plattformen: Debian lenny, Debian sid, Debian squeeze
Datum: Fr, 30. September 2011, 08:33
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-2372
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-2995
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-2998
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-2999
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3000
Applikationen: iceweasel

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2313-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
September 29, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : iceweasel
Vulnerability : several
Problem type : remote
Debian-specific: no
CVE ID : CVE-2011-2372 CVE-2011-2995 CVE-2011-2998 CVE-2011-2999
CVE-2011-3000

Several vulnerabilities have been found in Iceweasel, a web browser
based on Firefox:

CVE-2011-2372

Mariusz Mlynski discovered that websites could open a download
dialog - which has "open" as the default action -, while a user
presses the ENTER key.

CVE-2011-2995

Benjamin Smedberg, Bob Clary and Jesse Ruderman discovered crashes
in the rendering engine, which could lead to the execution of
arbitrary code.

CVE-2011-2998

Mark Kaplan discovered an integer underflow in the javascript
engine, which could lead to the execution of arbitrary code.

CVE-2011-2999

Boris Zbarsky discovered that incorrect handling of the
window.location object could lead to bypasses of the same-origin
policy.

CVE-2011-3000

Ian Graham discovered that multiple Location headers might lead to
CRLF injection.

For the oldstable distribution (lenny), this problem has been fixed in
version 1.9.0.19-14 of the xulrunner source package. This update also
marks the compromised DigiNotar root certs as revoked rather then
untrusted.

For the stable distribution (squeeze), this problem has been fixed
inversion 3.5.16-10. This update also marks the compromised DigiNotar
root certs as revoked rather then untrusted.

For the unstable distribution (sid), this problem has been fixed in
version 7.0-1.

We recommend that you upgrade your iceweasel packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iEYEARECAAYFAk6E1SwACgkQXm3vHE4uylr0hQCg6nAdNzlA+lxNjBj1ELODHpHP
qU0AnApogZnzUH6zrCL/bU6m4bxeSyEW
=0CJf
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Archive: http://lists.debian.org/20110929203047.GA5497@pisco.westfalen.local
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung