Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in eterm (Aktualisierung)
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in eterm (Aktualisierung)
ID: DSA-309-2
Distribution: Debian
Plattformen: Debian woody
Datum: Do, 12. Juni 2003, 13:00
Referenzen: Keine Angabe
Applikationen: Eterm
Update von: Pufferüberlauf in eterm

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

--------------------------------------------------------------------------
Debian Security Advisory DSA 309-2 security@debian.org
http://www.debian.org/security/ Matt Zimmerman
June 6th, 2003 http://www.debian.org/security/faq
--------------------------------------------------------------------------

Package : eterm
Vulnerability : buffer overflow
Problem-Type : local
Bugtraq ID : 7708

A buffer overflow was fixed in DSA-309-1, but a different error was
introduced in the handling of the ETERMPATH environment variable.
This bug was not security-related, but would cause this environment
variable not to be recognized correctly. This is now corrected by an
updated version of the package.

For the stable distribution (woody), this problem has been fixed in
version 0.9.2-0pre2002042903.2.

The old stable distribution (potato) is not affected by this bug.

For the unstable distribution (sid) this problem will be fixed soon.

We recommend that you update your eterm package.

Upgrade Instructions
--------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody
--------------------------------

Source archives:

eterm_0.9.2-0pre2002042903.2.dsc
Size/MD5 checksum: 580 5c0ae65bf55b15b1106c3a61a3dca885
eterm_0.9.2-0pre2002042903.2.tar.gz
Size/MD5 checksum: 669252 5731a6c8b112a4efbc972ed3aa79fda9

Alpha architecture:

eterm_0.9.2-0pre2002042903.2_alpha.deb
Size/MD5 checksum: 389946 ff9d406f610da8e9d44acfa3c84d523f

ARM architecture:

eterm_0.9.2-0pre2002042903.2_arm.deb
Size/MD5 checksum: 374188 229c86418aefa76f1204c996bf76dbee

Intel IA-32 architecture:

eterm_0.9.2-0pre2002042903.2_i386.deb
Size/MD5 checksum: 332428 e7caf3c5d19c4b044d66f1a778dbdab0

Intel IA-64 architecture:

eterm_0.9.2-0pre2002042903.2_ia64.deb
Size/MD5 checksum: 450248 973718a70de16cacca8c9eb3544775e3

HP Precision architecture:

eterm_0.9.2-0pre2002042903.2_hppa.deb
Size/MD5 checksum: 390280 00e161a913a93c2b11e7ae9c5fde3f65

Motorola 680x0 architecture:

eterm_0.9.2-0pre2002042903.2_m68k.deb
Size/MD5 checksum: 336910 45114c79be0ae424d232a3e69363bc0b

Big endian MIPS architecture:

eterm_0.9.2-0pre2002042903.2_mips.deb
Size/MD5 checksum: 335870 3aa9befa2a9881f5a8fca12b2da57004

Little endian MIPS architecture:

eterm_0.9.2-0pre2002042903.2_mipsel.deb
Size/MD5 checksum: 335080 d8f689f223fd20712d080009c82e5313

PowerPC architecture:

eterm_0.9.2-0pre2002042903.2_powerpc.deb
Size/MD5 checksum: 365272 2ae5e7b431ea0773be76909b9b904621

IBM S/390 architecture:

eterm_0.9.2-0pre2002042903.2_s390.deb
Size/MD5 checksum: 356198 df740938f6e6eaa9841d03250dfdfee7

Sun Sparc architecture:

eterm_0.9.2-0pre2002042903.2_sparc.deb
Size/MD5 checksum: 368926 e3df2fa45e0dde1fbf20cd2792459ec9

These files will probably be moved into the stable distribution on its
next revision.

--------------------------------------------------------------------------------
-
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-securitydists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (GNU/Linux)

iD8DBQE+57hKArxCt0PiXR4RAhzFAJ9SOGswVCC8vFQ2l+o9EDW1Y71E+wCeMIUz
Fxf1Yj137EUAJQ0w3+9jp0c=
=MVcd
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung