Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in PHP
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in PHP
ID: USN-1307-1
Distribution: Ubuntu
Plattformen: Ubuntu 8.04 LTS, Ubuntu 10.04 LTS, Ubuntu 10.10, Ubuntu 11.04, Ubuntu 11.10
Datum: Mi, 14. Dezember 2011, 20:48
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4566
Applikationen: PHP

Originalnachricht


--===============0673694980691418076==
Content-Type: multipart/signed; micalg="pgp-sha512";
protocol="application/pgp-signature";
boundary="=-2dvRGE1KjDcEokNKbeQZ"


--=-2dvRGE1KjDcEokNKbeQZ
Content-Type: text/plain; charset="UTF-8
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-1307-1
December 14, 2011

php5 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 11.10
- Ubuntu 11.04
- Ubuntu 10.10
- Ubuntu 10.04 LTS
- Ubuntu 8.04 LTS

Summary:

PHP could be made to crash or disclose sensitive information if it
processed a specially crafted image file.

Software Description:
- php5: HTML-embedded scripting language interpreter

Details:

Florent Hochwelker discovered that PHP incorrectly handled certain EXIF
headers in JPEG files. A remote attacker could exploit this issue to
view sensitive information or cause the PHP server to crash.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 11.10:
php5-cgi 5.3.6-13ubuntu3.3
php5-cli 5.3.6-13ubuntu3.3

Ubuntu 11.04:
php5-cgi 5.3.5-1ubuntu7.4
php5-cli 5.3.5-1ubuntu7.4

Ubuntu 10.10:
php5-cgi 5.3.3-1ubuntu9.7
php5-cli 5.3.3-1ubuntu9.7

Ubuntu 10.04 LTS:
php5-cgi 5.3.2-1ubuntu4.11
php5-cli 5.3.2-1ubuntu4.11

Ubuntu 8.04 LTS:
php5-cgi 5.2.4-2ubuntu5.19
php5-cli 5.2.4-2ubuntu5.19

In general, a standard system update will make all the necessary changes.

References:
http://www.ubuntu.com/usn/usn-1307-1
CVE-2011-4566

Package Information:
https://launchpad.net/ubuntu/+source/php5/5.3.6-13ubuntu3.3
https://launchpad.net/ubuntu/+source/php5/5.3.5-1ubuntu7.4
https://launchpad.net/ubuntu/+source/php5/5.3.3-1ubuntu9.7
https://launchpad.net/ubuntu/+source/php5/5.3.2-1ubuntu4.11
https://launchpad.net/ubuntu/+source/php5/5.2.4-2ubuntu5.19



--ÒdvRGE1KjDcEokNKbeQZ
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)

iQIcBAABCgAGBQJO6Of7AAoJEGVp2FWnRL6T2kYQAKwi33xmyivbbFg/3cjBnsXB
tii/7PeI+TZTyVzR6PJE57/qnAuU6wt274n7ioltKGU0eJqBsyF3ZZV2yBSBk4WP
BKMvqta2kAX26E4ng8MUl3BLDXambQbbGpGn/i5HuAMDDGsZFrjT6zQYrdnHAv5o
mkDLPksuf6RB+B6ReYabgLNRTOldTG5AUQBtclx08kTKr4Ar0isTKaHdhG1Cg9gv
HsBLmSVXmU7Roz2hTz5RQs6qPVxxmKqYAbHTgxenchbWFHex/EUYq0YQykH5DBMQ
M32hROS2FESlFJtSfLZhc7rwnDKgSrgEjNZ04DRmdln0mIcyH9mqekUPOzKD6kfO
hwZvf8m/jqU3hqQ9P1tWHPxjmZ2EfZ0105o71oYC1DxHJxWqUHRWZBjwf6zFiKtz
z6CXcfKUSmQ6j6uAO4Wpphn37yMJre6869R30egaj4aBiIEc4/efd5piWdDNDPaT
e/4vaDYEU3Spoh2cljSxiPpznWEVWlZezGH696014IVjLmJS1ltmIOfd6M6gDJ9C
pHtNGKvSectaN9QE/9fnWaZXh/7U3IUthWt9UFJyagwz25+v/EHFoIgK5P2T5Qk+
lHjGY7SnHyW5Qr/mWj+YS4VV85EUVHILbRTkDdmgRDDJveUw3SSSBmsY5565AR4p
0GWJkApvAPmwZYtcy3/s
=EUtu
-----END PGP SIGNATURE-----

--=-2dvRGE1KjDcEokNKbeQZ--



--===============0673694980691418076==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============0673694980691418076==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung