Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in libqt4
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in libqt4
ID: SUSE-SU-2012:0097-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Desktop 11 SP1, SUSE Linux Enterprise Server 11 SP1, SUSE Linux Enterprise Software Development Kit 11 SP1, SUSE Linux Enterprise Server 11 SP1 for VMware
Datum: Do, 19. Januar 2012, 10:36
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3922
Applikationen: libqt4

Originalnachricht

   SUSE Security Update: Security update for libqt4
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:0097-1
Rating: important
References: #739904
Cross-References: CVE-2011-3922
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that fixes one vulnerability is now available. It
includes one version update.

Description:


A stack-based buffer overflow in the glyph handling of
libqt4's harfbuzz has been fixed. CVE-2011-3922 has been
assigned to this issue.

Security Issuereference:

* CVE-2011-3922
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3922
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-libQtWebKit-devel-5624

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-libQtWebKit-devel-5624

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-libQtWebKit-devel-5624

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-libQtWebKit-devel-5624

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64) [New Version: 4.6.3]:

libQtWebKit-devel-4.6.3-5.12.1
libqt4-devel-4.6.3-5.12.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (ppc64 s390x x86_64)
[New Version: 4.6.3]:

libQtWebKit4-32bit-4.6.3-5.12.1
libqt4-sql-sqlite-32bit-4.6.3-5.12.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (ia64) [New Version:
4.6.3]:

libQtWebKit4-x86-4.6.3-5.12.1
libqt4-sql-sqlite-x86-4.6.3-5.12.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64) [New Version:
4.6.3]:

libQtWebKit4-4.6.3-5.12.1
libqt4-4.6.3-5.12.1
libqt4-qt3support-4.6.3-5.12.1
libqt4-sql-4.6.3-5.12.1
libqt4-sql-sqlite-4.6.3-5.12.1
libqt4-x11-4.6.3-5.12.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (x86_64) [New Version:
4.6.3]:

libQtWebKit4-32bit-4.6.3-5.12.1
libqt4-32bit-4.6.3-5.12.1
libqt4-qt3support-32bit-4.6.3-5.12.1
libqt4-sql-32bit-4.6.3-5.12.1
libqt4-x11-32bit-4.6.3-5.12.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64) [New
Version: 4.6.3]:

libQtWebKit4-4.6.3-5.12.1
libqt4-4.6.3-5.12.1
libqt4-qt3support-4.6.3-5.12.1
libqt4-sql-4.6.3-5.12.1
libqt4-sql-sqlite-4.6.3-5.12.1
libqt4-x11-4.6.3-5.12.1

- SUSE Linux Enterprise Server 11 SP1 (ppc64 s390x x86_64) [New Version:
4.6.3]:

libQtWebKit4-32bit-4.6.3-5.12.1
libqt4-32bit-4.6.3-5.12.1
libqt4-qt3support-32bit-4.6.3-5.12.1
libqt4-sql-32bit-4.6.3-5.12.1
libqt4-x11-32bit-4.6.3-5.12.1

- SUSE Linux Enterprise Server 11 SP1 (ia64) [New Version: 4.6.3]:

libQtWebKit4-x86-4.6.3-5.12.1
libqt4-qt3support-x86-4.6.3-5.12.1
libqt4-sql-x86-4.6.3-5.12.1
libqt4-x11-x86-4.6.3-5.12.1
libqt4-x86-4.6.3-5.12.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64) [New Version: 4.6.3]:

libQtWebKit4-4.6.3-5.12.1
libqt4-4.6.3-5.12.1
libqt4-qt3support-4.6.3-5.12.1
libqt4-sql-4.6.3-5.12.1
libqt4-sql-sqlite-4.6.3-5.12.1
libqt4-x11-4.6.3-5.12.1

- SUSE Linux Enterprise Desktop 11 SP1 (x86_64) [New Version: 4.6.3]:

libQtWebKit4-32bit-4.6.3-5.12.1
libqt4-32bit-4.6.3-5.12.1
libqt4-qt3support-32bit-4.6.3-5.12.1
libqt4-sql-32bit-4.6.3-5.12.1
libqt4-sql-sqlite-32bit-4.6.3-5.12.1
libqt4-x11-32bit-4.6.3-5.12.1


References:

http://support.novell.com/security/cve/CVE-2011-3922.html
https://bugzilla.novell.com/739904
?keywords=a173a1a6d496f9364a4dbb5249f6f174

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung