Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in libvorbis
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in libvorbis
ID: openSUSE-SU-2012:0319-1
Distribution: SUSE
Plattformen: SUSE openSUSE 11.4
Datum: Fr, 2. März 2012, 08:40
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0444
Applikationen: libvorbis

Originalnachricht

   openSUSE Security Update: libvorbis: fixed a heap based buffer overflow
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:0319-1
Rating: important
References: #747912
Cross-References: CVE-2012-0444
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

Specially crafted ogg files could cause a heap-based buffer
overflow in the vorbis audio compression library that could
potentially be exploited by attackers to cause a crash or
execute arbitrary code (CVE-2012-0444).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch libvorbis-5850

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

libvorbis-devel-1.3.2-6.7.1
libvorbis0-1.3.2-6.7.1
libvorbisenc2-1.3.2-6.7.1
libvorbisfile3-1.3.2-6.7.1

- openSUSE 11.4 (x86_64):

libvorbis0-32bit-1.3.2-6.7.1
libvorbisenc2-32bit-1.3.2-6.7.1
libvorbisfile3-32bit-1.3.2-6.7.1

- openSUSE 11.4 (noarch):

libvorbis-doc-1.3.2-6.7.1


References:

http://support.novell.com/security/cve/CVE-2012-0444.html
https://bugzilla.novell.com/747912

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung