Login
Newsletter
Werbung

Sicherheit: Denial of Service in Openswan
Aktuelle Meldungen Distributionen
Name: Denial of Service in Openswan
ID: 201203-13
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Fr, 16. März 2012, 19:12
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-2147
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4073
Applikationen: Openswan

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig4DC6EC2208FC1FE838770658
Content-Type: text/plain; charset=ISO-8859-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201203-13
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Openswan: Denial of Service
Date: March 16, 2012
Bugs: #372961, #389097
ID: 201203-13

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in Openswan may create a Denial of Service
condition.

Background
==========

Openswan is an implementation of IPsec for Linux.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/openswan < 2.6.37 >= 2.6.37

Description
===========

Two vulnerabilities have been found in Openswan:

* Improper permissions are used on /var/run/starter.pid and
/var/lock/subsys/ipsec (CVE-2011-2147).
* Openswan contains a use-after-free error in the cryptographic helper
handler (CVE-2011-4073).

Impact
======

A remote authenticated attacker or a local attacker may be able to
cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Openswan users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/openswan-2.6.37"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since November 10, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2011-2147
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2147
[ 2 ] CVE-2011-4073
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4073

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201203-13.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--------------enig4DC6EC2208FC1FE838770658
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iF4EAREIAAYFAk9jIHMACgkQAnl3SfnYR/hVVAD5AWpsiDeWljBtqILUuV72V5aC
+rMSm30IOIgekln4nd8A/juFGkuLlInPR4rM0nGWzp4uiuY2Zl9mwZlYsvDrx3Va
=Uue6
-----END PGP SIGNATURE-----

--------------enig4DC6EC2208FC1FE838770658--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung