Login
Newsletter
Werbung

Sicherheit: Pufferüberläufe in Samba
Aktuelle Meldungen Distributionen
Name: Pufferüberläufe in Samba
ID: SUSE-SU-2012:0504-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Desktop 10 SP4, SUSE SLE SDK 10 SP4, SUSE Linux Enterprise Server 10 SP4, SUSE Linux Enterprise Server 10 SP3 LTSS
Datum: So, 15. April 2012, 00:00
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1182
Applikationen: Samba

Originalnachricht

   SUSE Security Update: Security update for Samba
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:0504-1
Rating: critical
References: #747906 #752797
Cross-References: CVE-2012-1182
Affected Products:
SUSE Linux Enterprise Server 10 SP4
SUSE Linux Enterprise Server 10 SP3 LTSS
SUSE Linux Enterprise Desktop 10 SP4
SLE SDK 10 SP4
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:


A remote code execution flaw in Samba has been fixed:

* CVE-2012-1182: PIDL based autogenerated code uses
client supplied size values which allows attackers to write
beyond the allocated array size

Also the following bug has been fixed:

* mount.cifs: Properly update mtab during remount;
(bnc#747906).

Security Issue reference:

* CVE-2012-1182
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1182
>



Package List:

- SUSE Linux Enterprise Server 10 SP4 (i586 ia64 ppc s390x x86_64):

cifs-mount-3.0.36-0.13.20.1
ldapsmb-1.34b-25.13.20.1
libmsrpc-3.0.36-0.13.20.1
libmsrpc-devel-3.0.36-0.13.20.1
libsmbclient-3.0.36-0.13.20.1
libsmbclient-devel-3.0.36-0.13.20.1
samba-3.0.36-0.13.20.1
samba-client-3.0.36-0.13.20.1
samba-krb-printing-3.0.36-0.13.20.1
samba-python-3.0.36-0.13.20.1
samba-vscan-0.3.6b-43.13.20.1
samba-winbind-3.0.36-0.13.20.1

- SUSE Linux Enterprise Server 10 SP4 (s390x x86_64):

libsmbclient-32bit-3.0.36-0.13.20.1
samba-32bit-3.0.36-0.13.20.1
samba-client-32bit-3.0.36-0.13.20.1
samba-winbind-32bit-3.0.36-0.13.20.1

- SUSE Linux Enterprise Server 10 SP4 (noarch):

samba-doc-3.0.36-0.12.20.1

- SUSE Linux Enterprise Server 10 SP4 (ia64):

libsmbclient-x86-3.0.36-0.13.20.1
samba-client-x86-3.0.36-0.13.20.1
samba-winbind-x86-3.0.36-0.13.20.1
samba-x86-3.0.36-0.13.20.1

- SUSE Linux Enterprise Server 10 SP4 (ppc):

libsmbclient-64bit-3.0.36-0.13.20.1
samba-64bit-3.0.36-0.13.20.1
samba-client-64bit-3.0.36-0.13.20.1
samba-winbind-64bit-3.0.36-0.13.20.1

- SUSE Linux Enterprise Server 10 SP3 LTSS (i586 s390x x86_64):

cifs-mount-3.0.36-0.13.20.1
ldapsmb-1.34b-25.13.20.1
libmsrpc-3.0.36-0.13.20.1
libmsrpc-devel-3.0.36-0.13.20.1
libsmbclient-3.0.36-0.13.20.1
libsmbclient-devel-3.0.36-0.13.20.1
samba-3.0.36-0.13.20.1
samba-client-3.0.36-0.13.20.1
samba-krb-printing-3.0.36-0.13.20.1
samba-python-3.0.36-0.13.20.1
samba-vscan-0.3.6b-43.13.20.1
samba-winbind-3.0.36-0.13.20.1

- SUSE Linux Enterprise Server 10 SP3 LTSS (s390x x86_64):

libsmbclient-32bit-3.0.36-0.13.20.1
samba-32bit-3.0.36-0.13.20.1
samba-client-32bit-3.0.36-0.13.20.1
samba-winbind-32bit-3.0.36-0.13.20.1

- SUSE Linux Enterprise Server 10 SP3 LTSS (noarch):

samba-doc-3.0.36-0.12.20.1

- SUSE Linux Enterprise Desktop 10 SP4 (i586 x86_64):

cifs-mount-3.0.36-0.13.20.1
ldapsmb-1.34b-25.13.20.1
libsmbclient-3.0.36-0.13.20.1
libsmbclient-devel-3.0.36-0.13.20.1
samba-3.0.36-0.13.20.1
samba-client-3.0.36-0.13.20.1
samba-krb-printing-3.0.36-0.13.20.1
samba-vscan-0.3.6b-43.13.20.1
samba-winbind-3.0.36-0.13.20.1

- SUSE Linux Enterprise Desktop 10 SP4 (x86_64):

libsmbclient-32bit-3.0.36-0.13.20.1
samba-32bit-3.0.36-0.13.20.1
samba-client-32bit-3.0.36-0.13.20.1
samba-winbind-32bit-3.0.36-0.13.20.1

- SUSE Linux Enterprise Desktop 10 SP4 (noarch):

samba-doc-3.0.36-0.12.20.1

- SLE SDK 10 SP4 (i586 ia64 ppc s390x x86_64):

libmsrpc-3.0.36-0.13.20.1
libmsrpc-devel-3.0.36-0.13.20.1
libsmbclient-devel-3.0.36-0.13.20.1
libsmbsharemodes-3.0.36-0.13.20.1
libsmbsharemodes-devel-3.0.36-0.13.20.1
samba-python-3.0.36-0.13.20.1


References:

http://support.novell.com/security/cve/CVE-2012-1182.html
https://bugzilla.novell.com/747906
https://bugzilla.novell.com/752797
?keywords=62cd7ec87ad16e0edc0743bc15673759
?keywords=ddd29165a82cb06a9503d4d188911168

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung