Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in PHP
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in PHP
ID: FEDORA-2012-9762
Distribution: Fedora
Plattformen: Fedora 16
Datum: Di, 3. Juli 2012, 08:16
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-2143
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-2386
Applikationen: PHP

Originalnachricht

Name        : php
Product : Fedora 16
Version : 5.3.14
Release : 1.fc16
URL : http://www.php.net/
Summary : PHP scripting language for creating dynamic web sites
Description :
PHP is an HTML-embedded scripting language. PHP attempts to make it
easy for developers to write dynamically generated web pages. PHP also
offers built-in database integration for several commercial and
non-commercial database management systems, so writing a
database-enabled webpage with PHP is fairly simple. The most common
use of PHP coding is probably as a replacement for CGI scripts.

The php package contains the module which adds support for the PHP
language to Apache HTTP Server.

-------------------------------------------------------------------------------
-
Update Information:

The PHP development team would like to announce the immediate availability of
PHP 5.3.14. All users of PHP are encouraged to upgrade to PHP 5.3.14.

The release fixes multiple security issues: A weakness in the DES
implementation of crypt and a heap overflow issue in the phar extension.

PHP 5.3.14 fixes over 30 bugs. Please note that the use of php://fd streams is
now restricted to the CLI SAPI

Changelog: http://www.php.net/ChangeLog-5.php#5.3.14
-------------------------------------------------------------------------------
-
ChangeLog:

* Thu Jun 21 2012 Remi Collet <remi@fedoraproject.org> 5.3.14-1
- update to 5.3.14 (CVE-2012-2143, CVE-2012-2386)
- add missing provides (core, ereg, filter, standard)
* Wed May 9 2012 Remi Collet <remi@fedoraproject.org> 5.3.13-1
- update to 5.3.13 (CVE-2012-2311)
* Thu May 3 2012 Remi Collet <remi@fedoraproject.org> 5.3.12
- update to 5.3.12 (CVE-2012-1823)
* Fri Apr 27 2012 Remi Collet <remi@fedoraproject.org> 5.3.11-1
- update to 5.3.11
http://www.php.net/ChangeLog-5.php#5.3.11
- add /etc/sysconfig/php-fpm environment file (#784770)
- php-fpm: add security.limit_extensions in provided conf
- zip extension is back (unbundled in f17)
* Thu Feb 2 2012 Joe Orton <jorton@redhat.com> - 5.3.10-1
- update to 5.3.10
* Wed Jan 11 2012 Remi Collet <remi@fedoraproject.org> 5.3.9-1
- update to 5.3.9
http://www.php.net/ChangeLog-5.php#5.3.9
- fix owner of /var/log/php-fpm (bug #773077)
- add max_input_vars, max_file_uploads, zend.enable_gc to php.ini
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #816956 - CVE-2012-2143 BSD crypt(): DES encrypted password
weakness
https://bugzilla.redhat.com/show_bug.cgi?id=816956
[ 2 ] Bug #823594 - CVE-2012-2386 php: Integer overflow leading to
heap-buffer overflow in the Phar extension
https://bugzilla.redhat.com/show_bug.cgi?id=823594
-------------------------------------------------------------------------------
-

This update can be installed with the "yum" update program. Use
su -c 'yum update php' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung