Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in curl
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in curl
ID: DSA-2713-1
Distribution: Debian
Plattformen: Debian sid, Debian squeeze, Debian wheezy
Datum: Di, 25. Juni 2013, 07:14
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-2174
Applikationen: curl

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2713-1 security@debian.org
http://www.debian.org/security/ Salvatore Bonaccorso
June 24, 2013 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : curl
Vulnerability : heap overflow
Problem type : local (remote)
Debian-specific: no
CVE ID : CVE-2013-2174

Timo Sirainen discovered that cURL, an URL transfer library, is prone to
a heap overflow vulnerability due to bad checking of the input data in
the curl_easy_unescape function.

The curl command line tool is not affected by this problem as it doesn't
use the curl_easy_unescape function.

For the oldstable distribution (squeeze), this problem has been fixed in
version 7.21.0-2.1+squeeze4.

For the stable distribution (wheezy), this problem has been fixed in
version 7.26.0-1+wheezy3.

For the unstable distribution (sid), this problem has been fixed in
version 7.31.0-1.

We recommend that you upgrade your curl packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCgAGBQJRyLSvAAoJEHidbwV/2GP+ix8P/jeD+HKIwcp/PMb1EYk7ftlL
Y0aNTYugxBdQNo7CAAS0/7EbW4u5QeKp0a+583KcmFbWDXdAxW6oktcuYbyoLJzU
nunpACCKqiviRLeXHRp6Sw8JVBvqbPM/FsqxfV74edqegENTW4TBqn7rkQEy9DAN
GQ8vwzHBY4CvlndUOnIKeyWdIW6yu/fVjjCDtn6rNVw4WLYj4JbQuss/1trHd0gr
iQNefWsCK+YHpEz2XAnt1BuCvuDGjGR/iIaUJiO2X4+XxOjdQnXkkdCdX71wnNxc
ppr7duxSakLKMf/i/DB5aNZSAFXvK3lp9SSY/r8CHNaa39JNk7o1uyMnyv+8iJKD
Rq8iyh9t2uht4N7xzwy+N4xCIKEiLtCftSRtxeGOMgx1rY++Wo/68T8XZPcOuYDF
eMoEx1v6+ZKi8e/cakgUZ86QGWCs2KbTkYV5hTIIBc0rqJQPkRmOlcIM9/yD7Sz4
fMw4X2HQZA+pG+yh/YemedeMa4xA9TdYBMgKqkly3nsfFDHSQALIOsxcvpxZDGds
RaEta1Mv9Xly/3H2Oef1SRUXergQexFONAZqvmus/WtgyxUwncCnCsKDGRScRzT2
YD7y/nf8ZysTZGuVszdbcD5wkHWY3nNy4Y1mSXIOGnbJtZj1Zbh18zMQ4phX1m9i
JrVF5sEb2x+jznGeZNzm
=3QpJ
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Archive: http://lists.debian.org/E1UrE9O-0005wO-AC@master.debian.org
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung