Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in libpng
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in libpng
ID: 200407-06
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Fr, 9. Juli 2004, 13:00
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2002-1363
Applikationen: libpng

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200407-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libpng: Buffer overflow on row buffers
Date: July 08, 2004
Bugs: #56307
ID: 200407-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

libpng contains a buffer overflow vulnerability potentially allowing an
attacker to perform a Denial of Service attack or even execute
arbitrary code.

Background
==========

libpng is a standard library used to process PNG (Portable Network
Graphics) images. It is used by several other programs, including web
browsers and potentially server processes.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/libpng <= 1.2.5-r6 >= 1.2.5-r7

Description
===========

Due to a wrong calculation of loop offset values, libpng contains a
buffer overflow vulnerability on the row buffers. This vulnerability
was initially patched in January 2003 but since it has been discovered
that libpng contains the same vulnerability in two other places.

Impact
======

An attacker could exploit this vulnerability to cause programs linked
against the library to crash or execute arbitrary code with the
permissions of the user running the vulnerable program, which could be
the root user.

Workaround
==========

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version.

Resolution
==========

All libpng users should upgrade to the latest stable version:

# emerge sync

# emerge -pv ">=media-libs/libpng-1.2.5-r7"
# emerge ">=media-libs/libpng-1.2.5-r7"

You should also run revdep-rebuild to rebuild any packages that depend
on older versions of libpng :

# revdep-rebuild

References
==========

[ 1 ] CAN-2002-1363
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2002-1363

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200407-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFA7XK8zKC5hMHO6rkRAjLuAJ9zW3QogSBVEPOSgX0XS9Pv5qlx9gCdGKR+
UDQw/XJ+RWHohdUW3gY0rNg=
=nU11
-----END PGP SIGNATURE-----
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung