Login
Newsletter
Werbung

Sicherheit: Mangelnde Prüfung von Zertifikaten in PHP
Aktuelle Meldungen Distributionen
Name: Mangelnde Prüfung von Zertifikaten in PHP
ID: USN-1937-1
Distribution: Ubuntu
Plattformen: Ubuntu 10.04 LTS, Ubuntu 12.04 LTS, Ubuntu 12.10, Ubuntu 13.04
Datum: Fr, 6. September 2013, 08:45
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4248
Applikationen: PHP

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--===============7486983448732739908==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="------------enig7A6679249C9C11B23F42A050"

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig7A6679249C9C11B23F42A050
Content-Type: text/plain; charset=UTF-
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-1937-1
September 05, 2013

php5 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 13.04
- Ubuntu 12.10
- Ubuntu 12.04 LTS
- Ubuntu 10.04 LTS

Summary:

Fraudulent security certificates could allow sensitive information to
be exposed when accessing the Internet.

Software Description:
- php5: HTML-embedded scripting language interpreter

Details:

It was discovered that PHP did not properly handle certificates with NULL
characters in the Subject Alternative Name field. An attacker could exploit
this to perform a man in the middle attack to view sensitive information or
alter encrypted communications.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 13.04:
libapache2-mod-php5 5.4.9-4ubuntu2.3
php5-cgi 5.4.9-4ubuntu2.3
php5-cli 5.4.9-4ubuntu2.3

Ubuntu 12.10:
libapache2-mod-php5 5.4.6-1ubuntu1.4
php5-cgi 5.4.6-1ubuntu1.4
php5-cli 5.4.6-1ubuntu1.4

Ubuntu 12.04 LTS:
libapache2-mod-php5 5.3.10-1ubuntu3.8
php5-cgi 5.3.10-1ubuntu3.8
php5-cli 5.3.10-1ubuntu3.8

Ubuntu 10.04 LTS:
libapache2-mod-php5 5.3.2-1ubuntu4.21
libapache2-mod-php5filter 5.3.2-1ubuntu4.21
php5-cgi 5.3.2-1ubuntu4.21
php5-cli 5.3.2-1ubuntu4.21

In general, a standard system update will make all the necessary changes.

References:
http://www.ubuntu.com/usn/usn-1937-1
CVE-2013-4248

Package Information:
https://launchpad.net/ubuntu/+source/php5/5.4.9-4ubuntu2.3
https://launchpad.net/ubuntu/+source/php5/5.4.6-1ubuntu1.4
https://launchpad.net/ubuntu/+source/php5/5.3.10-1ubuntu3.8
https://launchpad.net/ubuntu/+source/php5/5.3.2-1ubuntu4.21



--------------enig7A6679249C9C11B23F42A050
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQIcBAEBCgAGBQJSKNCzAAoJEGVp2FWnRL6TzsAP/2iVTakv2VOOHJLJeZUWLPXn
Cru0UFJdN4oSjzpEaAnVKqd934fE7xQEulHU7x30HrNtK1elvUcqvWAUfsxV7Z0F
aLXZgJzBUvvssIbFOaHtFoGQj5oUTAQysjL/nOVEEFn7PPk0pxsKWsEdJvZU1vNO
2JwyvXmUYmnEP9sMPk7d8pkH1EngqV1gTpbeYvBct7t4cKAujAeq0MddyifC2ZlJ
J3UdeVAaWByVHyaNudmMFp58hbwVPbbRa/f6kooj+EYguPmXNzhEWzoOuEzsPKbv
d5QURy0NT8DRfU7hAN1KViOEDSJ2VHwYburzuer4+XH6E1UbS9tti3r58D1EHPwt
0kfp8QBZXUC0aXEGLc/k48i/kUXhDsyHdmpd+T7OsvZjvHiZDONdCBxzjlDNjNZ0
BWMz4yF+6wJUFEhZs/IuPc+RQPHgO9VF7QhMRjdxX/IQHgwQHvTrzvj3x1qQ6bfN
40ElY6dO8/1030mSRcIBqFu/eTwYl2Wg6xFERH9yT1CXa4CLj+XR+U7qxj1h8pnU
azWHbuuOBv+9/UeCIRb7l8Zd9GAJmVGX9NPgYzD59Y3ZCvc3JyiJXTm0vhhaPUf0
H6KfqD9sLDdU5fB5lqiS6GDz+A0yfKTNbfkqncHuOqv3n6mALec+XlcMQeZxltg8
O+H+DafBO83MkDEwoNst
=BF02
-----END PGP SIGNATURE-----

--------------enig7A6679249C9C11B23F42A050--


--===============7486983448732739908==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============7486983448732739908==--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung