Login
Newsletter
Werbung

Sicherheit: Überschreiben von Dateien in txt2man
Aktuelle Meldungen Distributionen
Name: Überschreiben von Dateien in txt2man
ID: USN-1979-1
Distribution: Ubuntu
Plattformen: Ubuntu 12.04 LTS, Ubuntu 12.10, Ubuntu 13.04
Datum: Di, 1. Oktober 2013, 08:01
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-1444
Applikationen: txt2man

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--===============0632725670509255111==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="MuSwupC1GqXBhLjNVOQ8Lmx60jEUskEDc"

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--MuSwupC1GqXBhLjNVOQ8Lmx60jEUskEDc
Content-Type: text/plain; charset=UTF-
Content-Transfer-Encoding: quoted-printable

==========================================================================
Ubuntu Security Notice USN-1979-1
September 30, 2013

txt2man vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 13.04
- Ubuntu 12.10
- Ubuntu 12.04 LTS

Summary:

txt2man could be made to overwrite files.

Software Description:
- txt2man: Converts flat ASCII text to man page format

Details:

Patrick J Cherry discovered that txt2man contained leftover debugging code
that incorrectly created a temporary file. A local attacker could possibly
use this issue to overwrite arbitrary files. In the default Ubuntu
installation, this should be prevented by the Yama link restrictions.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 13.04:
txt2man 1.5.5-4ubuntu0.13.04.1

Ubuntu 12.10:
txt2man 1.5.5-4ubuntu0.12.10.1

Ubuntu 12.04 LTS:
txt2man 1.5.5-4ubuntu0.12.04.1

In general, a standard system update will make all the necessary changes.

References:
http://www.ubuntu.com/usn/usn-1979-1
CVE-2013-1444

Package Information:
https://launchpad.net/ubuntu/+source/txt2man/1.5.5-4ubuntu0.13.04.1
https://launchpad.net/ubuntu/+source/txt2man/1.5.5-4ubuntu0.12.10.1
https://launchpad.net/ubuntu/+source/txt2man/1.5.5-4ubuntu0.12.04.1



--MuSwupC1GqXBhLjNVOQ8Lmx60jEUskEDc
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCgAGBQJSSbPqAAoJEGVp2FWnRL6T/sIP/jPNNSRk0x6Bts7V+34ZSh0a
b9rO7soBzpQt6Vwe1JLArrPagDNDatzZL7zqjrLEj2BXiUMHXjaEyz995J+OZ5KH
N5MbQP6r9eIMNxl8o08SHjB5J0mjl138LDe7o8TKbU2aNvy7DW7/4k3lOOfBL/ft
GmnejjZDsvpw+jO5sZQlQ+tGffl3pz3kizmvRB7Kh/mSIvlw5dDOWqqc7zZyJu1C
satIFhKAZcW3zkhe/ajk1QYmAGGv0JcuGUw7xIUN2bYSPA47UhgD+AroCoZsKB2z
mLKXy0pYcQck4mNoOeX5b4Hxft39cK4SjRteZgarj2pXt4dkpaJuTuAq/F3wJbcz
SY9ek4YtDEfgDiaqBhtTAgzVoANO5q56zRoxfDWPIBXWJPq8EgZkBINu4MvqxzUc
UIuCpDFMPLxeOYEQ3y3P4Uw3iumHOziGdH4v0nqZXqzDRFFyZMsGnynwc2pqlorZ
Nb/btQb4+eY8ZoSA3r6yGqQu6UW2EHTl9uACUuDUGl51YcVGswDuC/XDpc7QtbXA
yceeBIWBxvPa77lPnYxL+Zdzo4F8lRYGivQYRgWEJgdN2n8+RQSj/fpgTuMAt6FR
/8n3F5+UUxlY/vnZKLkfqZFrzfyWcsgy32IGN7tOJHGZOQMY5/lCjghZBKCnEw00
uFrfpWI1Tlzt7SXV2+fd
=DUqr
-----END PGP SIGNATURE-----

--MuSwupC1GqXBhLjNVOQ8Lmx60jEUskEDc--


--===============0632725670509255111==
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce

--===============0632725670509255111==--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung