Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf und fehlende Fehlerprüfung in cfengine
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf und fehlende Fehlerprüfung in cfengine
ID: 200408-08
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mi, 11. August 2004, 13:00
Referenzen: http://www.coresecurity.com/common/showdoc.php?idx=387&idxseccion=10
Applikationen: Cfengine

Originalnachricht

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200408-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: Cfengine : RSA Authentication Heap Corruption
Date: August 10, 2004
Bugs: #59895
ID: 200408-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Cfengine is vulnerable to a remote root exploit from clients in
AllowConnectionsFrom.

Background
==========

Cfengine is an agent/software robot and a high level policy language
for building expert systems to administrate and configure large
computer networks.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/cfengine <= 2.1.17 >= 2.1.8
net-misc/cfengine >= 2.0.0 >= 2.1.8

Description
===========

Two vulnerabilities have been found in cfservd. One is a buffer
overflow in the AuthenticationDialogue function and the other is a
failure to check the proper return value of the ReceiveTransaction
function.

Impact
======

An attacker could use the buffer overflow to execute arbitrary code
with the permissions of the user running cfservd, which is usually the
root user. However, before such an attack could be mounted, the
IP-based ACL would have to be bypassed. With the second vulnerability,
an attacker could cause a denial of service attack.

Workaround
==========

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of Cfengine.

Resolution
==========

All Cfengine users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=net-misc/cfengine-2.1.8"
# emerge ">=net-misc/cfengine-2.1.8"

References
==========

[ 1 ] Corelabs Advisory
showdoc.php?idx=387&idxseccion=10

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200408-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung