Login
Newsletter
Werbung

Sicherheit: Pufferüberläufe in qt3
Aktuelle Meldungen Distributionen
Name: Pufferüberläufe in qt3
ID: 200408-20
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mo, 23. August 2004, 13:00
Referenzen: http://www.mandrakesoft.com/security/advisories?name=MDKSA-2004:085
http://www.trolltech.com/developer/changes/changes-3.3.3.html
Applikationen: Qt

Originalnachricht

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200408-20
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Qt: Image loader overflows
Date: August 22, 2004
Bugs: #60855
ID: 200408-20

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

There are several bugs in Qt's image-handling code which could lead to
crashes or arbitrary code execution.

Background
==========

Qt is a cross-platform GUI toolkit used by KDE.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 x11-libs/qt <= 3.3.2 >= 3.3.3

Description
===========

There are several unspecified bugs in the QImage class which may cause
crashes or allow execution of arbitrary code as the user running the Qt
application. These bugs affect the PNG, XPM, BMP, GIF and JPEG image
types.

Impact
======

An attacker may exploit these bugs by causing a user to open a
carefully-constructed image file in any one of these formats. This may
be accomplished through e-mail attachments (if the user uses KMail), or
by simply placing a malformed image on a website and then convicing the
user to load the site in a Qt-based browser (such as Konqueror).

Workaround
==========

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of Qt.

Resolution
==========

All Qt users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=x11-libs/qt-3.3.3"
# emerge ">=x11-libs/qt-3.3.3"

References
==========

[ 1 ] Mandrake Advisory
http://www.mandrakesoft.com/security/advisories?name=MDKSA-2004:085
[ 2 ] Qt 3.3.3 ChangeLog
http://www.trolltech.com/developer/changes/changes-3.3.3.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200408-20.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung