Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in ruby19
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in ruby19
ID: SUSE-SU-2013:1897-1
Distribution: SUSE
Plattformen: SUSE Studio Onsite 1.3
Datum: Di, 17. Dezember 2013, 07:41
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4164
Applikationen: Ruby

Originalnachricht

   SUSE Security Update: Security update for ruby19
______________________________________________________________________________

Announcement ID: SUSE-SU-2013:1897-1
Rating: critical
References: #851803
Cross-References: CVE-2013-4164
Affected Products:
SUSE Studio Onsite 1.3
______________________________________________________________________________

An update that fixes one vulnerability is now available. It
includes one version update.

Description:


This update fixes a severe security bug in ruby19:

* CVE-2013-4164: heap overflow in float point parsing
could lead to crashes and code execution

Security Issue reference:

* CVE-2013-4164
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4164
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Studio Onsite 1.3:

zypper in -t patch slestso13-ruby19-8620

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Studio Onsite 1.3 (x86_64) [New Version: 1.9.3.p392]:

ruby19-1.9.3.p392-0.17.1
ruby19-devel-1.9.3.p392-0.17.1
ruby19-devel-extra-1.9.3.p392-0.17.1


References:

http://support.novell.com/security/cve/CVE-2013-4164.html
https://bugzilla.novell.com/851803
?keywords=3342ac1ab377ae7f16f87852381eeade

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung