Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in PHP
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in PHP
ID: FEDORA-2013-23215
Distribution: Fedora
Plattformen: Fedora 18
Datum: Fr, 20. Dezember 2013, 09:11
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-6420
Applikationen: PHP

Originalnachricht

Name        : php
Product : Fedora 18
Version : 5.4.23
Release : 1.fc18
URL : http://www.php.net/
Summary : PHP scripting language for creating dynamic web sites
Description :
PHP is an HTML-embedded scripting language. PHP attempts to make it
easy for developers to write dynamically generated web pages. PHP also
offers built-in database integration for several commercial and
non-commercial database management systems, so writing a
database-enabled webpage with PHP is fairly simple. The most common
use of PHP coding is probably as a replacement for CGI scripts.

The php package contains the module which adds support for the PHP
language to Apache HTTP Server.

-------------------------------------------------------------------------------
-
Update Information:

28 Nov 2013, PHP 5.4.23

Core:
* Fixed bug #66094 (unregister_tick_function tries to cast a Closure to a
string). (Laruence)
* Fixed bug #65947 (basename is no more working after fgetcsv in certain
situation). (Laruence)

JSON
* Fixed whitespace part of bug #64874 ("json_decode handles whitespace and
case-sensitivity incorrectly"). (Andrea Faulds)

MySQLi:
* Fixed bug #66043 (Segfault calling bind_param() on mysqli). (Laruence)

mysqlnd:
* Fixed bug #66124 (mysqli under mysqlnd loses precision when bind_param with
'i'). (Andrey)
* Fixed bug #66141 (mysqlnd quote function is wrong with NO_BACKSLASH_ESCAPES
after failed query). (Andrey)

OpenSSL:
* Fixed memory corruption in openssl_x509_parse() (CVE-2013-6420). (Stefan
Esser).

PDO
* Fixed bug 65946 (sql_parser permanently converts values bound to strings)

Backported from 5.5.8
* fix zend_register_functions breaks reflection, php bug 66218
-------------------------------------------------------------------------------
-
ChangeLog:

* Wed Dec 11 2013 Remi Collet <rcollet@redhat.com> 5.4.23-1
- update to 5.4.23, fix for CVE-2013-6420
- fix zend_register_functions breaks reflection, php bug 66218
* Wed Nov 13 2013 Remi Collet <remi@fedoraproject.org> 5.4.22-1
- update to 5.4.22
* Thu Oct 17 2013 Remi Collet <rcollet@redhat.com> - 5.4.21-1
- update to 5.4.21
* Thu Sep 19 2013 Remi Collet <rcollet@redhat.com> - 5.4.20-1
- update to 5.4.20
* Thu Aug 22 2013 Remi Collet <rcollet@redhat.com> - 5.4.19-1
- update to 5.4.19
* Mon Aug 19 2013 Remi Collet <rcollet@redhat.com> - 5.4.18-1
- update to 5.4.18, fix for CVE-2013-4248
- add Provides: php(pdo-abi), for consistency with php(api)
and php(zend-abi)
- fix php-enchant package summary and description
* Fri Jul 12 2013 Remi Collet <rcollet@redhat.com> - 5.4.17-2
- add security fix for CVE-2013-4113
- add missing ASL 1.0 license
* Wed Jul 3 2013 Remi Collet <rcollet@redhat.com> 5.4.17-1
- update to 5.4.17
- add missing man pages (phar, php-cgi)
* Wed Jun 5 2013 Remi Collet <rcollet@redhat.com> 5.4.16-1
- update to 5.4.16
- switch systemd unit to Type=notify
- patch for upstream Bug #64915 error_log ignored when daemonize=0
- patch for upstream Bug #64949 Buffer overflow in _pdo_pgsql_error
- patch for upstream bug #64960 Segfault in gc_zval_possible_root
* Thu May 9 2013 Remi Collet <rcollet@redhat.com> 5.4.15-1
- update to 5.4.15
- add version to "Obsoletes"
- own /usr/share/fpm
* Thu Apr 11 2013 Remi Collet <rcollet@redhat.com> 5.4.14-1
- update to 5.4.14
- clean old deprecated options
* Thu Mar 14 2013 Remi Collet <rcollet@redhat.com> 5.4.13-1
- update to 5.4.13
- security fix for CVE-2013-1643
- Hardened build (links with -z now option)
- Remove %config from %{_sysconfdir}/rpm/macros.*
(https://fedorahosted.org/fpc/ticket/259).
* Wed Feb 20 2013 Remi Collet <remi@fedoraproject.org> 5.4.12-1
- update to 5.4.12
- security fix for CVE-2013-1635
- enable tokyocabinet dba handler
- upstream patch (5.4.13) to fix dval to lval conversion
https://bugs.php.net/64142
- upstream patch (5.4.13) for 2 failed tests
- fix buit-in web server on ppc64 (fdset usage)
https://bugs.php.net/64128
* Wed Jan 16 2013 Remi Collet <rcollet@redhat.com> 5.4.11-1
- update to 5.4.11
- fix php.conf to allow MultiViews managed by php scripts
* Wed Dec 19 2012 Remi Collet <rcollet@redhat.com> 5.4.10-1
- update to 5.4.10
- remove patches merged upstream
* Tue Dec 11 2012 Remi Collet <rcollet@redhat.com> 5.4.9-3
- drop "Configure Command" from phpinfo output
* Tue Dec 11 2012 Joe Orton <jorton@redhat.com> - 5.4.9-2
- prevent php_config.h changes across (otherwise identical) rebuilds
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1036830 - CVE-2013-6420 php: memory corruption in
openssl_x509_parse()
https://bugzilla.redhat.com/show_bug.cgi?id=1036830
-------------------------------------------------------------------------------
-

This update can be installed with the "yum" update program. Use
su -c 'yum update php' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung