Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in Varnish
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in Varnish
ID: FEDORA-2013-24018
Distribution: Fedora
Plattformen: Fedora 20
Datum: Di, 6. Mai 2014, 08:11
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-0345
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4484
Applikationen: Varnish

Originalnachricht

Name        : varnish
Product : Fedora 20
Version : 3.0.5
Release : 1.fc20
URL : http://www.varnish-cache.org/
Summary : High-performance HTTP accelerator
Description :
This is Varnish Cache, a high-performance HTTP accelerator.
Documentation wiki and additional information about Varnish is
available on the following web site: http://www.varnish-cache.org/

-------------------------------------------------------------------------------
-
Update Information:

New upstream release 3.0.5. List of changes available at https://www.varnish-cache.org/releases/varnish-cache-3.0.5
- Changed default mask for varnish log dir to 700, closing #915413
- Added a patch for CVE-2013-4484 from upstream, closing #1025128

-------------------------------------------------------------------------------
-
ChangeLog:

* Tue Dec 3 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> 3.0.5-1
- New upstream release
- Dropped patch for CVE-2013-4484, as it's in upstream
* Thu Nov 21 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> 3.0.4-2
- Changed default mask for varnish log dir to 700, closing #915413
- Added a patch for CVE-2013-4484 from upstream, closing #1025128
* Mon Aug 12 2013 Ingvar Hagelund <ingvar@redpill-linpro.com> 3.0.4-1
- New upstream release
- Added libedit-devel to the build reqs
- Changed the old-style initrc sed patching to a blacklist as in upstream
- Some tab vs space cleanup to make rpmlint more happy
- Added requirement of redhat-rpm-config, which provides redhat-hardened-cc1,
needed for _hardened_build, closes #975147
- Removed no-pcre patch, as pcre is now switched off by default upstream
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1025128 - CVE-2013-4484 varnish: denial of service handling
certain GET requests [fedora-all]
https://bugzilla.redhat.com/show_bug.cgi?id=1025128
[ 2 ] Bug #915413 - CVE-2013-0345 varnish: world-readable log files
[fedora-all]
https://bugzilla.redhat.com/show_bug.cgi?id=915413
-------------------------------------------------------------------------------
-

This update can be installed with the "yum" update program. Use
su -c 'yum update varnish' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung