Login
Newsletter
Werbung

Sicherheit: Preisgabe von Informationen in libgcrypt
Aktuelle Meldungen Distributionen
Name: Preisgabe von Informationen in libgcrypt
ID: 201408-10
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Fr, 29. August 2014, 23:05
Referenzen: http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-5270
Applikationen: libgcrypt

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--1bTPWbpFODiEHiFi4sBIUxxGg2x47uWj8
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201408-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Libgcrypt: Side-channel attack
Date: August 29, 2014
Bugs: #519396
ID: 201408-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Libgcrypt could allow a remote attacker to extract
ElGamal private key information.

Background
==========

Libgcrypt is a general purpose cryptographic library derived out of
GnuPG.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/libgcrypt < 1.5.4 >= 1.5.4

Description
===========

A vulnerability in the implementation of ElGamal decryption procedures
of Libgcrypt leaks information to various side-channels.

Impact
======

A physical side-channel attack allows a remote attacker to fully
extract decryption keys during the decryption of a chosen ciphertext.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Libgcrypt users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libgcrypt-1.5.4"

References
==========

[ 1 ] CVE-2014-5270
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-5270

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201408-10.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--1bTPWbpFODiEHiFi4sBIUxxGg2x47uWj8
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIcBAEBCgAGBQJUAFJJAAoJEPw7F94F4Tage4EP/19FAyo96yhF/rHA7gGaG6uB
ZUIMKvNLsbzI+/ZtscEgvg0XMVZtNd5KfiiRZ0aP+G8+Y64Yge+f0S/YbDvNDXC+
fSe34NVs79n6VMgVaccdF35RoS986B5n13FuQiFfyDXjqRy8mcLbMOa2SFmehy3d
1PP12PHtLfUp7RvC0ZGAI4qH/ZoXZp5TExuQMN9uqAsnXPN72JZXxNe6KtUfiQZH
4djZ2NGgBiickKRYUp+V3KJxlYc7YMUp791xMDomg1HSvWkUkl+gs3w/tDEUveja
S7H0Xsyw4jF3oQXGcdTLS7tn3joPqyH8zFv0hewtFka/nzQjrjCcEnKRnBV2lyjh
JE4O9kKEbmvEm6bfuPvigiNXzM0VMLz1mluJjsyhnD9Fxt8lnf2gRnxREW82W7pL
EDWDGIgH4UqD85eVWJLcum2oR/dRoNDgjlcYfJIpRdhGjl7kvVUiVsdTt5QJhQe4
nSavUYg1AbuMTttl2t82XfwC8l7WE302xITlXo6Sv7e9bZKCW/HugmFaF1D6P0og
EAwRzj85ZS77mJKN7Z/fLYu83V0pN2Fhf0hNkyBWph4stUG/dOvhU7vWtlpdGxlX
Mh59KYnQEpip42kvB5KcZDu9SyhOABErYANVm1ljgiwhsAJx8m3IjJzzNA5xrDTV
q7iWqxU23rN9mBKUvowR
=Gxty
-----END PGP SIGNATURE-----

--1bTPWbpFODiEHiFi4sBIUxxGg2x47uWj8--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung