Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in MCollective
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in MCollective
ID: 201412-15
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: So, 14. Dezember 2014, 00:30
Referenzen: http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3248
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3251
Applikationen: MCollective

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--1Uwd4lJfmQN2i8hCa04wJSp1DSauxRNcs
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201412-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: MCollective: Privilege escalation
Date: December 13, 2014
Bugs: #513292, #517286
ID: 201412-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Two vulnerabilities have been found in MCollective, the worst of which
could lead to privilege escalation.

Background
==========

MCollective is a framework to build server orchestration or parallel
job execution systems.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-admin/mcollective < 2.5.3 >= 2.5.3

Description
===========

Two vulnerabilities have been found in MCollective:

* An untrusted search path vulnerability exists in MCollective
(CVE-2014-3248)
* MCollective does not properly validate server certificates
(CVE-2014-3251)

Impact
======

A local attacker can execute arbitrary a Trojan horse shared library,
potentially resulting in arbitrary code execution and privilege
escalation. Furthermore, a local attacker may be able to establish
unauthorized MCollective connections.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All MCollective users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-admin/mcollective-2.5.3"

References
==========

[ 1 ] CVE-2014-3248
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3248
[ 2 ] CVE-2014-3251
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3251

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201412-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--1Uwd4lJfmQN2i8hCa04wJSp1DSauxRNcs
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iF4EAREIAAYFAlSMfFYACgkQAnl3SfnYR/it0QD/Wh95XitNBuknlrwbEVW/IwZf
bhCV0jU98AcBWISNgusBAILP/IkKzS1IAVSUqtFH1GgYUf3wNgofXSW39vxLCOX1
=DP2E
-----END PGP SIGNATURE-----

--1Uwd4lJfmQN2i8hCa04wJSp1DSauxRNcs--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung