Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in popt
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in popt
ID: SUSE-SU-2014:1697-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Desktop 11 SP3, SUSE Linux Enterprise Server 11 SP3 for VMware, SUSE Linux Enterprise Server 11 SP3, SUSE Linux Enterprise Software Development Kit 11 SP3
Datum: Mi, 24. Dezember 2014, 09:32
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-6435
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8118
Applikationen: popt

Originalnachricht

   SUSE Security Update: Security update for popt
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:1697-1
Rating: important
References: #892431 #906803 #908128
Cross-References: CVE-2013-6435 CVE-2014-8118
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Desktop 11 SP3
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:


This rpm update fixes the following security and non security issues.

* bnc#908128: check for bad invalid name sizes (CVE-2014-8118)
* bnc#906803: create files with mode 0 (CVE-2013-6435)
* bnc#892431: honor --noglob in install mode

Security Issues:

* CVE-2014-8118
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-8118>
* CVE-2013-6435
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-6435>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP3:

zypper in -t patch sdksp3-popt-10097

- SUSE Linux Enterprise Server 11 SP3 for VMware:

zypper in -t patch slessp3-popt-10097

- SUSE Linux Enterprise Server 11 SP3:

zypper in -t patch slessp3-popt-10097

- SUSE Linux Enterprise Desktop 11 SP3:

zypper in -t patch sledsp3-popt-10097

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP3 (i586 ia64 ppc64
s390x x86_64):

popt-devel-1.7-37.60.2
rpm-devel-4.4.2.3-37.60.2

- SUSE Linux Enterprise Software Development Kit 11 SP3 (ppc64 s390x
x86_64):

rpm-32bit-4.4.2.3-37.60.2

- SUSE Linux Enterprise Software Development Kit 11 SP3 (ppc64):

popt-devel-32bit-1.7-37.60.2
rpm-devel-32bit-4.4.2.3-37.60.2

- SUSE Linux Enterprise Software Development Kit 11 SP3 (ia64):

rpm-x86-4.4.2.3-37.60.2

- SUSE Linux Enterprise Server 11 SP3 for VMware (i586 x86_64):

popt-1.7-37.60.2
rpm-4.4.2.3-37.60.2

- SUSE Linux Enterprise Server 11 SP3 for VMware (x86_64):

popt-32bit-1.7-37.60.2
rpm-32bit-4.4.2.3-37.60.2

- SUSE Linux Enterprise Server 11 SP3 (i586 ia64 ppc64 s390x x86_64):

popt-1.7-37.60.2
rpm-4.4.2.3-37.60.2

- SUSE Linux Enterprise Server 11 SP3 (ppc64 s390x x86_64):

popt-32bit-1.7-37.60.2
rpm-32bit-4.4.2.3-37.60.2

- SUSE Linux Enterprise Server 11 SP3 (ia64):

popt-x86-1.7-37.60.2
rpm-x86-4.4.2.3-37.60.2

- SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64):

popt-1.7-37.60.2
rpm-4.4.2.3-37.60.2

- SUSE Linux Enterprise Desktop 11 SP3 (x86_64):

popt-32bit-1.7-37.60.2
rpm-32bit-4.4.2.3-37.60.2


References:

http://support.novell.com/security/cve/CVE-2013-6435.html
http://support.novell.com/security/cve/CVE-2014-8118.html
https://bugzilla.suse.com/show_bug.cgi?id=892431
https://bugzilla.suse.com/show_bug.cgi?id=906803
https://bugzilla.suse.com/show_bug.cgi?id=908128
?keywords=25800fa95867098c22bbab2dce9ea93b

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung