Login
Newsletter
Werbung

Sicherheit: Mangelnde Rechteprüfung in policycoreutils
Aktuelle Meldungen Distributionen
Name: Mangelnde Rechteprüfung in policycoreutils
ID: 201412-44
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Sa, 27. Dezember 2014, 01:52
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-3215
Applikationen: policycoreutils

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--N4AfUn5UkTtUK3hAa6xoBH9Nos3mfJPSR
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201412-44
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: policycoreutils: Privilege escalation
Date: December 26, 2014
Bugs: #509896
ID: 201412-44

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in policycoreutils could lead to local privilege
escalation.

Background
==========

policycoreutils is a collection of SELinux policy utilities.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-apps/policycoreutils
< 2.2.5-r4 >= 2.2.5-r4

Description
===========

The seunshare utility is owned by root with 4755 permissions which can
be exploited by a setuid system call.

Impact
======

A local attacker may be able to gain escalated privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All policycoreutils users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=sys-apps/policycoreutils-2.2.5-r4"

References
==========

[ 1 ] CVE-2014-3215
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3215

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201412-44.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--N4AfUn5UkTtUK3hAa6xoBH9Nos3mfJPSR
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG/MacGPG2 v2.0.22 (Darwin)
Comment: GPGTools - https://gpgtools.org

iQIcBAEBCgAGBQJUnbOkAAoJEHUQoJc5cxF0BkAQAKqrjj/p3A/JVxlC/GN6yTFj
o+2zIuvnCexvUgK18wmkRwrlSOnillG//+1WOGqVIU9z12y4IFV72g6cn6hJFtDg
LjeRoiLnVYSd4GBHwY6+W15c5j5jObZ5Gftjc1UptBFNc9SGQFG4snS+T7JNzK7P
8fMQUdgmmyvt9Sxcr4DQgLbfJ3UxiglSReSWAV92WpQaLxbrVPhxU96r1RupHUZ6
UGMFspdpHCQgHjluoqSmmTF6NobLEbmZD309aYezoPSOZRYw6zGBkX9noV/QGP6h
7jngDkiu/1bW5AcqYLzCwcbwD0vLe0wPqI73Ibf0RVU7aUidUe4iHkabmd0trNkG
JV9foj5qVnI0nHR47aqKAzu1PGY0SIERXlPZUFD+ksWT2KCDcwtrFIX+h+9aZpiQ
q1amv3MvzKX3rIRcgie/Lxnxv2UMeFR5Laon+xxlOHGEfvJwo8fwOlQ/fpbvProZ
ICUioXivlNODpL+aIkbJ0gVI/p2gJSugFfv6yPLT6ejIpd0IefvnSs5dolQuR6Ri
tgZMGy0+I/z9Hwh2YSjmmQxQlfkq5+sKdGukm0Hs3MUp/D4wUlZYOEytiZEhuLcP
/zDep+BAUAIm0noeQpa/chL6naYOTR5vKQuXkelkSBk6jnyqJtBFuzcutTBQ5SHV
6OpN9NgDneC0d7mewLSa
=kvmH
-----END PGP SIGNATURE-----

--N4AfUn5UkTtUK3hAa6xoBH9Nos3mfJPSR--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung