Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in libuser
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in libuser
ID: FEDORA-2015-12064
Distribution: Fedora
Plattformen: Fedora 21
Datum: Mo, 3. August 2015, 07:27
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-3246
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-3245
Applikationen: libuser

Originalnachricht

Name        : libuser
Product : Fedora 21
Version : 0.62
Release : 1.fc21
URL : https://fedorahosted.org/libuser/
Summary : A user and group account administration library
Description :
The libuser library implements a standardized interface for manipulating
and administering user and group accounts. The library uses pluggable
back-ends to interface to its data sources.

Sample applications modeled after those included with the shadow password
suite are included.

-------------------------------------------------------------------------------
-
Update Information:

Security fix for CVE-2015-3245, CVE-2015-3246
-------------------------------------------------------------------------------
-
ChangeLog:

* Thu Jul 23 2015 Miloslav Trmač <mitr@redhat.com> - 0.62-1
- Update to libuser-0.62
Resolves: #1246225 (CVE-2015-3245, CVE-2015-3246)
* Wed Jun 17 2015 Fedora Release Engineering
<rel-eng@lists.fedoraproject.org> - 0.61-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Wed Mar 25 2015 Miloslav Trmač <mitr@redhat.com> - 0.61-1
- Update to libuser-0.61, notably adding Python 3 bindings
Resolves: #1014555
- Filter out libuser plugin and Python extension Provides:
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.60-7
- Rebuilt for Fedora 23 Change
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1233043 - CVE-2015-3245 libuser does not filter newline characters
in the GECOS field
https://bugzilla.redhat.com/show_bug.cgi?id=1233043
[ 2 ] Bug #1233052 - CVE-2015-3246 libuser: Security flaw in handling
/etc/passwd file
https://bugzilla.redhat.com/show_bug.cgi?id=1233052
-------------------------------------------------------------------------------
-

This update can be installed with the "yum" update program. Use
su -c 'yum update libuser' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung