Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in Git
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in Git
ID: 201509-06
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Do, 24. September 2015, 22:05
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-9390
Applikationen: Git

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--AxPVC6ULPDSDdt7gSgAINJ6TI056QFo2D
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201509-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Git: Arbitrary command execution
Date: September 24, 2015
Bugs: #532984
ID: 201509-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An attacker could execute arbitrary commands via Git repositories in a
case-insensitive or case-normalizing filesystem.

Background
==========

Git is a free and open source distributed version control system
designed to handle everything from small to very large projects with
speed and efficiency.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-vcs/git < 2.0.5 *>= 1.8.5.6
*>= 1.9.5
>= 2.0.5

Description
===========

A vulnerability in Git causing Git-compatible clients that access
case-insensitive or case-normalizing filesystems to overwrite the
.git/config when cloning or checking out a repository, leading to
execution of arbitrary commands.

Impact
======

An attacker can execute arbitrary commands on a client machine that
clones a crafted malicious Git tree.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Git 1.8.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-vcs/git-1.8.5.6"

All Git 1.9.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-vcs/git-1.9.5"

All Git 2.0.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-vcs/git-2.0.5"

References
==========

[ 1 ] CVE-2014-9390
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-9390

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201509-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2015 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



--AxPVC6ULPDSDdt7gSgAINJ6TI056QFo2D
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQEcBAEBCgAGBQJWBCwKAAoJECULev7WN52FeYwIAJGJBf/fMOGoE8ruyAqoRTKF
HCm+M6N3IVnh8x9m5d/hnrBbZ4pW0gO6QhjgzJ7l31tC962bLc+kI4pZFHvR0XcE
1F+cX0Nt5zDdUriAHcxjG+A2g2H8FoJdZzRMR6pZUqMKVmATUNmtrZ4/sDPO/D4s
f+LQ2h02NsaOTFBBGuk24zS6Pm11xJbn9tum90/eEmZHcf6TKEQ7t0vNSQSUUr/l
l8SnkdSzLj82tvt5yPDV5oOVVn27Z0KUpuZ7meBXUW+9hMPFWK3eZQMLKB2khrac
uBSbE7AW9pf+xo3xHr3HFCRTOZrpwYWNZIjihVPczq2SpB7All+QUR/rAXhtk6s=
=cAGr
-----END PGP SIGNATURE-----

--AxPVC6ULPDSDdt7gSgAINJ6TI056QFo2D--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung