Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in openstack-ironic-discoverd
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in openstack-ironic-discoverd
ID: RHSA-2015:1929-01
Distribution: Red Hat
Plattformen: Red Hat Enterprise Linux OpenStack Platform
Datum: Do, 22. Oktober 2015, 23:21
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5306
Applikationen: openstack-ironic-discoverd

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Important: openstack-ironic-discoverd security update
Advisory ID: RHSA-2015:1929-01
Product: Red Hat Enterprise Linux OpenStack Platform
Advisory URL: https://access.redhat.com/errata/RHSA-2015:1929
Issue date: 2015-10-22
CVE Names: CVE-2015-5306
=====================================================================

1. Summary:

Updated openstack-ironic-discoverd packages that fix one security issue are
now available for Red Hat Enterprise Linux OpenStack Platform 7.0.

Red Hat Product Security has rated this update as having Important security
impact. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available from the CVE link in the
References section.

2. Relevant releases/architectures:

OpenStack 7.0 Director for RHEL 7 - noarch

3. Description:

Ironic provides bare metal provisioning for OpenStack nodes.

It was discovered that enabling debug mode in openstack-ironic-discoverd
also enables debug mode in the underlying Flask framework. If errors are
encountered while Flask is in debug mode, a user experiencing an error may
be able to access the debug console (effectively, a command shell).
(CVE-2015-5306)

All openstack-ironic-discoverd users are advised to upgrade to these
updated packages, which correct this issue.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

For details on how to apply this update, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1256421 - Incorrect RAM report
1273698 - CVE-2015-5306 openstack-ironic-discoverd: potential remote code
execution with debug mode enabled

6. Package List:

OpenStack 7.0 Director for RHEL 7:

Source:
openstack-ironic-discoverd-1.1.0-8.el7ost.src.rpm

noarch:
openstack-ironic-discoverd-1.1.0-8.el7ost.noarch.rpm
openstack-ironic-discoverd-ramdisk-1.1.0-8.el7ost.noarch.rpm
python-ironic-discoverd-1.1.0-8.el7ost.noarch.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2015-5306
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2015 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFWKUGdXlSAg2UNWIIRApu+AJ43oSwTrXPe428gIreOc0hRRyMjXACfc83c
gi30TIZ/c+d7frLe6iAKVhA=
=eg7y
-----END PGP SIGNATURE-----


--
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung