Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in php-ZendFramework
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in php-ZendFramework
ID: FEDORA-2015-2e7c06c639
Distribution: Fedora
Plattformen: Fedora 23
Datum: So, 8. November 2015, 23:53
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5723
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5161
Applikationen: php-ZendFramework

Originalnachricht

Name        : php-ZendFramework
Product : Fedora 23
Version : 1.12.16
Release : 1.fc23
URL : http://framework.zend.com/
Summary : Leading open-source PHP framework
Description :
Extending the art & spirit of PHP, Zend Framework is based on simplicity,
object-oriented best practices, corporate friendly licensing, and a rigorously
tested agile code base. Zend Framework is focused on building more secure,
reliable, and modern Web 2.0 applications & web services, and consuming
widely
available APIs from leading vendors like Google, Amazon, Yahoo!, Flickr, as
well as API providers and catalogers like StrikeIron and ProgrammableWeb.

-------------------------------------------------------------------------------
-
Update Information:

Update to 1.12.16 - fixes CVE-2015-5161:
http://framework.zend.com/security/advisory/ZF2015-06 - fixes CVE-2015-5723:
http://framework.zend.com/security/advisory/ZF2015-07 - removed services:
DeveloperGarden, Technorati
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #1269080 - CVE-2015-5723 php-ZendFramework: various flaws
[epel-all]
https://bugzilla.redhat.com/show_bug.cgi?id=1269080
[ 2 ] Bug #1253255 - CVE-2015-5161 php-ZendFramework: XML external entity
injection (XXE) on PHP FPM [epel-7]
https://bugzilla.redhat.com/show_bug.cgi?id=1253255
[ 3 ] Bug #1253253 - CVE-2015-5161 php-ZendFramework: XML external entity
injection (XXE) on PHP FPM [epel-6]
https://bugzilla.redhat.com/show_bug.cgi?id=1253253
[ 4 ] Bug #1269081 - CVE-2015-5723 php-ZendFramework: various flaws
[fedora-all]
https://bugzilla.redhat.com/show_bug.cgi?id=1269081
[ 5 ] Bug #1253251 - CVE-2015-5161 php-ZendFramework: XML external entity
injection (XXE) on PHP FPM [fedora-all]
https://bugzilla.redhat.com/show_bug.cgi?id=1253251
-------------------------------------------------------------------------------
-

This update can be installed with the "yum" update program. Use
su -c 'yum update php-ZendFramework' at the command line.
For more information, refer to "Managing Software with yum",
available at https://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung