Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in Linux
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in Linux
ID: SUSE-SU-2015:2084-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Live Patching 12
Datum: Di, 24. November 2015, 23:25
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-7613
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5707
Applikationen: Linux

Originalnachricht

   SUSE Security Update: Security update for Linux Kernel Live Patch 5
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:2084-1
Rating: important
References: #940338 #940342 #948536 #948701
Cross-References: CVE-2015-5707 CVE-2015-7613
Affected Products:
SUSE Linux Enterprise Live Patching 12
______________________________________________________________________________

An update that solves two vulnerabilities and has two fixes
is now available.

Description:


This kernel live patch for Linux Kernel 3.12.43-52.6.1 fixes two security
issues:

- CVE-2015-7613: A race condition in the IPC object implementation in the
Linux kernel allowed local users to gain privileges by triggering an
ipc_addid call that leads to uid and gid comparisons against
uninitialized data, related to msg.c, shm.c, and util.c. (bsc#948701
bsc#948536)
- CVE-2015-5707: Integer overflow in the sg_start_req function in
drivers/scsi/sg.c in the Linux kernel allowed local users to cause a
denial of service or possibly have unspecified other impact via a large
iov_count value in a write request. (bsc#940342 bsc#940338)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Live Patching 12:

zypper in -t patch SUSE-SLE-Live-Patching-12-2015-887=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Live Patching 12 (x86_64):

kgraft-patch-3_12_43-52_6-default-3-2.1
kgraft-patch-3_12_43-52_6-xen-3-2.1


References:

https://www.suse.com/security/cve/CVE-2015-5707.html
https://www.suse.com/security/cve/CVE-2015-7613.html
https://bugzilla.suse.com/940338
https://bugzilla.suse.com/940342
https://bugzilla.suse.com/948536
https://bugzilla.suse.com/948701

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung