Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in GNU C library
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in GNU C library
ID: RHSA-2015:2589-01
Distribution: Red Hat
Plattformen: Red Hat Enterprise Linux
Datum: So, 13. Dezember 2015, 15:16
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-5277
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1472
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-7423
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1473
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1781
Applikationen: GNU C library

Originalnachricht

=====================================================================
Red Hat Security Advisory

Synopsis: Important: glibc security update
Advisory ID: RHSA-2015:2589-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2015-2589.html
Issue date: 2015-12-09
CVE Names: CVE-2013-7423 CVE-2015-1472 CVE-2015-1473
CVE-2015-1781 CVE-2015-5277
=====================================================================

1. Summary:

Updated glibc packages that fix multiple security issues are now available
for Red Hat Enterprise Linux 7.1 Extended Update Support.

Red Hat Product Security has rated this update as having Important security
impact. Common Vulnerability Scoring System (CVSS) base scores, which give
detailed severity ratings, are available for each vulnerability from the
CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.1) - x86_64
Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.1) - x86_64
Red Hat Enterprise Linux Server EUS (v. 7.1) - ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Server Optional EUS (v. 7.1) - ppc64, ppc64le, s390x,
x86_64

3. Description:

The glibc packages provide the standard C libraries (libc), POSIX thread
libraries (libpthread), standard math libraries (libm), and the Name
Server Caching Daemon (nscd) used by multiple programs on the system.
Without these libraries, the Linux system cannot function correctly.

It was discovered that the nss_files backend for the Name Service Switch in
glibc would return incorrect data to applications or corrupt the heap
(depending on adjacent heap contents). A local attacker could potentially
use this flaw to execute arbitrary code on the system. (CVE-2015-5277)

It was discovered that, under certain circumstances, glibc's getaddrinfo()
function would send DNS queries to random file descriptors. An attacker
could potentially use this flaw to send DNS queries to unintended
recipients, resulting in information disclosure or data loss due to the
application encountering corrupted data. (CVE-2013-7423)

A buffer overflow flaw was found in the way glibc's gethostbyname_r() and
other related functions computed the size of a buffer when passed a
misaligned buffer as input. An attacker able to make an application call
any of these functions with a misaligned buffer could use this flaw to
crash the application or, potentially, execute arbitrary code with the
permissions of the user running the application. (CVE-2015-1781)

A heap-based buffer overflow flaw and a stack overflow flaw were found in
glibc's swscanf() function. An attacker able to make an application call
the swscanf() function could use these flaws to crash that application or,
potentially, execute arbitrary code with the permissions of the user
running the application. (CVE-2015-1472, CVE-2015-1473)

The CVE-2015-5277 issue was discovered by Sumit Bose and Lukáš Slebodník of
Red Hat, and the CVE-2015-1781 issue was discovered by Arjun Shankar of Red
Hat.

All glibc users are advised to upgrade to these updated packages, which
contain backported patches to correct these issues.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

For details on how to apply this update, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1187109 - CVE-2013-7423 glibc: getaddrinfo() writes DNS queries to random file
descriptors under high load
1188235 - CVE-2015-1472 glibc: heap buffer overflow in glibc swscanf
1199525 - CVE-2015-1781 glibc: buffer overflow in gethostbyname_r() and related
functions with misaligned buffer
1209105 - CVE-2015-1473 glibc: Stack-overflow in glibc swscanf
1262914 - CVE-2015-5277 glibc: data corruption while reading the NSS files
database

6. Package List:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.1):

Source:
glibc-2.17-79.el7_1.src.rpm

x86_64:
glibc-2.17-79.el7_1.i686.rpm
glibc-2.17-79.el7_1.x86_64.rpm
glibc-common-2.17-79.el7_1.x86_64.rpm
glibc-debuginfo-2.17-79.el7_1.i686.rpm
glibc-debuginfo-2.17-79.el7_1.x86_64.rpm
glibc-debuginfo-common-2.17-79.el7_1.i686.rpm
glibc-debuginfo-common-2.17-79.el7_1.x86_64.rpm
glibc-devel-2.17-79.el7_1.i686.rpm
glibc-devel-2.17-79.el7_1.x86_64.rpm
glibc-headers-2.17-79.el7_1.x86_64.rpm
glibc-utils-2.17-79.el7_1.x86_64.rpm
nscd-2.17-79.el7_1.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.1):

x86_64:
glibc-debuginfo-2.17-79.el7_1.i686.rpm
glibc-debuginfo-2.17-79.el7_1.x86_64.rpm
glibc-debuginfo-common-2.17-79.el7_1.i686.rpm
glibc-debuginfo-common-2.17-79.el7_1.x86_64.rpm
glibc-static-2.17-79.el7_1.i686.rpm
glibc-static-2.17-79.el7_1.x86_64.rpm

Red Hat Enterprise Linux Server EUS (v. 7.1):

Source:
glibc-2.17-79.el7_1.src.rpm

ppc64:
glibc-2.17-79.el7_1.ppc.rpm
glibc-2.17-79.el7_1.ppc64.rpm
glibc-common-2.17-79.el7_1.ppc64.rpm
glibc-debuginfo-2.17-79.el7_1.ppc.rpm
glibc-debuginfo-2.17-79.el7_1.ppc64.rpm
glibc-debuginfo-common-2.17-79.el7_1.ppc.rpm
glibc-debuginfo-common-2.17-79.el7_1.ppc64.rpm
glibc-devel-2.17-79.el7_1.ppc.rpm
glibc-devel-2.17-79.el7_1.ppc64.rpm
glibc-headers-2.17-79.el7_1.ppc64.rpm
glibc-utils-2.17-79.el7_1.ppc64.rpm
nscd-2.17-79.el7_1.ppc64.rpm

s390x:
glibc-2.17-79.el7_1.s390.rpm
glibc-2.17-79.el7_1.s390x.rpm
glibc-common-2.17-79.el7_1.s390x.rpm
glibc-debuginfo-2.17-79.el7_1.s390.rpm
glibc-debuginfo-2.17-79.el7_1.s390x.rpm
glibc-debuginfo-common-2.17-79.el7_1.s390.rpm
glibc-debuginfo-common-2.17-79.el7_1.s390x.rpm
glibc-devel-2.17-79.el7_1.s390.rpm
glibc-devel-2.17-79.el7_1.s390x.rpm
glibc-headers-2.17-79.el7_1.s390x.rpm
glibc-utils-2.17-79.el7_1.s390x.rpm
nscd-2.17-79.el7_1.s390x.rpm

x86_64:
glibc-2.17-79.el7_1.i686.rpm
glibc-2.17-79.el7_1.x86_64.rpm
glibc-common-2.17-79.el7_1.x86_64.rpm
glibc-debuginfo-2.17-79.el7_1.i686.rpm
glibc-debuginfo-2.17-79.el7_1.x86_64.rpm
glibc-debuginfo-common-2.17-79.el7_1.i686.rpm
glibc-debuginfo-common-2.17-79.el7_1.x86_64.rpm
glibc-devel-2.17-79.el7_1.i686.rpm
glibc-devel-2.17-79.el7_1.x86_64.rpm
glibc-headers-2.17-79.el7_1.x86_64.rpm
glibc-utils-2.17-79.el7_1.x86_64.rpm
nscd-2.17-79.el7_1.x86_64.rpm

Red Hat Enterprise Linux Server EUS (v. 7.1):

Source:
glibc-2.17-79.ael7b_1.src.rpm

ppc64le:
glibc-2.17-79.ael7b_1.ppc64le.rpm
glibc-common-2.17-79.ael7b_1.ppc64le.rpm
glibc-debuginfo-2.17-79.ael7b_1.ppc64le.rpm
glibc-debuginfo-common-2.17-79.ael7b_1.ppc64le.rpm
glibc-devel-2.17-79.ael7b_1.ppc64le.rpm
glibc-headers-2.17-79.ael7b_1.ppc64le.rpm
glibc-utils-2.17-79.ael7b_1.ppc64le.rpm
nscd-2.17-79.ael7b_1.ppc64le.rpm

Red Hat Enterprise Linux Server Optional EUS (v. 7.1):

ppc64:
glibc-debuginfo-2.17-79.el7_1.ppc.rpm
glibc-debuginfo-2.17-79.el7_1.ppc64.rpm
glibc-debuginfo-common-2.17-79.el7_1.ppc.rpm
glibc-debuginfo-common-2.17-79.el7_1.ppc64.rpm
glibc-static-2.17-79.el7_1.ppc.rpm
glibc-static-2.17-79.el7_1.ppc64.rpm

s390x:
glibc-debuginfo-2.17-79.el7_1.s390.rpm
glibc-debuginfo-2.17-79.el7_1.s390x.rpm
glibc-debuginfo-common-2.17-79.el7_1.s390.rpm
glibc-debuginfo-common-2.17-79.el7_1.s390x.rpm
glibc-static-2.17-79.el7_1.s390.rpm
glibc-static-2.17-79.el7_1.s390x.rpm

x86_64:
glibc-debuginfo-2.17-79.el7_1.i686.rpm
glibc-debuginfo-2.17-79.el7_1.x86_64.rpm
glibc-debuginfo-common-2.17-79.el7_1.i686.rpm
glibc-debuginfo-common-2.17-79.el7_1.x86_64.rpm
glibc-static-2.17-79.el7_1.i686.rpm
glibc-static-2.17-79.el7_1.x86_64.rpm

Red Hat Enterprise Linux Server Optional EUS (v. 7.1):

ppc64le:
glibc-debuginfo-2.17-79.ael7b_1.ppc64le.rpm
glibc-debuginfo-common-2.17-79.ael7b_1.ppc64le.rpm
glibc-static-2.17-79.ael7b_1.ppc64le.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2013-7423
https://access.redhat.com/security/cve/CVE-2015-1472
https://access.redhat.com/security/cve/CVE-2015-1473
https://access.redhat.com/security/cve/CVE-2015-1781
https://access.redhat.com/security/cve/CVE-2015-5277
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2015 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iD8DBQFWaAjFXlSAg2UNWIIRAqokAKC0aLqDf57HbtwD3FAwRH36DkG2bwCgpiHu
dnRSyot5nK1GdxiUPgMF99E=
=aoOW
-----END PGP SIGNATURE-----


--
Enterprise-watch-list mailing list
Enterprise-watch-list@redhat.com
https://www.redhat.com/mailman/listinfo/enterprise-watch-list
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung