Login
Newsletter
Werbung

Sicherheit: Umgehung des Passworts in GRUB
Aktuelle Meldungen Distributionen
Name: Umgehung des Passworts in GRUB
ID: 201512-03
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: So, 20. Dezember 2015, 14:26
Referenzen: https://wiki.gentoo.org/wiki/GRUB2_Quick_Start
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-8370
Applikationen: GRUB

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--L6j6SJobNwGtfAuD129kJFrwnNB5BDL0O
Content-Type: text/plain; charset=utf-
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201512-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GRUB: Authentication bypass
Date: December 19, 2015
Bugs: #568326
ID: 201512-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

GRUB's authentication prompt can be bypassed by entering a sequence of
backspace characters.

Background
==========

GNU GRUB is a multiboot boot loader used by most Linux systems.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-boot/grub < 2.02_beta2-r8 *>= 0.97 *
>= 2.02_beta2-r8 *
-------------------------------------------------------------------
NOTE: Packages marked with asterisks require manual intervention!

Description
===========

An integer underflow in GRUB's username/password authentication code
has been discovered.

Impact
======

An attacker with access to the system console may bypass the username
prompt by entering a sequence of backspace characters, allowing them
e.g. to get full access to GRUB's console or to load a customized
kernel.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GRUB 2.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-boot/grub-2.02_beta2-r8"

After upgrading, make sure to run the grub2-install command with
options appropriate for your system. See the GRUB2 Quick Start guide in
the references below for examples. Your system will be vulnerable until
this action is performed.

References
==========

[ 1 ] CVE-2015-8370
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-8370
[ 2 ] GRUB2 Quick Start guide
https://wiki.gentoo.org/wiki/GRUB2_Quick_Start

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201512-03

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2015 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--L6j6SJobNwGtfAuD129kJFrwnNB5BDL0O
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJWdWf9AAoJEFc90n/Ha1ljc0AQAIO/Urdk33YQKUhwYrtO7XNK
nH/lcmQAYcskLVOMBXHBRw3DKquSRYmmqSxiQA+irfpIq8dSh7dzaCsRaQwoRj0F
LXgX/oGlJ9lJOCTL/zXQR1e2JAwa7cgR1vFKhvMpK57jxZba1iy3NBXa+kwe1OQd
FlMfopK6pgg5+uajYZ+Aj5VrzMSFjn6qjPFzrP31JrruoemjjyCWXY1w7nKvZInE
vGeDnlyofIar0k9AzpUBFuHu3N1F3CDzOpoIFsC/gml072inaqA3Md9DYHbNVgKr
V6MvCML6fuCvvhVkORnq1YD0mbhDaZI23UNYEtD6RNLnE8eCxpd8UJizt/CzYrXF
8xOgb2ge7MKEN+i1qP9dblN59RjS8HgKGVpi19JvKyEkJlJOfyjf/eFk/9r5bRfF
fJNnPfrWAvvoO3nc6piksczE4CuDCbI5Ig/YlCblfAeBmuMOp/77rc2FaUqpeBpc
pC5Pq5OJRPN21bajZXg8L8TtXDVeoi3+S0Y+scx9M+xAAA/CoHufBKo0xUazN/fD
moD9llK1tMi+T1/VYx8MiL0wRrPzmH2lLYTKaly9V2UMKqSSOHvVn4mIeyXbwOqH
aUa8cF/7rYGoijQtUBT1x2T5XxvUp9fQBpE462qP8Ovf3Ebef5TkOd2Kxvg6dxeC
5x6tPN9rjqMp5lD9Zjmd
=q8xn
-----END PGP SIGNATURE-----

--L6j6SJobNwGtfAuD129kJFrwnNB5BDL0O--
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung