Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in luxman
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in luxman
ID: DSA-693-1
Distribution: Debian
Plattformen: Debian woody
Datum: Di, 15. März 2005, 12:00
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0385
Applikationen: luxman

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

--------------------------------------------------------------------------
Debian Security Advisory DSA 693-1 security@debian.org
http://www.debian.org/security/ Martin Schulze
March 14, 2005 http://www.debian.org/security/faq
--------------------------------------------------------------------------

Package : luxman
Vulnerability : buffer overflow
Problem-Type : local
Debian-specific: no
CVE ID : CAN-2005-0385

Kevin Finisterre discovered a buffer overflow in luxman, an SVGA based
PacMan clone, that could lead to the execution of arbitrary commands
as root.

For the stable distribution (woody) this problem has been fixed in
version 0.41-17.2.

For the unstable distribution (sid) this problem has been fixed in
version 0.41-20.

We recommend that you upgrade your luxman package.


Upgrade Instructions
--------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
--------------------------------

Source archives:

http://security.debian.org/pool/updates/main/l/luxman/luxman_0.41-17.2.dsc
Size/MD5 checksum: 570 a55086f936bbcfe22598ac0aeb94f8da
luxman_0.41-17.2.diff.gz
Size/MD5 checksum: 7105 8719173e012bab5680d138d25e30b619
luxman_0.41.orig.tar.gz
Size/MD5 checksum: 268279 aa389327578e2d65f3f5035193e407cb

Intel IA-32 architecture:

luxman_0.41-17.2_i386.deb
Size/MD5 checksum: 290762 c4123222e992a37dcf609768a20e7e8f


These files will probably be moved into the stable distribution on
its next update.

--------------------------------------------------------------------------------
-
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-securitydists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)

iD8DBQFCNbpiW5ql+IAeqTIRAhtSAJ0d3a6I8wMPZUxKMaOGXtd5oZ7MJgCeI3NF
FIFFNlRq/R/T9Qs2asyHLSo=
=NXet
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung