Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in ImageWorsener
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in ImageWorsener
ID: 201706-06
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Di, 6. Juni 2017, 14:43
Referenzen: http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7940
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7453
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7454
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8326
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7939
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8327
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7452
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7962
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8325

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--fOJSVd3vCwNoo9HKGhr9o1iMKSgkKB16G
Content-Type: multipart/mixed;
boundary="Duj1pMUcd6jeAGKu2SE0Dh6C5MMq67AAf";
protected-headers="v1"
From: Thomas Deutschmann <whissi@gentoo.org>
Reply-To: security@gentoo.org
To: gentoo-announce@lists.gentoo.org
Message-ID: <ac42da09-1e69-df33-7d69-7db9539eedac@gentoo.org>
Subject: [ GLSA 201706-06 ] ImageWorsener: Multiple vulnerabilities

--Duj1pMUcd6jeAGKu2SE0Dh6C5MMq67AAf
Content-Type: text/plain; charset=utf-8
Content-Language: en-U
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201706-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: ImageWorsener: Multiple vulnerabilities
Date: June 06, 2017
Bugs: #618014
ID: 201706-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in ImageWorsener, the worst of
which allows remote attackers to cause a Denial of Service condition or
have other unspecified impact.

Background
==========

ImageWorsener is a cross-platform command-line utility and library for
image scaling and other image processing.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-gfx/imageworsener < 1.3.1 >= 1.3.1

Description
===========

Multiple vulnerabilities have been discovered in ImageWorsener. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to process a specially crafted
image file using ImageWorsener, possibly resulting in a Denial of
Service condition or have other unspecified impacts.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ImageWorsener users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=media-gfx/imageworsener-1.3.1"

References
==========

[ 1 ] CVE-2017-7452
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7452
[ 2 ] CVE-2017-7453
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7453
[ 3 ] CVE-2017-7454
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7454
[ 4 ] CVE-2017-7939
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7939
[ 5 ] CVE-2017-7940
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7940
[ 6 ] CVE-2017-7962
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7962
[ 7 ] CVE-2017-8325
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8325
[ 8 ] CVE-2017-8326
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8326
[ 9 ] CVE-2017-8327
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-8327

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201706-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


--Duj1pMUcd6jeAGKu2SE0Dh6C5MMq67AAf--

--fOJSVd3vCwNoo9HKGhr9o1iMKSgkKB16G
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0

iQJ8BAEBCgBmBQJZNmueXxSAAAAAAC4AKGlzc3Vlci1mcHJAbm90YXRpb25zLm9w
ZW5wZ3AuZmlmdGhob3JzZW1hbi5uZXQzM0M1ODQ4MkM0MDIyOTJEMkUzQzVDMDY5
NzA5RjkwQzNDOTZGRkM4AAoJEJcJ+Qw8lv/IUzwP/jxAZ0UPKk3bvPZlFyYjuE5F
/s+qU3Cmoft72YIR9C9V1XhJQaA3Iuh+0xSCU2lLQc1U/5R8X3OOY6NJld7s5mXW
Ip64kpFMKhLgOAgMdeiqGDm7p9NlCnH9JnlepRG78bwJJnZjmYVZt2Bv0syO9Vee
mhWN9g6MF71kf90ju4V9hu70sfEpwHa/Y8rGVly7V3dJ3ClAKxIHSzItRF8pcd+U
Pyi551jYUYXByHYO8dfwaJdc8CSOUD5cM6yRS7E2O8WePcoMKLhIgYilXTqYUKHq
KskK7RS0yha8VJncKMyZ1PVcgbz3MTD3HT/a7O0VHrhd2w7l3tT9UCaVBPL9v0UT
6TDf2qr0L72El1DGoaSh7CjZ8qv7Jlkek2Hgvwqr6toTI9cdnxXyG3iqZRPg2jsw
3gX2H2rwag7LdJadnvA/wrVodjsH239cqyLTE4sTHDl645X8mGTo/aO1CEujhuAc
bT0wDBSKzZw42cNlqwTcruPHrDr6sUpDBRTPUO9ei+m9csgayLW789zLpwaS3nzm
F5JKcfFGUoD20esWWfMJQlfyqVqVMlC6gjorXSSymqm7KpugrH7ToFMdGyo7NbpS
q3IkZW8PavVqT6Dyhsl26YAzV3wh20UQFvqrWFG0dIjo/vGy7pwEs31vqa3DCPUC
bl8WX6giJDN5wL4UknUp
=RpIK
-----END PGP SIGNATURE-----

--fOJSVd3vCwNoo9HKGhr9o1iMKSgkKB16G--
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung