Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in GNU C library
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in GNU C library
ID: SUSE-SU-2018:0074-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Desktop 12-SP2, SUSE Linux Enterprise Software Development Kit 12-SP2, SUSE Linux Enterprise Server 12-SP2, SUSE Linux Enterprise Server for Raspberry Pi 12-SP2, SUSE OpenStack Cloud Magnum Orchestration 7, SUSE Linux Enterprise Desktop 12-SP3, SUSE Linux Enterprise Server 12-SP3, SUSE Linux Enterprise Software Development Kit 12-SP3, SUSE CaaS Platform ALL
Datum: Fr, 12. Januar 2018, 21:03
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15804
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000408
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15671
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16997
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-15670
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1000001
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-1000409

Originalnachricht

   SUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:0074-1
Rating: important
References: #1051042 #1053188 #1063675 #1064569 #1064580
#1064583 #1070905 #1071319 #1073231 #1074293

Cross-References: CVE-2017-1000408 CVE-2017-1000409 CVE-2017-15670
CVE-2017-15671 CVE-2017-15804 CVE-2017-16997
CVE-2018-1000001
Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP3
SUSE Linux Enterprise Software Development Kit 12-SP2
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2
SUSE Linux Enterprise Server 12-SP3
SUSE Linux Enterprise Server 12-SP2
SUSE Linux Enterprise Desktop 12-SP3
SUSE Linux Enterprise Desktop 12-SP2
SUSE CaaS Platform ALL
OpenStack Cloud Magnum Orchestration 7
______________________________________________________________________________

An update that solves 7 vulnerabilities and has three fixes
is now available.

Description:

This update for glibc fixes the following issues:

- A privilege escalation bug in the realpath() function has been fixed.
[CVE-2018-1000001, bsc#1074293]

- A memory leak and a buffer overflow in the dynamic ELF loader has been
fixed. [CVE-2017-1000408, CVE-2017-1000409, bsc#1071319]

- An issue in the code handling RPATHs was fixed that could have been
exploited by an attacker to execute code loaded from arbitrary
libraries. [CVE-2017-16997, bsc#1073231]

- A potential crash caused by a use-after-free bug in pthread_create() has
been fixed. [bsc#1053188]

- A bug that prevented users to build shared objects which use the
optimized libmvec.so API has been fixed. [bsc#1070905]

- A memory leak in the glob() function has been fixed. [CVE-2017-15670,
CVE-2017-15671, CVE-2017-15804, bsc#1064569, bsc#1064580, bsc#1064583]

- A bug that would lose the syscall error code value in case of crashes
has been fixed. [bsc#1063675]


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP3:

zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-55=1

- SUSE Linux Enterprise Software Development Kit 12-SP2:

zypper in -t patch SUSE-SLE-SDK-12-SP2-2018-55=1

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:

zypper in -t patch SUSE-SLE-RPI-12-SP2-2018-55=1

- SUSE Linux Enterprise Server 12-SP3:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-55=1

- SUSE Linux Enterprise Server 12-SP2:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-55=1

- SUSE Linux Enterprise Desktop 12-SP3:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-55=1

- SUSE Linux Enterprise Desktop 12-SP2:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2018-55=1

- SUSE CaaS Platform ALL:

zypper in -t patch SUSE-CAASP-ALL-2018-55=1

- OpenStack Cloud Magnum Orchestration 7:

zypper in -t patch SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-55=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le
s390x x86_64):

glibc-debuginfo-2.22-62.3.4
glibc-debugsource-2.22-62.3.4
glibc-devel-static-2.22-62.3.4

- SUSE Linux Enterprise Software Development Kit 12-SP3 (noarch):

glibc-info-2.22-62.3.4

- SUSE Linux Enterprise Software Development Kit 12-SP2 (aarch64 ppc64le
s390x x86_64):

glibc-debuginfo-2.22-62.3.4
glibc-debugsource-2.22-62.3.4
glibc-devel-static-2.22-62.3.4

- SUSE Linux Enterprise Software Development Kit 12-SP2 (noarch):

glibc-info-2.22-62.3.4

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (aarch64):

glibc-2.22-62.3.4
glibc-debuginfo-2.22-62.3.4
glibc-debugsource-2.22-62.3.4
glibc-devel-2.22-62.3.4
glibc-devel-debuginfo-2.22-62.3.4
glibc-locale-2.22-62.3.4
glibc-locale-debuginfo-2.22-62.3.4
glibc-profile-2.22-62.3.4
nscd-2.22-62.3.4
nscd-debuginfo-2.22-62.3.4

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (noarch):

glibc-html-2.22-62.3.4
glibc-i18ndata-2.22-62.3.4
glibc-info-2.22-62.3.4

- SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):

glibc-2.22-62.3.4
glibc-debuginfo-2.22-62.3.4
glibc-debugsource-2.22-62.3.4
glibc-devel-2.22-62.3.4
glibc-devel-debuginfo-2.22-62.3.4
glibc-locale-2.22-62.3.4
glibc-locale-debuginfo-2.22-62.3.4
glibc-profile-2.22-62.3.4
nscd-2.22-62.3.4
nscd-debuginfo-2.22-62.3.4

- SUSE Linux Enterprise Server 12-SP3 (s390x x86_64):

glibc-32bit-2.22-62.3.4
glibc-debuginfo-32bit-2.22-62.3.4
glibc-devel-32bit-2.22-62.3.4
glibc-devel-debuginfo-32bit-2.22-62.3.4
glibc-locale-32bit-2.22-62.3.4
glibc-locale-debuginfo-32bit-2.22-62.3.4
glibc-profile-32bit-2.22-62.3.4

- SUSE Linux Enterprise Server 12-SP3 (noarch):

glibc-html-2.22-62.3.4
glibc-i18ndata-2.22-62.3.4
glibc-info-2.22-62.3.4

- SUSE Linux Enterprise Server 12-SP2 (aarch64 ppc64le s390x x86_64):

glibc-2.22-62.3.4
glibc-debuginfo-2.22-62.3.4
glibc-debugsource-2.22-62.3.4
glibc-devel-2.22-62.3.4
glibc-devel-debuginfo-2.22-62.3.4
glibc-locale-2.22-62.3.4
glibc-locale-debuginfo-2.22-62.3.4
glibc-profile-2.22-62.3.4
nscd-2.22-62.3.4
nscd-debuginfo-2.22-62.3.4

- SUSE Linux Enterprise Server 12-SP2 (s390x x86_64):

glibc-32bit-2.22-62.3.4
glibc-debuginfo-32bit-2.22-62.3.4
glibc-devel-32bit-2.22-62.3.4
glibc-devel-debuginfo-32bit-2.22-62.3.4
glibc-locale-32bit-2.22-62.3.4
glibc-locale-debuginfo-32bit-2.22-62.3.4
glibc-profile-32bit-2.22-62.3.4

- SUSE Linux Enterprise Server 12-SP2 (noarch):

glibc-html-2.22-62.3.4
glibc-i18ndata-2.22-62.3.4
glibc-info-2.22-62.3.4

- SUSE Linux Enterprise Desktop 12-SP3 (x86_64):

glibc-2.22-62.3.4
glibc-32bit-2.22-62.3.4
glibc-debuginfo-2.22-62.3.4
glibc-debuginfo-32bit-2.22-62.3.4
glibc-debugsource-2.22-62.3.4
glibc-devel-2.22-62.3.4
glibc-devel-32bit-2.22-62.3.4
glibc-devel-debuginfo-2.22-62.3.4
glibc-devel-debuginfo-32bit-2.22-62.3.4
glibc-locale-2.22-62.3.4
glibc-locale-32bit-2.22-62.3.4
glibc-locale-debuginfo-2.22-62.3.4
glibc-locale-debuginfo-32bit-2.22-62.3.4
nscd-2.22-62.3.4
nscd-debuginfo-2.22-62.3.4

- SUSE Linux Enterprise Desktop 12-SP3 (noarch):

glibc-i18ndata-2.22-62.3.4

- SUSE Linux Enterprise Desktop 12-SP2 (noarch):

glibc-i18ndata-2.22-62.3.4

- SUSE Linux Enterprise Desktop 12-SP2 (x86_64):

glibc-2.22-62.3.4
glibc-32bit-2.22-62.3.4
glibc-debuginfo-2.22-62.3.4
glibc-debuginfo-32bit-2.22-62.3.4
glibc-debugsource-2.22-62.3.4
glibc-devel-2.22-62.3.4
glibc-devel-32bit-2.22-62.3.4
glibc-devel-debuginfo-2.22-62.3.4
glibc-devel-debuginfo-32bit-2.22-62.3.4
glibc-locale-2.22-62.3.4
glibc-locale-32bit-2.22-62.3.4
glibc-locale-debuginfo-2.22-62.3.4
glibc-locale-debuginfo-32bit-2.22-62.3.4
nscd-2.22-62.3.4
nscd-debuginfo-2.22-62.3.4

- SUSE CaaS Platform ALL (x86_64):

glibc-2.22-62.3.4
glibc-debuginfo-2.22-62.3.4
glibc-debugsource-2.22-62.3.4
glibc-locale-2.22-62.3.4
glibc-locale-debuginfo-2.22-62.3.4

- OpenStack Cloud Magnum Orchestration 7 (x86_64):

glibc-2.22-62.3.4
glibc-debuginfo-2.22-62.3.4
glibc-debugsource-2.22-62.3.4
glibc-locale-2.22-62.3.4
glibc-locale-debuginfo-2.22-62.3.4


References:

https://www.suse.com/security/cve/CVE-2017-1000408.html
https://www.suse.com/security/cve/CVE-2017-1000409.html
https://www.suse.com/security/cve/CVE-2017-15670.html
https://www.suse.com/security/cve/CVE-2017-15671.html
https://www.suse.com/security/cve/CVE-2017-15804.html
https://www.suse.com/security/cve/CVE-2017-16997.html
https://www.suse.com/security/cve/CVE-2018-1000001.html
https://bugzilla.suse.com/1051042
https://bugzilla.suse.com/1053188
https://bugzilla.suse.com/1063675
https://bugzilla.suse.com/1064569
https://bugzilla.suse.com/1064580
https://bugzilla.suse.com/1064583
https://bugzilla.suse.com/1070905
https://bugzilla.suse.com/1071319
https://bugzilla.suse.com/1073231
https://bugzilla.suse.com/1074293

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung