Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in p7zip
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in p7zip
ID: SUSE-SU-2018:0464-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Desktop 12-SP2, SUSE Linux Enterprise Server 12-SP2, SUSE Linux Enterprise Server for Raspberry Pi 12-SP2, SUSE Linux Enterprise Desktop 12-SP3, SUSE Linux Enterprise Server 12-SP3
Datum: Fr, 16. Februar 2018, 22:43
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-5996
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-17969
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-1372
Applikationen: p7zip

Originalnachricht

   SUSE Security Update: Security update for p7zip
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:0464-1
Rating: important
References: #1077724 #1077725 #1077978 #984650
Cross-References: CVE-2016-1372 CVE-2017-17969 CVE-2018-5996

Affected Products:
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2
SUSE Linux Enterprise Server 12-SP3
SUSE Linux Enterprise Server 12-SP2
SUSE Linux Enterprise Desktop 12-SP3
SUSE Linux Enterprise Desktop 12-SP2
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:



This update for p7zip fixes the following issues:

Security issues fixed:

- CVE-2016-1372: Fixed multiple vulnerabilities when processing crafted 7z
files (bsc#984650)
- CVE-2017-17969: Fixed a heap-based buffer overflow in a shrink decoder
(bsc#1077725)
- CVE-2018-5996: Fixed memory corruption in RAR decompression. The
complete RAR decoder was removed as it also has license issues
(bsc#1077724 bsc#1077978)


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:

zypper in -t patch SUSE-SLE-RPI-12-SP2-2018-319=1

- SUSE Linux Enterprise Server 12-SP3:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-319=1

- SUSE Linux Enterprise Server 12-SP2:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-2018-319=1

- SUSE Linux Enterprise Desktop 12-SP3:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-319=1

- SUSE Linux Enterprise Desktop 12-SP2:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP2-2018-319=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (aarch64):

p7zip-9.20.1-7.3.1
p7zip-debuginfo-9.20.1-7.3.1
p7zip-debugsource-9.20.1-7.3.1

- SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):

p7zip-9.20.1-7.3.1
p7zip-debuginfo-9.20.1-7.3.1
p7zip-debugsource-9.20.1-7.3.1

- SUSE Linux Enterprise Server 12-SP2 (aarch64 ppc64le s390x x86_64):

p7zip-9.20.1-7.3.1
p7zip-debuginfo-9.20.1-7.3.1
p7zip-debugsource-9.20.1-7.3.1

- SUSE Linux Enterprise Desktop 12-SP3 (x86_64):

p7zip-9.20.1-7.3.1
p7zip-debuginfo-9.20.1-7.3.1
p7zip-debugsource-9.20.1-7.3.1

- SUSE Linux Enterprise Desktop 12-SP2 (x86_64):

p7zip-9.20.1-7.3.1
p7zip-debuginfo-9.20.1-7.3.1
p7zip-debugsource-9.20.1-7.3.1


References:

https://www.suse.com/security/cve/CVE-2016-1372.html
https://www.suse.com/security/cve/CVE-2017-17969.html
https://www.suse.com/security/cve/CVE-2018-5996.html
https://bugzilla.suse.com/1077724
https://bugzilla.suse.com/1077725
https://bugzilla.suse.com/1077978
https://bugzilla.suse.com/984650

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung